Deepin NVidia Driver 418.56

deepin
#1

Olá pessoal,

Já fazia um tempo que não criava nenhum tutorial em site algum :smile:, então resolvi vir até aqui compartilhar algo em que eu estava trabalhando nesta última semana. :wink:

Comecei a usar o Linux Deepin a pouco tempo e como eu uso placa de vídeo NVidia resolvi instalar o mesmo, porém, percebi que não há drivers com versões maiores que 390.XX no repositório deles e como o Deepin é agora baseado no Debian, decidi compilar na mão o Driver NVidia 418.56 usando o source do Debian Stable + Backports, pois é lá que tem o driver que eu precisava.
Feito isto e também depois de vários testes incluindo o repositório local que criei pra poder usar no meu próprio sistema para ver se funciona corretamente com o apt e se o Driver também funciona de forma estável e ainda notificando o time Debian de um simples BUG achado e que já foi corrigido e vendo que está tudo OK e estável, decidi montar meu próprio repositório online para poder compartilhar.

Como não consegui usar o Launchpad, achei outra maneira de compartilhar, criei um repositório no meu próprio Github

Clique aqui Vá até a minha página do repositório Deepin NVidia

Configurei a página com instruções tanto em inglês quanto em português para uma fácil configuração do meu repositório.

Qualquer dúvida, relato de BUG ou informações relevantes, podem me contatar.
Porém, quando for lançado no repositório oficial do Deepin, recomendo usar o mesmo.
Notei que recentemente no repositório SID já foi lançado a versão 418.74, porém, acho mais seguro compilar apenas quando fosse para o repositório Stable+Backports novamente já que o Deepin presa pela estabilidade.

Ps.: Quem traduziu o texto da minha página para o Inglês foi o @Dio, pois sou meio fraco em inglês.
É… Tenho que fazer um curso de inglês, senão to perdido :rofl:

Até mais pessoal :+1:

7 Likes
#2

Sou avançado em inglês desde 9 anos, posso contar contigo. Também sei alemão, espanhol, francês, italiano e neerlandês. Estou a estudar basco, catalão, georgiano, grego, romeno, russo e ucraniano.

4 Likes
#3

Tu deve ser bem inteligente, pra decorar uma língua só já é difícil, imagina tudo isso. Claro, pra quem é leigo em línguas igual eu é difícil mesmo.
É bom saber que posso contar com a ajuda de mais uma pessoa, enquanto aprendo também :+1:

1 Like
#4

Parabéns @elppans, por mais pessoas com essas atitudes!

1 Like
#5

Valeu, se quiser testar fique a vontade, se achar algum BUG relate pra eu enviar pro time Debian ou verificar se já tem algum relato do mesmo lá

1 Like
#6

Eu tenho uma dúvida, ele funciona em notebook híbrido? kkkk digo isto porque eu tenho um boot com Ubuntu + DDE porque eu não consigo de forma alguma instalar driver da Nvidia (nem prime) no meu notebook, caso for para testar vou fazer final de semana com todo prazer, adoro o Deepin, mas infelizmente esse contratempo me deixou sem opções a não ser Ubuntu e derivados (19.04)

#7

Já estou compatilhando com a comunidade no Telegram!

2 Likes
#8

Opa, desculpe a demora, eu peguei uma bucha no trabalho aqui pra resolver. Levou o dia inteiro mas resolvi… Hahaha :rofl:
Sobre a dúvida, infelizmente não tenho notebook, então não pude testar. Mas se quiser testar, vou ficar agradecido pela ajuda :wink::+1:

#9

Valeu amigo, já é de grande ajuda tanto pra mim quanto para a comunidade Linux Deepin.
Qualquer tipo de ato já é um grande passo, é o que faz a comunidade Linux crescer :wink::+1:

1 Like
#10

Por hora somente Ubuntu e as suas flavours ou o Mint ou Pop!_OS.

1 Like
#11

Não entendi, somente eles o que? Que suporta algo ou que são suas Distros ou sei lá

#12

Na dúvida, teste!

Nativamente o Deepin está com um driver antigo da nvidia… Mas irá funcionar normalmente. Se precisar da útima versão, terá que atualizar manualmente.

1 Like
#13

Acho que ele se refere a drivers atualizados.

1 Like
#14

O que quer dizer que, por falta de drivers oficial, não custa nada testar o que tá disponível mesmo que não oficial.
Agora entendi :thinking:

#15

Q somente vão ter suporte satisfatório. E os drivers que são entregues no Deepin são oficiais, só que “velhos”.

1 Like
#16

O que compilei também são oficiais. Oficiais do source do Debian :rofl:
Compilação pura