[RESOLVIDO] Ajuda com "held broken packages" no Linux Mint 19.1 (Cinnamon)

linux-mint
#1

Boas, galere.

Decidi começar a utilizar alguma distro e julguei que deveria ir de LM. Fiz uma instalação do Linux Mint 19.1 (cinnamon) no Dell inspiron 3443, em modo UEFI com secure boot ativado, normalmente.

Este laptop possui chips gráficos híbridos (intel e nvidia), sendo eles: Intel HD Graphics 5500 e uma geforce 820M.

Decidi instalar o driver da nvidia. Baixei o driver nvidia-driver-390 (sudo apt install nvidia-driver-390). Instalei, coloquei o nouveau na blacklist. Não subiu o xorg na reinicialização, loguei pelo tty e (em /etc/modprobe.d) vi que o arquivo blacklist-framebuffer.conf estava com uma linha dando block no nvidiafb. Comentei e subiu normalmente.

Porém], no site da nvidia, vi que esta minha plaquinha suporta drivers >= 410. Decidi att o driver até descobrir que teria de compilar. Não quis fazer isso porque não sei (comecei hoje!). Então, vi no blog do dio que tem o ppa. Adicionei o ppa:graphics-drivers/ppa (pelo software sources do update manager do mint). Tickei os duas opções que apareceram e fui ver se o mint acharia updates.

Ele achou a versão 390 (que eu ja tinha instalado pelo terminal). Pensei “Ah, vou instalar de novo. Talvez ele precise para reconhecer”. Instalei, reiniciei, tudo certo. Porém, quando fui buscar por mais atualizações, vi que não achou nada (isso pela interface gráfica). Fui no terminal, procurei e há o driver 410. Tentei instalar e segue o erro que recebo:

sudo apt install nvidia-driver-410

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-driver-410 : Depends: xserver-xorg-video-nvidia-410 (= 410.78-0ubuntu1~gpu18.04.1) but it is not going to be installed
                     Depends: libnvidia-cfg1-410 (= 410.78-0ubuntu1~gpu18.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Com certeza, foi essa minha brincadeira.

As dúvidas são:

  1. consigo instalar um drive mais recente (no caso, o 410 mesmo)?;
  2. Como resolvo esses problemas de pacotes que, de algum modo, estão presos e não posso fazer nada com eles?

===== O QUE JÁ TENTEI =====

dpkg --configure -a (não fez nada)
sudo apt-get install -f (não fez nada)

Depois de rodar estes dois comandos tentei o sudo apt install nvidia-driver-410 e o erro ainda persistiu.

Caso seja relevante, esta é a saída o inxi -G

inxi -G

Graphics:
  Device-1: Intel HD Graphics 5500 driver: i915 v: kernel 
  Device-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT 
  620M/625M/630M/720M] 
  driver: nvidiafb v: kernel 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2) 
  v: 4.5 Mesa 18.2.2 

E essa do sources.list:

cat /etc/apt/sources.list

#deb cdrom:[Linux Mint 19.1 _Tessa_ - Release amd64 20181217]/ bionic contrib main non-free (sim, só isso)

E essa do official-package-repositories.list:

cat official-package-repositories.list

    # Do not edit this file manually, use Software Sources instead.

    deb http://packages.linuxmint.com tessa main upstream import backport #id:linuxmint_main

    deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
    deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
    deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse

    deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
    deb http://archive.canonical.com/ubuntu/ bionic partner

E essa do graphics-drivers-ppa-bionic.list:

cat graphics-drivers-ppa-bionic.list

deb http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic main
# 
deb-src http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic main

Bom, espero que esteja servido de informações e detalhes acerca do que fiz. Caso precisam de mais alguma coisa, basta informar. Não quero resposta pronta. Não ligo nada de ler documentação (pode mandar conteúdo em inglês) - sou programador, então faz parte do leque de must-do.

Desde já, agradeço a todos! Valeu

0 Likes

#2

O driver mais atual é o 415, mas é difícil saber porque o seu apt está com esses pacotes travados pra instalar, você deve ter algum programa instalado que é incompatível com eles.

1 Like

#3

o erro é o seguinte ele precisa atualizar alguns componentes pra rodar o driver nvidia mas algum programa seu precisa da versão antiga do pacote que o nvidia precisa atualizado pra funcionar entendeu? isso se chama hold packages

pra solucionar faça

dpkg --get-selections | grep hold

isso vai listar os pacotes “segurados”

depois

sudo apt-mark unhold (nome do pacote) com todos que ele reclamar de hold,depois faça

sudo apt-get update (atualiza repositorio)
sudo apt-get upgrade (atualiza todos os pacotes)

tente instalar novamente e veja que ele vai remover algum pacote pra instalar esse da nvidia =D

1 Like

#4

Man, tenho um vídeo no canal ensinando como instalar Linux (Ubuntu e Mint) em notebooks híbridos, creio que vá te ajudar. https://youtu.be/J_XkH15on74

2 Likes

#5

Agradeço pelas respostas, antes de tudo!

Este é o ponto. O que fazer? kkkk

@pinguimfu, eu já tinha feito algo parecido que não havia retornado nada. Mesmo assim, tentei e nada é retornado. O segundo comando depende da resposta do primeiro, então nem executei e os outros dois também já havia feito e nada, mesmo assim, tentei novamente, e nada de novo.

Fala, meu querido! Seu canal é bem legal. Sim, eu já havia visto mas, infelizmente, o Mint já estava instalado quando cheguei nele. A não ser que ele sirva também pro sistema já instalado. Me avisa aí se der! De todo jeito, o módulo do nouveau já está na blacklist.

De todo jeito, como já estava instalado, segui os procedimentos do canal do Mateus (Linux 4fasters), como havia dito no primeiro post.

Deu certo, instalou, mas instalou o 390. Fora isso, o driver manager continua não mostrando nada quando carrego. Além disso, como se não bastasse, baixei o nvidia-settings e ele mostra apenas isso que vocês veem na imagem.

nvidia-x-server-settings

Digo “apenas isso”, porque tem bem mais informações nos de outras pessoas que vi no youtube.

Tudo isso é engraçado. O prime-select query mostra nvidia, assim como o nvidia-settings, mas as coisas estão estranhas.

Vou desinstalar o driver atual e tentar atualizar. Foi a única coisa que não tentei ainda.

Não quero reinstalar o OS. Quero pegar o feeling de troubleshooting, a não ser que seja avançado demais ou que “não tenha jeito” mesmo.

Anyway, muito obrigado, galera!

1 Like

#6

ta com cara que o driver não carregou no kernel,ou vc ta com uma versão do painel nvidia diferente do driver e por isso essa diferença

1 Like

#7

Se eu fosse você eu instalava os repos oficiais da Nvidia pro ubuntu e baixava logo o driver mais novo…

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update

depois disso só instalar o nvidia novamente

1 Like

#8

Essa foi rápida!

Então, o lsmod retorna um bando de coisa da nvidia. Teoricamente está carregando, né? Ou não?

Saída do lsmod pra nvidia

lsmod | grep -i nvidia
nvidiafb               49152  0
vgastate               24576  1 nvidiafb
fb_ddc                 16384  1 nvidiafb
i2c_algo_bit           16384  3 nvidiafb,i915,nouveau

Saída do lsmod pra nouveau

lsmod | grep -i nouveau
nouveau              1716224  0
ttm                   106496  1 nouveau
mxm_wmi                16384  1 nouveau
wmi                    24576  6 dell_wmi,wmi_bmof,dell_smbios,dell_wmi_descriptor,mxm_wmi,nouveau
i2c_algo_bit           16384  3 nvidiafb,i915,nouveau
drm_kms_helper        172032  2 i915,nouveau
drm                   401408  8 drm_kms_helper,i915,ttm,nouveau
video                  45056  4 dell_wmi,dell_laptop,i915,nouveau

mmmm… olha só. Teoricamente está subindo os 2!
texto em negritoBom a saída para blacklist de nouveau tá dando isso

grep -i nouveau *
nvidia-driver.conf:blacklist nouveau
nvidia-driver.conf:blacklist lbm-nouveau
nvidia-driver.conf:alias nouveau off
nvidia-driver.conf:alias lbm-nouveau off
nvidia-graphics-drivers.conf:blacklist nouveau
nvidia-graphics-drivers.conf:blacklist lbm-nouveau
nvidia-graphics-drivers.conf:alias nouveau off
nvidia-graphics-drivers.conf:alias lbm-nouveau off

O arquivo nvidia-driver.conf foi eu que criei porque quando instalei o driver pelo terminal, ontem, nada havia sido criado. Porém, depois adicionei o ppa e instalei pela interface gráfica. Deve ser por isso que apareceu o arquivo que deveria ter aparecido. Deve ter algum conflito aqui. Engraçado é que dei alguns reboots ontem e não tinha nada disso. Mostrou apenas hoje. Bom, vou desinstalar todos os driver da nvidia refazer os processos.

Adorando o desafio, galera! Brigadão pela atenção e ajuda! Stay tunned I’ll be here ASAP!

0 Likes

#9

tenta dar blacklist no driver free (nouveau) que deve ser isso

sudo bash -c “echo blacklist nouveau > /etc/modprobe.d/blacklist-nvidia-nouveau.conf”

sudo bash -c “echo options nouveau modeset=0 >> /etc/modprobe.d/blacklist-nvidia-nouveau.conf”

e depois reinicie

1 Like

#10

Já desinstalei tudo referente à nvidia. Agora, só pra tirar uma dúvida, os pacotes de drivers com :i386 são 32bits certo? Então devo instalar os pacotes SEM o :i386 (porque meu processador é 64bits). Tá certo isso?

0 Likes

#11

Vlww pelo apoio man. Faz o seguinte, faça um bkp e refaça a instalação do jeito que ensino no vídeo, é mais garantido de dar certo!!!:v:

2 Likes

#12

É, acabei tendo que fazer isso, mas!

Coloco o pendrive, faço o boot normal pelo pendrive e, na tela do grub, quando aperto tab, nao aparecem as opções que aparecem no seu vídeo. Na real, não aparece nada.

Será que isso é por conta do UEFI e secure boot?

0 Likes

#14

Cara, o que faltou aí foi você ativar o DRM, no Diolinux tem tutorial pra isso.

1 Like

#15

Pode ser, vc pode tentar sem o UEFI e dai é pra ir. Tenta tb com a tecla E.

1 Like

#16

@CanalOCaraDoTI

Ricardo, desculpa pela ignorada. Não foi intencional.
Depois eu vi que tava escrito na tela de instalação que a parada era a tal da tecla ‘e’. Mais um caso de RTFM! kkkk

Além disso, Ricardo, fiz do jeito que estava em seu vídeo, mas para mim não funcionou. O problema é que o driver manager do mint não mostra nada quando é carregado, então eu tenho que instalar pelo terminal, mesmo. Mas brigadão! Inclusive, acredito que vocês possam produzir conteúdo com essa minha saga aqui para ajudar pessoas. Digo vocês porque pode ser você, o Dio, ou qualquer pessoa que se importa em facilitar e resolver a vida da galera de maneira fácil.

@pinguimfu e @rauldipeas

Agradeço a atenção de vocês (principalmente o @pinguimfu), mas não era nada que foi discutido aqui.

TL;DR

  1. Rode este comando: lspci -vnn | grep '\''[030[02]\]'
    Se a saída tiver [0300] e [0302] em vermelho você tem um sistema nvidia optimus e deve continuar. Senão, talvez a solução não esteja aqui.

  2. Se o item anterior for verdadeiro e você tiver uma GeForce 820m é provável que apenas o driver 390 vá funcionar (então comece por ele);

  3. Se, depois da instalação e da reinicialização, a tela de login não aparecer (ficar tudo preto) aperte Ctrl+Alt+F1 (se estiver no laptop e não for, tenta a combinação anterior com a tecla Fn adicionada - Ctrl+Alt+Fn+F1). Loga com seu usuário e senha. Em seguida, rode o comando sudo dpkg-reconfigure lightdm (substitua lightdm pelo nome do seu display manager). Reinicialize;

  4. Se foi, e você consegue logar normalmente, é isso. Se você nem vê a tela de login ou se o login fica em loop, continue lendo;

  5. Se você não vê a tela de login: siga os passos deste link de acordo com o seu display manager;

  6. Se o login fica em loop: aperte Ctrl+Alt+F1 (se estiver no laptop e não for, tenta a combinação anterior com a tecla Fn adicionada - Ctrl+Alt+Fn+F1). Loga com seu usuário e senha. Renomeie o arquivo .Xauthority para qualquer nome (não o apague). Pressione Ctrl+Alt+F7 (ou a variação com o Fn) e logue com seus dados normalmente. Deve funcionar;

  7. Se funcionar pode remover o arquivo que você renomeou (está na sua pasta home). Caso não tenha funcionado, aí vai ter que procurar;

VERSÃO ESTENDIDA E SEM CORTES

Antes de tudo, quero dizer pra quem está lendo e tem a mesma config que eu que por mais que o site da nvidia diga que o driver disponível pra GeForce 820m é o 410.93, eu não consegui fazer este driver funcionar. Eu tentei de tudo. Comecei instalando pelo ppa o pacote nvidia-driver-410. Ele instalou e (aparentemente) não reclamou de nada. Quando rebootei, a tela ficou toda preta. Tipo, o display desligava! O laptop não desligava mas o display sim.

Dei Ctrl+Alt+F1, loguei e verifiquei a pasta /etc/modprobe.d pra ver se tinha algum blacklist para o nouveau. Não tinha arquivo nenhum. Tentei criar mas sem sucesso. Em seguida, removi absolutamente tudo da nvidia e baixei o driver do site (um arquivo .run). Quando fui instalar, durante o processo, saiu uma mensagem no console dizendo que aquele driver não era compatível, que o driver seria instalado mas que ele ignoraria a placa (ou seja, não iria funcionar) e que o driver que eu deveria usar era o da família 390. Percebam a inconsistência da nvidia em relação aos drivers suportados. Eu usei a própria ferramenta DELES pra ver qual driver deveria usar e durante a instalação sou notificado que aquele driver não serve. Absurdo! (peço desculpas, por não documentar estas mensagens e postar aqui)

Fiquei como? Mas enfim…

Mais uma vez, removi TUDO da nvidia, baixei o pacote nvidia-driver-390 e instalei. Fiz o reboot. O mesmo sintoma da tela desligar. Novamente, fiz o Ctr+Alt+F1 e loguei. Verifiquei na /etc/modprobe.d e desta vez havia um arquivo que botava o driver nouveau na blacklist. Bom sinal! Mas como resolver a parada da tela?

Bom, saí lendo tudo de fórum gringo, fazendo as coisas e nada. Reinstalei lightdm, reinstalei xorg e nada. Na real, tive que reinstalar o Mint porque depois que reinstalei estes dois últimos nem da splash do mint eu saía.

Cheguei a postar no fórum do Linux Mint e ninguém pôde me ajudar lá também, infelizmente.
Porém, foi no fórum da nvidia que consegui resolver o meu problema.

Lá me foi dito que o problema era que o comando que habilita a saída do prime não estava presente no lightdm.

Foi dito para eu fazer sudo dpkg-reconfigure lightdm e rebootar pra ver se ia. Se não fosse, teria que fazer manualmente. Adivinhem… CLARO QUE NÃO FOI! kkkkkkk

Fui e fiz manualmente como diz na wiki do Arch que vocês podem conferir aqui.

DETALHE: sigam os passos de acordo com o Display Manager (DM) que vocês utilizam. Outra coisa, neste link explica também o que é o tal do nvidia Optimus.

Fui, fiz isso e… [musiquinha do baú do Zelda] funcionou! Porém…

A tela não ficava mais preta e a GUI subia, mas quando logava, o SO me redirecionava pra tela de login novamente e ficava nesse looping. Daí, pesquisei como sair disso e vi que renomeando o arquivo que fica em .Xauthority que fica na home (~) isso parava de acontecer.

Bom, fiz isso e funcionou!

Loguei normalmente, rebootei pra me assegurar e depois apaguei o arquivo antigo que tinha sido renomeado.

OBSERVAÇÕES E FONTES

Pra ver se seu sistema possui a tecnologia nvidia optimus execute o comando lspci -vnn | grep '\''[030[02]\]' Se houverem duas saídas em vermelho ([0300] e [0302]) então você foi premiado com o optimus…

Caso haja o arquivo xorg.conf em /etc/X11 E você tenha optimus APAGUE O ARQUIVO. Foi-me dito que, em dispositivos optimus, esse arquivo só atrapalha o sistema;

Caso alguém queira ver a saga nos fóruns, pode ver a thread no fórum do linux mint e, caso se interesse, pode ver no fórum da nvidia as well (ambos em inglês).

Recomendo que, caso tenham problemas relacionados à nvidia, procurem diretamente no fórum dedicado ao linux da empresa. Na Primeira resposta já resolveram meu problema! (em inglês)

A informação sobre como detectar se seu sistema possui optimus, pode ser vista no site do reddit (em inglês).

FINALIZANDO…

Meu problema agora é que o SO tá demorando 1.25m desde ligar o laptop, botar a senha e carregar o desktop, o que é MUITO tempo! Mesmo se você tirar 4s assumindo como o tempo que eu digito a senha (que é tempo demais, inclusive) ainda assim é bem ruim. Mas, isso é outro problema e que vocês até podem me ajudar a resolver, caso vocês saibam algo pra otimizar o boot do Linux. Mas para isso abrirei outra thread.

Nos vemos na próxima!

0 Likes

Linux não Roda em Notebooks novos ?!
#17

Parabens não só pela persistencia mas tambem pela SOLUÇÃO que sera muito util pra mais gente

1 Like

#18

Fala, @pinguimfu!

Pô, brigadão! Tô fazendo isso pra provar pra mim mesmo que consigo mexer no Linux (usei windows minha vida toda!). Tô bem feliz com o resultado porque tô fazendo coisas já meio “avançadas” em menos de uma semana.

Prova mais do que cabal que quem quer consegue e que nem todo usuário windows é burro! kkkkkkk

Valeu, man!

1 Like

#19

Acontece, serve como aprendizado kkkkk E só por curiosidade, vc ja tentou o Ubuntu??? Digo isso pq to usando agora ele na minha hibrida e ele ta se saindo melhor q o Mint. E cara, essa do ppa nao funcionar foi nova pra mim kkkkk seriao !!! Usar os arquivos do site da NVIDIA era a ultima coisa q eu ia lhe aconselhar kkkkk Mas fica como registro hehe E outra coisa a sua geforce é GT ou GTX???

1 Like

#20

O engraçado é que, se eu não usasse o driver do site, eu não ia ver a saída falando que o driver ia ser ignorado. Assim, eu nem testei depois que eu arrumei a parada do lightdm, mas a saída do driver diz que ele ignoraria minha placa. Além disso, quando instalei o driver 410, o arquivo que põe o nouveau na blacklist nem é gerado no /etc/modprobe.d, então talvez nem funfe mesmo.

Quanto ao Ubuntu, não tentei. A verdade é que decidi ir pelo Mint porque parece ser a distro mais indicada pra novatos (mesmo sendo necessário instalar o driver de vídeo pelo terminal, no meu caso).

Depois eu testo com o 410 novamente.

Mas é isso aí! Valeuzera!

1 Like

#21

Tenta o Ubuntu 18.04.1 (acho q vc nao vai sentir tanta dificuldade, ele é bem sussa), junto com o ppa la do video e tenta por o driver 415.27, q é o mais novo. E no meu note, eu tive q deixar UEFI e sem Security Boot, se eu deixasse o legacy ele ficava “maluco” kkkkkk Se vc for ver la no meu canal, na aba comunidade, eu fiz uma modificação no Ubuntu q a galera curtiu e to bolando um video ou live pra mostrar, entao se ficar a dica, tenta o UBuntu (se vc nao gosta do GNome, tem o XFCE, MATE, KDE, Bundgie [ q eu lembre kkkk]) talvez de bom ai man. Quando tiver resultados da um update aki mesmo !!! (e acho q a lentidadão no seu boot é usar o driver 410).

1 Like