Redução de ruídos de microfone em reuniões ao vivo

Pessoal, boa tarde!

Uso o Pop_OS 21.1 em meu notebook e comprei um microfone pra melhorar meu áudio nas reuniões e aulas.

Comprei um Fifine 683. Ele é um microfone por USB, tem botão mute, entrada para fone de ouvido e controle de ganho.

Minha dúvida: quando o microfone não está no mudo ou com ganho muito baixo, eu ouço um som ambiente. Por mais silêncio que esteja. É baixo, mas é perceptível e tal.

Tentei utilizar o programa cadmus e um outro que esqueci o nome, mas não notei diferença nenhuma. Tem algum outro programa pra ajudar nisso?

Tentei este tutorial, mas não deu certo Ative o cancelamento de eco e ruído do microfone no Linux - #7 por FireMax. Não aparece o novo microfone.

Não entendo absolutamente nada de microfone, se alguém tiver algum conteúdo massa sobre isso, vou gostar muito!

Valeu gente!

Edita -----

Vou por algumas informações do notebook e do sistema:

Resumo
System:
  Kernel: 5.15.11-76051511-generic x86_64 bits: 64 Desktop: GNOME 40.5 
  Distro: Pop!_OS 21.10 
Machine:
  Type: Laptop System: Acer product: Aspire E5-571 v: V1.26 serial: <filter> 
  Mobo: Acer model: EA50_HB v: V1.26 serial: <filter> UEFI: Insyde v: 1.26 
  date: 12/18/2014 
Battery:
  ID-1: BAT1 charge: 23.5 Wh (100.0%) condition: 23.5/55.9 Wh (42.0%) 
CPU:
  Info: Dual Core model: Intel Core i3-4005U bits: 64 type: MT MCP cache: 
  L2: 3 MiB 
  Speed: 798 MHz min/max: 800/1700 MHz Core speeds (MHz): 1: 798 2: 798 
  3: 798 4: 798 
Graphics:
  Device-1: Intel Haswell-ULT Integrated Graphics driver: i915 v: kernel 
  Device-2: Chicony HD WebCam type: USB driver: uvcvideo 
  Display: x11 server: X.Org 1.20.13 driver: loaded: modesetting 
  unloaded: fbdev,vesa resolution: 1: 1366x768~60Hz 2: 1360x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) 
  v: 4.5 Mesa 21.2.2 
Audio:
  Device-1: Intel Haswell-ULT HD Audio driver: snd_hda_intel 
  Device-2: Intel 8 Series HD Audio driver: snd_hda_intel 
  Device-3: FIFINE 683 Microphone FIFINE 683 Microphone type: USB 
  driver: snd-usb-audio 
  Sound Server-1: ALSA v: k5.15.11-76051511-generic running: yes 
  Sound Server-2: PulseAudio v: 15.0 running: yes 
  Sound Server-3: PipeWire v: 0.3.32 running: yes 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 
  IF: enp1s0f1 state: down mac: <filter> 
  Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  driver: ath9k 
  IF: wlp2s0 state: up mac: <filter> 
  IF-ID-1: docker0 state: down mac: <filter> 
Bluetooth:
  Device-1: Lite-On Atheros AR3012 Bluetooth type: USB driver: btusb 
  Report: hciconfig ID: hci0 rfk-id: 3 state: down 
  bt-service: enabled,running rfk-block: hardware: no software: yes 
  address: <filter> 
Drives:
  Local Storage: total: 223.57 GiB used: 133.81 GiB (59.9%) 
  ID-1: /dev/sda vendor: Kingston model: SA400S37240G size: 223.57 GiB 
Partition:
  ID-1: / size: 47.86 GiB used: 24.17 GiB (50.5%) fs: ext4 dev: /dev/sda2 
  ID-2: /boot/efi size: 486 MiB used: 159.7 MiB (32.9%) fs: vfat 
  dev: /dev/sda1 
  ID-3: /home size: 166.71 GiB used: 109.48 GiB (65.7%) fs: ext4 
  dev: /dev/sda4 
Swap:
  ID-1: swap-1 type: partition size: 3.83 GiB used: 1.8 MiB (0.0%) 
  dev: /dev/dm-0 
Sensors:
  System Temperatures: cpu: 53.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 267 Uptime: 3h 26m Memory: 7.69 GiB used: 5.35 GiB (69.6%) 
  Shell: Bash inxi: 3.3.06 

Olá @rxtheodoro tudo bem contigo?

Pode mandar uma amostra de áudio onde você consegue identificar esse “ruído”?
Talvez o que você esteja precisando seja melhorar a absorção acústica do local onde você faz essas gravações.

:vulcan_salute:

2 curtidas

Já tentou com o NoiseTorch?

2 curtidas

Vamos ver se sou bem sucedido com essas dicas, pois eu tenho um microfone B-max, BM-888 e simplesmente não tem como aproveitar o áudio gravado por ele, pois fica chiando o tempo todo.

1 curtida

https://www.vivaolinux.com.br/dica/Habilitando-supressao-de-ruido-no-PulseAudio

Eu encontrei essa dica na internet para a redução de ruídos no PulseAudio. Espero que funcione. Como não tenho esse problema com o microfone não fiz o teste dos comandos.

3 curtidas

Opa!

Desculpa a demora!

Gravei um vídeo rápido aqui!

Esse som ambiente que fica. Se ligar o removedor de ruídos do OBS já fica ótimo! Mas não sei fazer isso rolar ao vivo, no google.meet da vida.

Sobre o NoiseTorch, não ficou legal. Ela da umas cortadas quando falo, independente da porcentagem que eu colocar. Reduz o ruído. Mas da umas cortadas :frowning:

Sobre o link do vivaolinux, acho que foi o que melhor funcionou:

Desculpa não ter feito uma capa pra cada vídeo e tudo mais, não mexer com essas coisas, iria demorar mais ainda pra responder aqui haha Mas acho que daria um bom vídeo para o youtube haha

1 curtida