Notebook Positivo N1250 sem som no Linux

Há uns dias ganhei um notebook da positivo do governo, um N1250.
Hoje instalei o Arch Linux nele, mas não está saindo som algum.
Mesmo reconhecendo o negócio de som, não sai nenhum.

Screenshot_2022-02-02_13-02-19

Mesma questão do tópico:

Somente no Linux, não consigo reproduzir som no meu notebook

inxi -F e manda o output, por favor…

1 curtida
System:
  Host: archlinux Kernel: 5.16.4-arch1-1 x86_64 bits: 64 Desktop: Xfce 4.16.0
    Distro: Arch Linux
Machine:
  Type: Laptop System: Positivo Tecnologia SA product: N1250 v: N/A
    serial: <superuser required>
  Mobo: Positivo Tecnologia SA model: N14DP7-V2 v: 11175018
    serial: <superuser required> UEFI: N/A v: 1.14.X date: 08/24/2021
Battery:
  ID-1: BAT0 charge: 27.0 Wh (73.0%) condition: 37.0/37.0 Wh (100.0%)
CPU:
  Info: dual core model: Intel Celeron N4020 bits: 64 type: MCP cache:
    L2: 4 MiB
  Speed (MHz): avg: 2291 min/max: 800/2800 cores: 1: 2397 2: 2185
Graphics:
  Device-1: Intel GeminiLake [UHD Graphics 600] driver: i915 v: kernel
  Device-2: SunplusIT MTD camera type: USB driver: snd-usb-audio,uvcvideo
  Display: x11 server: X.org 1.21.1.3 driver: loaded: modesetting
    resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio
    driver: sof-audio-pci-intel-apl
  Device-2: SunplusIT MTD camera type: USB driver: snd-usb-audio,uvcvideo
  Sound Server-1: ALSA v: k5.16.4-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: yes
Network:
  Message: No device data found.
  IF-ID-1: wlan0 state: up mac: 20:57:9e:4a:56:27
Bluetooth:
  Device-1: Realtek 802.11n WLAN Adapter type: USB driver: btusb,rtl8xxxu
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: not found
    rfk-block: hardware: no software: no address: see --recommends
Drives:
  Local Storage: total: 119.24 GiB used: 11.62 GiB (9.7%)
  ID-1: /dev/sda model: SATA CVB-CD128 size: 119.24 GiB
Partition:
  ID-1: / size: 17.69 GiB used: 5.18 GiB (29.3%) fs: ext4 dev: /dev/sda2
  ID-2: /boot size: 483 MiB used: 55.9 MiB (11.6%) fs: vfat dev: /dev/sda1
  ID-3: /home size: 98.02 GiB used: 6.38 GiB (6.5%) fs: ext4 dev: /dev/sda3
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 61.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 161 Uptime: 24m Memory: 3.65 GiB used: 1.98 GiB (54.2%)
  Shell: Bash inxi: 3.3.12

Tá aê

está usando pipewire? tenho um positivo e um lenovo onde os speakers só funcionam (sem nenhum tweak) com pipewire…

@fastos2016, esse modelo da Positivo tem histórico de problemas quanto à saída de som sob distros variadas. Minha curiosidade era ver se os sistemas rolling release e bleeding edge caberiam nesse computador sem problemas. Pelo jeito, não.

putz kkk
então seria melhor eu voltar pro windows e usar ele cm o wsl?

Não diria melhor, porém mais fácil. Eu recomendo que teste com o Kernel 5.10 LTS e vá testando outras distros, em modo live e veja se alguma funciona. Positivo é uma bomba…
Ah, e o Arch não tem oficialmente no WSL, apenas SLE, openSUSE, Debian, Ubuntu e Alpine

Ele parece que está em mute

Tenta

pamixer -u

1 curtida

Sim sim.
Acho que se eu voltar pro WSL vou ficar com o Ubuntu ou o ArchWSL msm.

Recomendo ler

https://wiki.archlinux.org/title/PulseAudio/Troubleshooting#Muted_audio_device

Já tinha lido antes…
Mas agora tentei de novo, quando eu trocava os negócio de MM pra OO as vezes fazia um som.
Queria saber o porque do OS conseguir identificar o hardware de som, mas não conseguir fazer ele transmitir nada.

Pode ser por vários motivos

https://wiki.archlinux.org/title/PulseAudio/Troubleshooting

Na página te informa vários motivos
Exemplos

https://wiki.archlinux.org/title/Advanced_Linux_Sound_Architecture#Disabling_auto_mute_on_startup

Normalmente você salva a configuração, mas pode acontecer de ter problemas

Isso depende de pc e suas configurações

MM é mudo

OO é com som.

Achei isso
O problema que o cara teve é praticamente o mesmo que tenho, só que descrito de uma melhor forma.

Com a imagem que você mandou

Screenshot_2022-02-02_13-02-19

Clica no cadeado amarelo
Depois clica no ícone de som ao lado , e por fim, no cadeado amarelo.

Veja se resolve

Não li texto enviado

1 curtida

Nope…
Testei umas coisas, agora tá diferente:
Screenshot_2022-02-02_21-39-20

Engraçado que o som está com X.

Vc clicou em cima do ícone do som. Que na imagem está sem clicar.

Tentou ?

pamixer -u

Graças a você ter colocado esse link, consegui solucionar o problema tbm fui um dos premiados com a benção desse positivo pelo gov do ceará kkkkkk. Pesquisando pela placa de som contida no post do lore.kernel (ES8336), encontrei um método:

PS: Eu sou bem leigo, não tenho certeza se isso pode futuramente trazer algum problema quando for atualizar o kernel do S.O, mas, a curto prazo, resolve pelo menos o problema de áudio e fone

Passo 1: Se tiver recém-formatado, dê um apt update e depois um upgrade pra atualizar tudo direitin e evitar erros

Passo 2: Clone com o git esse repositório.

Passo 3: Instale o .deb da pasta raiz (firmware-sof-signed_1.7-1_all.deb)

Passo 4: Após isso, vá na pasta kernel e instale cada um dos .deb lá

Passo 5: Volte, e agora vá na pasta tplg e copie todos os arquivos de lá para a pasta raiz (custom-kernel)

Passo 6: Entre como administrador com o sudo su, dê permissão para executar no arquivo make.sh com o chmod +x , e então execute-o ./make.sh

Passo 7: Após o processo ter terminado, reinicie o seu PC, e provavelmente o áudio estará funcionando.

Eu testei esse processo nas distros Ubuntu e Linux Mint, e em ambas, funcionou muito bem. Tenta aí com o Arch, espero seu retorno…

6 curtidas

Deu certo, Deus abençoe vocês :slight_smile:

Nem tentei no Arch linux, por causa dos .deb.
Até dá pra usar umas gambiarra pra fazer funcionar, mas como era algo sensível, achei melhor ir direto pra uma deviração de Debian, o ZorinOS.

Se alguém estiver com problemas com o kernel.zip, é só dar os seguintes comandos:
zip -F kernel.zip --out ker.zip
unzip ker.zip
ou algo assim

Ah
Também há um caminho mais simples, que é seguindo esses passos

Bem, se a gente tiver problemas com alguma atualização esse kernel tamo aí dnv.
Depois vou tentar fazer aquelas teclas especiais funcionarem kkkk.

3 curtidas

Só para adicionar informação

O firmware está no repositório oficial extra do arch

https://archlinux.org/packages/extra/x86_64/sof-firmware/

Acho que é só instalar e pronto

1 curtida