Linux Mint 21.2 "Victoria" Sem Áudio

Boa tarde a todos, estou tendo esse problema com(muito provavelmente) todos os Linux que instalo no meu PC, antes desse Linux Mint eu estava com a última versão do Debian e essa é a página em que eu tentei concertar ele: Debian 12 Sem Áudio . Infelizmente ainda não possuo informações sobre o defeito aqui no Mint, a menos que as soluções do Debian sejam as mesmas para ele, nesse caso as informações do link acima são até onde eu cheguei.

Você usa Intel?

Sim, Intel Celeron J1800 ‎2,41 GHz.

Dê o comando apt list firmware-sof-signed e me diga se o pacote está instalado ou não.

1 curtida

Parece que sim, essas foram as respostas do terminal:


yllasjofn@Codee:~$ apt list firmware-sof-signed
Listing... Pronto
firmware-sof-signed/jammy-updates,jammy-updates,now 2.0-1ubuntu4.2 all [instalado]
N: There is 1 additional version. Please use the '-a' switch to see it
yllasjofn@Codee:~$ -a
-a: comando não encontrado
yllasjofn@Codee:~$

Mande o resultado do comando

inxi -SMA

Instale o inxi se ele não estiver instalado.

Esse é o resultado:

yllasjofn@Codee:~$ inxi -SMA
System:
  Host: Codee Kernel: 5.15.0-88-generic x86_64 bits: 64
    Desktop: Cinnamon 5.8.4 Distro: Linux Mint 21.2 Victoria
Machine:
  Type: Desktop Mobo: PCWARE model: IPX1800E2 v: 1.2
    serial: <superuser required> UEFI: American Megatrends v: 5.6.5
    date: 11/14/2018
Audio:
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio
    driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.15.0-88-generic running: yes
  Sound Server-2: PulseAudio v: 15.99.1 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes
yllasjofn@Codee:~$

Dê o comando

sudo xed /etc/modprobe.d/alsa-base.conf

No final do arquivo adicione a linha

options snd-hda-intel dmic_detect=0

Salve o arquivo e reinicie o computador.

Infelizmente não estou conseguindo rodar o primeiro comando, durante a instalação do Linux Mint, ele não pediu para eu colocar uma senha sudo, aí quando eu tento rodar o primeiro comando, ele pede uma senha sudo, mas ela sequer existe. Tentei também na primeira tentativa colocar a senha do usuário normal pra ver se funcionava e acabou abrindo uma página com a mensagem: Privilégios Elevados. Resposta do terminal a segunda tentativa:

yllasjofn@Codee:~$ sudo xed /etc/modprobe.d/alsa-base.conf
[sudo] senha para yllasjofn:      
Sinto muito, tente novamente.
[sudo] senha para yllasjofn:


** (xed:7534): WARNING **: 13:06:47.737: Set document metadata failed: Não há suporte à definição do atributo metadata::xed-position
yllasjofn@Codee:~$

Pode adicionar a linha lá, salvar o arquivo e reiniciar o computador.

O problema aí será que não é na sua placa de áudio, não?

Se o problema fosse a placa, o som não funcionava no Windows 10(Meu PC é Dual Boot)

Em qual localização dessa coisa eu adiciono a senha sudo?

Em canto nenhum. Você forneceu a senha no momento em que abriu o arquivo.

Ué, senha que usei foi minha senha de usuário normal, a criação da senha sudo não foi pedida durante a instalação. Mas acho que entendi, essa é a página que deve aparecer após eu executar o primeiro comando, então agora é só adicionar a linha no final do arquivo(O arquivo sendo a própria página).

O Linux Mint configura seu usuário normal para ter privilégios de root quando você usa o sudo.

Pronto, adicionei a linha no final do arquivo, salvei e reiniciei o PC. Infelizmente o som ainda não está funcionando.

Pode retirar aquela linha do arquivo lá.

Dê o comando alsamixer e mande print do terminal para nós.

Estou começando a desconfiar que trata-se de um bug no driver de áudio. Por que eu estou desconfiando disso? Bem, a Canonical tem algo chamado atualizações em fases, nas quais alguns pacotes, dependendo de sua importância e/ou do nível de alteração que sofreram, têm suas atualizações entregues aos usuários aos poucos. Dessa forma a Canonical consegue rastrear bugs antes que os pacotes sejam entregues a todos os usuários. Acabei de perceber que o pacote firmware-sof-signed está passando pelo processo de atualização em fases.

Um teste que você pode fazer é remover o pacote firmware-sof-signed para ver se com outro driver seu áudio funciona