Debian 12 Sem Áudio

Bom dia rapazeada, meu Debian 12 não possui áudio nenhum, alguém sabe como resolver esse problema? Até agora as informações que consegui sobre o meu problema são essas(Tudo no terminal):

Clique para ver a saída do terminal
pkexec bash
root@Codee:~# apt update && apt install pipewire
Atingido:1 http://security.debian.org/debian-security bookworm-security InRelease
Atingido:2 http://deb.debian.org/debian bookworm InRelease                     
Atingido:3 http://deb.debian.org/debian bookworm-updates InRelease             
Atingido:4 http://deb.debian.org/debian bookworm-proposed-updates InRelease    
Atingido:5 https://dl.google.com/linux/chrome/deb stable InRelease             
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto        
All packages are up to date.
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto        
pipewire is already the newest version (0.3.65-3).
pipewire configurado para instalar manualmente.
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
  libbotan-2-19 librnp0 libtspi1 linux-headers-6.1.0-10-amd64
  linux-headers-6.1.0-10-common linux-headers-6.1.0-11-amd64
  linux-headers-6.1.0-11-common linux-headers-6.1.0-9-amd64
  linux-headers-6.1.0-9-common linux-image-6.1.0-10-amd64
  linux-image-6.1.0-11-amd64 linux-image-6.1.0-9-amd64
Utilize 'apt autoremove' para os remover.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
6 pacotes não totalmente instalados ou removidos.
Depois desta operação, 0 B adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
Configurando initramfs-tools (0.142) ...
update-initramfs: deferring update (trigger activated)
Configurando linux-image-6.1.0-11-amd64 (6.1.38-4) ...
/etc/kernel/postinst.d/dkms:
dkms: running auto installation service for kernel 6.1.0-11-amd64.
dkms: autoinstall for kernel: 6.1.0-11-amd64.
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-6.1.0-11-amd64
raspi-firmware: missing /boot/firmware, did you forget to mount it?
run-parts: /etc/initramfs/post-update.d//z50-raspi-firmware exited with return c
ode 1
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: erro ao processar o pacote linux-image-6.1.0-11-amd64 (--configure):
 o subprocesso instalado, do pacote linux-image-6.1.0-11-amd64, o script post-in
stallation retornou erro do status de saída 1
Configurando linux-image-6.1.0-10-amd64 (6.1.38-2) ...
/etc/kernel/postinst.d/dkms:
dkms: running auto installation service for kernel 6.1.0-10-amd64.
dkms: autoinstall for kernel: 6.1.0-10-amd64.
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-6.1.0-10-amd64
raspi-firmware: missing /boot/firmware, did you forget to mount it?
run-parts: /etc/initramfs/post-update.d//z50-raspi-firmware exited with return c
ode 1
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: erro ao processar o pacote linux-image-6.1.0-10-amd64 (--configure):
 o subprocesso instalado, do pacote linux-image-6.1.0-10-amd64, o script post-in
stallation retornou erro do status de saída 1
Configurando linux-image-6.1.0-12-amd64 (6.1.52-1) ...
/etc/kernel/postinst.d/dkms:
dkms: running auto installation service for kernel 6.1.0-12-amd64.
dkms: autoinstall for kernel: 6.1.0-12-amd64.
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-6.1.0-12-amd64
raspi-firmware: missing /boot/firmware, did you forget to mount it?
run-parts: /etc/initramfs/post-update.d//z50-raspi-firmware exited with return c
ode 1
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: erro ao processar o pacote linux-image-6.1.0-12-amd64 (--configure):
 o subprocesso instalado, do pacote linux-image-6.1.0-12-amd64, o script post-in
stallation retornou erro do status de saída 1
Configurando linux-image-6.1.0-13-amd64 (6.1.55-1) ...
/etc/kernel/postinst.d/dkms:
dkms: running auto installation service for kernel 6.1.0-13-amd64.
dkms: autoinstall for kernel: 6.1.0-13-amd64.
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-6.1.0-13-amd64
raspi-firmware: missing /boot/firmware, did you forget to mount it?
run-parts: /etc/initramfs/post-update.d//z50-raspi-firmware exited with return c
ode 1
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: erro ao processar o pacote linux-image-6.1.0-13-amd64 (--configure):
 o subprocesso instalado, do pacote linux-image-6.1.0-13-amd64, o script post-in
stallation retornou erro do status de saída 1
dpkg: problemas com dependências impedem a configuração de linux-image-amd64:
 linux-image-amd64 depende de linux-image-6.1.0-13-amd64 (= 6.1.55-1); porém:
  Pacote linux-image-6.1.0-13-amd64 não está configurado ainda.

dpkg: erro ao processar o pacote linux-image-amd64 (--configure):
 problemas de dependência - deixando desconfigurado
A processar 'triggers' para initramfs-tools (0.142) ...
update-initramfs: Generating /boot/initrd.img-6.1.0-13-amd64
raspi-firmware: missing /boot/firmware, did you forget to mount it?
run-parts: /etc/initramfs/post-update.d//z50-raspi-firmware exited with return c
ode 1
dpkg: erro ao processar o pacote initramfs-tools (--configure):
 o subprocesso instalado, do pacote initramfs-tools, o script post-installation 
retornou erro do status de saída 1
Erros foram encontrados durante o processamento de:
 linux-image-6.1.0-11-amd64
 linux-image-6.1.0-10-amd64
 linux-image-6.1.0-12-amd64
 linux-image-6.1.0-13-amd64
 linux-image-amd64
 initramfs-tools
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@Codee:~# systemctl enable pipewire --now
Failed to enable unit: Unit file pipewire.service does not exist.
root@Codee:~# systemctl status pipewire
Unit pipewire.service could not be found.
root@Codee:~#

Alguém tem alguma ideia do que pode estar acontecendo?

Me parece que tem algo quebrado nos seus pacotes tenta rodar esse comando pra limpar e ajustar os pacotes não instalados.

  1. Atualize a lista de pacotes:

    sudo apt update
    
  2. Corrija pacotes quebrados (se houver):

    sudo apt install -f
    
  3. Remova pacotes não necessários (obsoletos):

    sudo apt autoremove
    
  4. Limpe o cache dos pacotes baixados:

    sudo apt clean
    
  5. Remova pacotes antigos de configuração:

    sudo apt autoclean
    

Completei todos os passos, o som ainda não retornou e o resultado final foi esse:

Resumo
pkexec bash
root@Codee:~# apt update
Atingido:1 http://security.debian.org/debian-security bookworm-security InRelease
Atingido:2 http://deb.debian.org/debian bookworm InRelease                     
Atingido:3 http://deb.debian.org/debian bookworm-updates InRelease             
Atingido:4 http://deb.debian.org/debian bookworm-proposed-updates InRelease
Atingido:5 https://dl.google.com/linux/chrome/deb stable InRelease
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto        
All packages are up to date.
root@Codee:~# apt install -f
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto        
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
  libbotan-2-19 librnp0 libtspi1 linux-headers-6.1.0-10-amd64
  linux-headers-6.1.0-10-common linux-headers-6.1.0-11-amd64
  linux-headers-6.1.0-11-common linux-headers-6.1.0-9-amd64
  linux-headers-6.1.0-9-common linux-image-6.1.0-10-amd64
  linux-image-6.1.0-11-amd64 linux-image-6.1.0-9-amd64
Utilize 'apt autoremove' para os remover.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
6 pacotes não totalmente instalados ou removidos.
Depois desta operação, 0 B adicionais de espaço em disco serão usados.
Configurando initramfs-tools (0.142) ...
update-initramfs: deferring update (trigger activated)
Configurando linux-image-6.1.0-11-amd64 (6.1.38-4) ...
/etc/kernel/postinst.d/dkms:
dkms: running auto installation service for kernel 6.1.0-11-amd64.
dkms: autoinstall for kernel: 6.1.0-11-amd64.
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-6.1.0-11-amd64
raspi-firmware: missing /boot/firmware, did you forget to mount it?
run-parts: /etc/initramfs/post-update.d//z50-raspi-firmware exited with return c
ode 1
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: erro ao processar o pacote linux-image-6.1.0-11-amd64 (--configure):
 o subprocesso instalado, do pacote linux-image-6.1.0-11-amd64, o script post-in
stallation retornou erro do status de saída 1
Configurando linux-image-6.1.0-10-amd64 (6.1.38-2) ...
/etc/kernel/postinst.d/dkms:
dkms: running auto installation service for kernel 6.1.0-10-amd64.
dkms: autoinstall for kernel: 6.1.0-10-amd64.
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-6.1.0-10-amd64
raspi-firmware: missing /boot/firmware, did you forget to mount it?
run-parts: /etc/initramfs/post-update.d//z50-raspi-firmware exited with return c
ode 1
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: erro ao processar o pacote linux-image-6.1.0-10-amd64 (--configure):
 o subprocesso instalado, do pacote linux-image-6.1.0-10-amd64, o script post-in
stallation retornou erro do status de saída 1
Configurando linux-image-6.1.0-12-amd64 (6.1.52-1) ...
/etc/kernel/postinst.d/dkms:
dkms: running auto installation service for kernel 6.1.0-12-amd64.
dkms: autoinstall for kernel: 6.1.0-12-amd64.
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-6.1.0-12-amd64
raspi-firmware: missing /boot/firmware, did you forget to mount it?
run-parts: /etc/initramfs/post-update.d//z50-raspi-firmware exited with return c
ode 1
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: erro ao processar o pacote linux-image-6.1.0-12-amd64 (--configure):
 o subprocesso instalado, do pacote linux-image-6.1.0-12-amd64, o script post-in
stallation retornou erro do status de saída 1
Configurando linux-image-6.1.0-13-amd64 (6.1.55-1) ...
/etc/kernel/postinst.d/dkms:
dkms: running auto installation service for kernel 6.1.0-13-amd64.
dkms: autoinstall for kernel: 6.1.0-13-amd64.
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-6.1.0-13-amd64
raspi-firmware: missing /boot/firmware, did you forget to mount it?
run-parts: /etc/initramfs/post-update.d//z50-raspi-firmware exited with return c
ode 1
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: erro ao processar o pacote linux-image-6.1.0-13-amd64 (--configure):
 o subprocesso instalado, do pacote linux-image-6.1.0-13-amd64, o script post-in
stallation retornou erro do status de saída 1
dpkg: problemas com dependências impedem a configuração de linux-image-amd64:
 linux-image-amd64 depende de linux-image-6.1.0-13-amd64 (= 6.1.55-1); porém:
  Pacote linux-image-6.1.0-13-amd64 não está configurado ainda.

dpkg: erro ao processar o pacote linux-image-amd64 (--configure):
 problemas de dependência - deixando desconfigurado
A processar 'triggers' para initramfs-tools (0.142) ...
update-initramfs: Generating /boot/initrd.img-6.1.0-13-amd64
raspi-firmware: missing /boot/firmware, did you forget to mount it?
run-parts: /etc/initramfs/post-update.d//z50-raspi-firmware exited with return c
ode 1
dpkg: erro ao processar o pacote initramfs-tools (--configure):
 o subprocesso instalado, do pacote initramfs-tools, o script post-installation 
retornou erro do status de saída 1
Erros foram encontrados durante o processamento de:
 linux-image-6.1.0-11-amd64
 linux-image-6.1.0-10-amd64
 linux-image-6.1.0-12-amd64
 linux-image-6.1.0-13-amd64
 linux-image-amd64
 initramfs-tools
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@Codee:~# apt autoremove
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto        
Os pacotes a seguir serão REMOVIDOS:
  libbotan-2-19 librnp0 libtspi1 linux-headers-6.1.0-10-amd64
  linux-headers-6.1.0-10-common linux-headers-6.1.0-11-amd64
  linux-headers-6.1.0-11-common linux-headers-6.1.0-9-amd64
  linux-headers-6.1.0-9-common linux-image-6.1.0-10-amd64
  linux-image-6.1.0-11-amd64 linux-image-6.1.0-9-amd64
0 pacotes atualizados, 0 pacotes novos instalados, 12 a serem removidos e 0 não atualizados.
6 pacotes não totalmente instalados ou removidos.
Depois desta operação, 1.414 MB de espaço em disco serão liberados.
Você quer continuar? [S/n] s
(Lendo banco de dados ... 360927 ficheiros e diretórios atualmente instalados.)
A remover linux-image-6.1.0-10-amd64 (6.1.38-2) ...
/etc/kernel/postrm.d/initramfs-tools:
update-initramfs: Deleting /boot/initrd.img-6.1.0-10-amd64
/etc/kernel/postrm.d/z50-raspi-firmware:
raspi-firmware: missing /boot/firmware, did you forget to mount it?
run-parts: /etc/kernel/postrm.d/z50-raspi-firmware exited with return code 1
dpkg: erro ao processar o pacote linux-image-6.1.0-10-amd64 (--remove):
 o subprocesso instalado, do pacote linux-image-6.1.0-10-amd64, o script post-re
moval retornou erro do status de saída 1
dpkg: demasiados erros, a parar
Erros foram encontrados durante o processamento de:
 linux-image-6.1.0-10-amd64
Processamento parou porque havia muitos erros.
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@Codee:~# apt clean
root@Codee:~# apt autoclean
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto        
root@Codee:~# 
```

Vamos lá tem um erro em um pacote e isso talvez não seja o problema mas ta dando alguns problemas a você.

  1. Atualize a lista de pacotes:

    sudo apt update
    
  2. Atualize todos os pacotes do sistema:

    sudo apt upgrade
    
  3. Force a reinstalação do pacote linux-image-amd64:

    sudo apt-get install --reinstall linux-image-amd64
    
  4. Execute novamente o processo de configuração:

    sudo dpkg --configure -a
    
  5. Verifique se há pacotes quebrados e, se necessário, corrija-os:

    sudo apt install -f
    

Depois de executar esses passos, verifique se o problema persiste.

Segui todos os passos, o som não voltou e esse são os resultados no terminal:

Resumo
pkexec bash
root@Codee:~# apt update
Atingido:1 http://deb.debian.org/debian bookworm InRelease
Atingido:2 http://deb.debian.org/debian bookworm-updates InRelease                    
Atingido:3 http://security.debian.org/debian-security bookworm-security InRelease     
Atingido:4 http://deb.debian.org/debian bookworm-proposed-updates InRelease           
Atingido:5 https://dl.google.com/linux/chrome/deb stable InRelease                    
Lendo listas de pacotes... Pronto                        
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto        
All packages are up to date.
root@Codee:~# apt upgrade
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto        
Calculando atualização... Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
6 pacotes não totalmente instalados ou removidos.
É preciso baixar 68,5 MB de arquivos.
Depois desta operação, 0 B adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
Obter:1 http://deb.debian.org/debian bookworm/main amd64 linux-image-6.1.0-10-amd64 amd64 6.1.38-2 [68,5 MB]
Baixados 68,5 MB em 6s (11,9 MB/s)                     
Configurando initramfs-tools (0.142) ...
update-initramfs: deferring update (trigger activated)
Configurando linux-image-6.1.0-11-amd64 (6.1.38-4) ...
/etc/kernel/postinst.d/dkms:
dkms: running auto installation service for kernel 6.1.0-11-amd64.
dkms: autoinstall for kernel: 6.1.0-11-amd64.
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-6.1.0-11-amd64
raspi-firmware: missing /boot/firmware, did you forget to mount it?
run-parts: /etc/initramfs/post-update.d//z50-raspi-firmware exited with return code 1
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: erro ao processar o pacote linux-image-6.1.0-11-amd64 (--configure):
 o subprocesso instalado, do pacote linux-image-6.1.0-11-amd64, o script post-installat
ion retornou erro do status de saída 1
Configurando linux-image-6.1.0-12-amd64 (6.1.52-1) ...
/etc/kernel/postinst.d/dkms:
dkms: running auto installation service for kernel 6.1.0-12-amd64.
dkms: autoinstall for kernel: 6.1.0-12-amd64.
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-6.1.0-12-amd64
raspi-firmware: missing /boot/firmware, did you forget to mount it?
run-parts: /etc/initramfs/post-update.d//z50-raspi-firmware exited with return code 1
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: erro ao processar o pacote linux-image-6.1.0-12-amd64 (--configure):
 o subprocesso instalado, do pacote linux-image-6.1.0-12-amd64, o script post-installat
ion retornou erro do status de saída 1
Configurando linux-image-6.1.0-13-amd64 (6.1.55-1) ...
/etc/kernel/postinst.d/dkms:
dkms: running auto installation service for kernel 6.1.0-13-amd64.
dkms: autoinstall for kernel: 6.1.0-13-amd64.
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-6.1.0-13-amd64
raspi-firmware: missing /boot/firmware, did you forget to mount it?
run-parts: /etc/initramfs/post-update.d//z50-raspi-firmware exited with return code 1
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: erro ao processar o pacote linux-image-6.1.0-13-amd64 (--configure):
 o subprocesso instalado, do pacote linux-image-6.1.0-13-amd64, o script post-installat
ion retornou erro do status de saída 1
dpkg: problemas com dependências impedem a configuração de linux-image-amd64:
 linux-image-amd64 depende de linux-image-6.1.0-13-amd64 (= 6.1.55-1); porém:
  Pacote linux-image-6.1.0-13-amd64 não está configurado ainda.

dpkg: erro ao processar o pacote linux-image-amd64 (--configure):
 problemas de dependência - deixando desconfigurado
A processar 'triggers' para initramfs-tools (0.142) ...
update-initramfs: Generating /boot/initrd.img-6.1.0-13-amd64
raspi-firmware: missing /boot/firmware, did you forget to mount it?
run-parts: /etc/initramfs/post-update.d//z50-raspi-firmware exited with return code 1
dpkg: erro ao processar o pacote initramfs-tools (--configure):
 o subprocesso instalado, do pacote initramfs-tools, o script post-installation retorno
u erro do status de saída 1
Erros foram encontrados durante o processamento de:
 linux-image-6.1.0-11-amd64
 linux-image-6.1.0-12-amd64
 linux-image-6.1.0-13-amd64
 linux-image-amd64
 initramfs-tools
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@Codee:~# apt-get install --reinstall linux-image-amd64
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto        
Os pacotes a seguir serão REMOVIDOS:
  linux-image-6.1.0-10-amd64
0 pacotes atualizados, 0 pacotes novos instalados, 1 reinstalados, 1 a serem removidos e 0 não atualizados.
6 pacotes não totalmente instalados ou removidos.
Depois desta operação, 408 MB de espaço em disco serão liberados.
Você quer continuar? [S/n] s
E: Internal Error, No file name for linux-image-amd64:amd64
root@Codee:~# dpkg --configure -a
Configurando initramfs-tools (0.142) ...
update-initramfs: deferring update (trigger activated)
Configurando linux-image-6.1.0-11-amd64 (6.1.38-4) ...
/etc/kernel/postinst.d/dkms:
dkms: running auto installation service for kernel 6.1.0-11-amd64.
/usr/sbin/dkms: linha 2497: echo: erro de escrita: Pipe quebrado
dkms: autoinstall for kernel: 6.1.0-11-amd64.
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-6.1.0-11-amd64
apt install -f
raspi-firmware: missing /boot/firmware, did you forget to mount it?
run-parts: /etc/initramfs/post-update.d//z50-raspi-firmware exited with return code 1
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: erro ao processar o pacote linux-image-6.1.0-11-amd64 (--configure):
 o subprocesso instalado, do pacote linux-image-6.1.0-11-amd64, o script post-installation retornou erro do status de saída 1
Configurando linux-image-6.1.0-12-amd64 (6.1.52-1) ...
/etc/kernel/postinst.d/dkms:
dkms: running auto installation service for kernel 6.1.0-12-amd64.
/usr/sbin/dkms: linha 2497: echo: erro de escrita: Pipe quebrado
dkms: autoinstall for kernel: 6.1.0-12-amd64.
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-6.1.0-12-amd64

Tenta agora

sudo apt-get install --reinstall linux-image

Tentei, a resposta fo essa:

pkexec bash
root@Codee:~# apt-get install --reinstall linux-image
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto        
E: Impossível encontrar o pacote linux-image
root@Codee:~#

Roda o comando:

apt search linux

E manda a saída por favor

Na vdd deveria achar o anterior tenta ver se ta escrito igual aqui

Rodei o comando e a resposta do terminal ultrapassou o limite de caracteres permitidas pelo fórum, te enviei a imagem do fórum avisando isso lá no Discord. O que é a saída?

É um raspberry Pi?

Ao que parece são dois problemas. O primeiro é que parece que foi instalado algum pacote específico para o raspberry pi que depende de arquivos de firmware que não estão instalados. Caso não seja um raspberry, vc precisa desisntalar algo que foi anteriormente instalado.

Outro ponto é que o áudio deveria funcionar perfeitamente no ambiente gráfico. O ideal é vc procurar pelas configurações de áudio do seu ambiente (seria XFCE?) e verificar o que ele indica.

Você me pediu pelo Discord para usar os comandos “apt search linux | grep amd64” e “apt search linux-image”, fiz os dois e o resultado foi esse:

Resumo
pkexec bash
root@Codee:~# apt search | grep amd64

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

E: Tem de fornecer pelo menos um padrão de busca
root@Codee:~# apt search linux-image
Sorting... Pronto
Full Text Search... Pronto
linux-headers-6.1.0-10-amd64/stable,now 6.1.38-2 amd64 [installed]
  Header files for Linux 6.1.0-10-amd64

linux-headers-6.1.0-10-cloud-amd64/stable 6.1.38-2 amd64
  Header files for Linux 6.1.0-10-cloud-amd64

linux-headers-6.1.0-10-rt-amd64/stable 6.1.38-2 amd64
  Header files for Linux 6.1.0-10-rt-amd64

linux-headers-6.1.0-11-amd64/stable-security,now 6.1.38-4 amd64 [installed]
  Header files for Linux 6.1.0-11-amd64

linux-headers-6.1.0-11-cloud-amd64/stable-security 6.1.38-4 amd64
  Header files for Linux 6.1.0-11-cloud-amd64

linux-headers-6.1.0-11-rt-amd64/stable-security 6.1.38-4 amd64
  Header files for Linux 6.1.0-11-rt-amd64

linux-headers-6.1.0-12-amd64/stable-security,now 6.1.52-1 amd64 [installed,automatic]
  Header files for Linux 6.1.0-12-amd64

linux-headers-6.1.0-12-cloud-amd64/stable-security 6.1.52-1 amd64
  Header files for Linux 6.1.0-12-cloud-amd64

linux-headers-6.1.0-12-rt-amd64/stable-security 6.1.52-1 amd64
  Header files for Linux 6.1.0-12-rt-amd64

linux-headers-6.1.0-13-amd64/stable,now 6.1.55-1 amd64 [installed,automatic]
  Header files for Linux 6.1.0-13-amd64

linux-headers-6.1.0-13-cloud-amd64/stable 6.1.55-1 amd64
  Header files for Linux 6.1.0-13-cloud-amd64

linux-headers-6.1.0-13-rt-amd64/stable 6.1.55-1 amd64
  Header files for Linux 6.1.0-13-rt-amd64

linux-headers-6.1.0-9-amd64/now 6.1.27-1 amd64 [installed,local]
  Header files for Linux 6.1.0-9-amd64

linux-image-6.1.0-10-amd64/stable,now 6.1.38-2 amd64 [installed]
  Linux 6.1 for 64-bit PCs (signed)

linux-image-6.1.0-10-amd64-dbg/stable 6.1.38-2 amd64
  Debug symbols for linux-image-6.1.0-10-amd64

linux-image-6.1.0-10-amd64-unsigned/stable 6.1.38-2 amd64
  Linux 6.1 for 64-bit PCs

linux-image-6.1.0-10-cloud-amd64/stable 6.1.38-2 amd64
  Linux 6.1 for x86-64 cloud (signed)

linux-image-6.1.0-10-cloud-amd64-dbg/stable 6.1.38-2 amd64
  Debug symbols for linux-image-6.1.0-10-cloud-amd64

linux-image-6.1.0-10-cloud-amd64-unsigned/stable 6.1.38-2 amd64
  Linux 6.1 for x86-64 cloud

linux-image-6.1.0-10-rt-amd64/stable 6.1.38-2 amd64
  Linux 6.1 for 64-bit PCs, PREEMPT_RT (signed)

linux-image-6.1.0-10-rt-amd64-dbg/stable 6.1.38-2 amd64
  Debug symbols for linux-image-6.1.0-10-rt-amd64

linux-image-6.1.0-10-rt-amd64-unsigned/stable 6.1.38-2 amd64
  Linux 6.1 for 64-bit PCs, PREEMPT_RT

linux-image-6.1.0-11-amd64/stable-security,now 6.1.38-4 amd64 [installed]
  Linux 6.1 for 64-bit PCs (signed)

linux-image-6.1.0-11-amd64-dbg/stable-security 6.1.38-4 amd64
  Debug symbols for linux-image-6.1.0-11-amd64

linux-image-6.1.0-11-amd64-unsigned/stable-security 6.1.38-4 amd64
  Linux 6.1 for 64-bit PCs

linux-image-6.1.0-11-cloud-amd64/stable-security 6.1.38-4 amd64
  Linux 6.1 for x86-64 cloud (signed)

linux-image-6.1.0-11-cloud-amd64-dbg/stable-security 6.1.38-4 amd64
  Debug symbols for linux-image-6.1.0-11-cloud-amd64

linux-image-6.1.0-11-cloud-amd64-unsigned/stable-security 6.1.38-4 amd64
  Linux 6.1 for x86-64 cloud

linux-image-6.1.0-11-rt-amd64/stable-security 6.1.38-4 amd64
  Linux 6.1 for 64-bit PCs, PREEMPT_RT (signed)

linux-image-6.1.0-11-rt-amd64-dbg/stable-security 6.1.38-4 amd64
  Debug symbols for linux-image-6.1.0-11-rt-amd64

linux-image-6.1.0-11-rt-amd64-unsigned/stable-security 6.1.38-4 amd64
  Linux 6.1 for 64-bit PCs, PREEMPT_RT

linux-image-6.1.0-12-amd64/stable-security,now 6.1.52-1 amd64 [installed,automatic]
  Linux 6.1 for 64-bit PCs (signed)

linux-image-6.1.0-12-amd64-dbg/stable-security 6.1.52-1 amd64
  Debug symbols for linux-image-6.1.0-12-amd64

linux-image-6.1.0-12-amd64-unsigned/stable-security 6.1.52-1 amd64
  Linux 6.1 for 64-bit PCs

linux-image-6.1.0-12-cloud-amd64/stable-security 6.1.52-1 amd64
  Linux 6.1 for x86-64 cloud (signed)

linux-image-6.1.0-12-cloud-amd64-dbg/stable-security 6.1.52-1 amd64
  Debug symbols for linux-image-6.1.0-12-cloud-amd64

linux-image-6.1.0-12-cloud-amd64-unsigned/stable-security 6.1.52-1 amd64
  Linux 6.1 for x86-64 cloud

linux-image-6.1.0-12-rt-amd64/stable-security 6.1.52-1 amd64
  Linux 6.1 for 64-bit PCs, PREEMPT_RT (signed)

linux-image-6.1.0-12-rt-amd64-dbg/stable-security 6.1.52-1 amd64
  Debug symbols for linux-image-6.1.0-12-rt-amd64

linux-image-6.1.0-12-rt-amd64-unsigned/stable-security 6.1.52-1 amd64
  Linux 6.1 for 64-bit PCs, PREEMPT_RT

linux-image-6.1.0-13-amd64/stable,now 6.1.55-1 amd64 [installed,automatic]
  Linux 6.1 for 64-bit PCs (signed)

linux-image-6.1.0-13-amd64-dbg/stable 6.1.55-1 amd64
  Debug symbols for linux-image-6.1.0-13-amd64

linux-image-6.1.0-13-amd64-unsigned/stable 6.1.55-1 amd64
  Linux 6.1 for 64-bit PCs

linux-image-6.1.0-13-cloud-amd64/stable 6.1.55-1 amd64
  Linux 6.1 for x86-64 cloud (signed)

linux-image-6.1.0-13-cloud-amd64-dbg/stable 6.1.55-1 amd64
  Debug symbols for linux-image-6.1.0-13-cloud-amd64

linux-image-6.1.0-13-cloud-amd64-unsigned/stable 6.1.55-1 amd64
  Linux 6.1 for x86-64 cloud

linux-image-6.1.0-13-rt-amd64/stable 6.1.55-1 amd64
  Linux 6.1 for 64-bit PCs, PREEMPT_RT (signed)

linux-image-6.1.0-13-rt-amd64-dbg/stable 6.1.55-1 amd64
  Debug symbols for linux-image-6.1.0-13-rt-amd64

linux-image-6.1.0-13-rt-amd64-unsigned/stable 6.1.55-1 amd64
  Linux 6.1 for 64-bit PCs, PREEMPT_RT

linux-image-6.1.0-9-amd64/now 6.1.27-1 amd64 [installed,local]
  Linux 6.1 for 64-bit PCs (signed)

linux-image-amd64/stable,now 6.1.55-1 amd64 [installed]
  Linux para computadores de 64 bits (meta-pacote)

linux-image-amd64-dbg/stable 6.1.55-1 amd64
  Debugging symbols for Linux amd64 configuration (meta-package)

linux-image-amd64-signed-template/stable 6.1.55-1 amd64
  Template for signed linux-image packages for amd64

linux-image-cloud-amd64/stable 6.1.55-1 amd64
  Linux for x86-64 cloud (meta-package)

linux-image-cloud-amd64-dbg/stable 6.1.55-1 amd64
  Debugging symbols for Linux cloud-amd64 configuration (meta-package)

linux-image-rt-amd64/stable 6.1.55-1 amd64
  Linux para computadores de 64 bits (meta-pacote)

linux-image-rt-amd64-dbg/stable 6.1.55-1 amd64
  Debugging symbols for Linux rt-amd64 configuration (meta-package)

root@Codee:~#

É um computador e meu ambiente gráfico é GNOME

Da um

apt get install --reinstall linux-headers-6.1.0-13-amd64

Você me pediu pelo Discord para jogar a partir do 6.1.0.13, aqui vai:

Resumo
linux-image-6.1.0-13-amd64-dbg/stable 6.1.55-1 amd64
  Debug symbols for linux-image-6.1.0-13-amd64

linux-image-6.1.0-13-amd64-unsigned/stable 6.1.55-1 amd64
  Linux 6.1 for 64-bit PCs

linux-image-6.1.0-13-cloud-amd64/stable 6.1.55-1 amd64
  Linux 6.1 for x86-64 cloud (signed)

linux-image-6.1.0-13-cloud-amd64-dbg/stable 6.1.55-1 amd64
  Debug symbols for linux-image-6.1.0-13-cloud-amd64

linux-image-6.1.0-13-cloud-amd64-unsigned/stable 6.1.55-1 amd64
  Linux 6.1 for x86-64 cloud

linux-image-6.1.0-13-rt-amd64/stable 6.1.55-1 amd64
  Linux 6.1 for 64-bit PCs, PREEMPT_RT (signed)

linux-image-6.1.0-13-rt-amd64-dbg/stable 6.1.55-1 amd64
  Debug symbols for linux-image-6.1.0-13-rt-amd64

linux-image-6.1.0-13-rt-amd64-unsigned/stable 6.1.55-1 amd64
  Linux 6.1 for 64-bit PCs, PREEMPT_RT

linux-image-6.1.0-9-amd64/now 6.1.27-1 amd64 [installed,local]
  Linux 6.1 for 64-bit PCs (signed)

linux-image-amd64/stable,now 6.1.55-1 amd64 [installed]
  Linux para computadores de 64 bits (meta-pacote)

linux-image-amd64-dbg/stable 6.1.55-1 amd64
  Debugging symbols for Linux amd64 configuration (meta-package)

linux-image-amd64-signed-template/stable 6.1.55-1 amd64
  Template for signed linux-image packages for amd64

linux-image-cloud-amd64/stable 6.1.55-1 amd64
  Linux for x86-64 cloud (meta-package)

linux-image-cloud-amd64-dbg/stable 6.1.55-1 amd64
  Debugging symbols for Linux cloud-amd64 configuration (meta-package)

linux-image-rt-amd64/stable 6.1.55-1 amd64
  Linux para computadores de 64 bits (meta-pacote)

linux-image-rt-amd64-dbg/stable 6.1.55-1 amd64
  Debugging symbols for Linux rt-amd64 configuration (meta-package)

root@Codee:~#

Fiz o comando “apt get install --reinstall linux-headers-6.1.0-13-amd64” que você me pediu e a resposta do terminal foi essa:

Resumo

pkexec bash root@Codee:~# apt get install --reinstall linux-headers-6.1.0-13-amd64 E: Operação get inválida root@Codee:~#

Sei que usa Debian, mas utilizei o método no link abaixo e funcionou no Ubuntu 22.04. e também no Trisquel 11.
O que funcionou pra mim foi o 5º e último.

Usei todas as soluções do site, infelizmente o som não voltou. Aqui está todas as respostas do terminal:

Resumo
pkexec bash
root@Codee:~# apt install inxi
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto        
The following additional packages will be installed:
  bind9-dnsutils bind9-host bind9-libs dnsutils libfstrm0 libjemalloc2
  libmaxminddb0 libuv1 tree
Pacotes sugeridos:
  libxml-dumper-perl mmdb-bin
Os pacotes a seguir serão REMOVIDOS:
  linux-image-6.1.0-10-amd64
Os NOVOS pacotes a seguir serão instalados:
  bind9-dnsutils bind9-host bind9-libs dnsutils inxi libfstrm0 libjemalloc2
  libmaxminddb0 libuv1 tree
0 pacotes atualizados, 10 pacotes novos instalados, 1 a serem removidos e 0 não atualizados.
6 pacotes não totalmente instalados ou removidos.
É preciso baixar 3.416 kB de arquivos.
Depois desta operação, 400 MB de espaço em disco serão liberados.
Você quer continuar? [S/n] s
Obter:1 http://deb.debian.org/debian bookworm/main amd64 libuv1 amd64 1.44.2-1 [140 kB]
Obter:2 http://deb.debian.org/debian bookworm/main amd64 libfstrm0 amd64 0.6.1-1 [21,6 kB]
Obter:3 http://deb.debian.org/debian bookworm/main amd64 libjemalloc2 amd64 5.3.0-1 [275 kB]
Obter:4 http://deb.debian.org/debian bookworm/main amd64 libmaxminddb0 amd64 1.7.1-1 [29,8 kB]
Obter:5 http://deb.debian.org/debian bookworm/main amd64 bind9-libs amd64 1:9.18.19-1~deb12u1 [1.410 kB]
Obter:6 http://deb.debian.org/debian bookworm/main amd64 bind9-host amd64 1:9.18.19-1~deb12u1 [303 kB]
Obter:7 http://deb.debian.org/debian bookworm/main amd64 bind9-dnsutils amd64 1:9.18.19-1~deb12u1 [401 kB]
Obter:8 http://deb.debian.org/debian bookworm/main amd64 dnsutils all 1:9.18.19-1~deb12u1 [259 kB]
Obter:9 http://deb.debian.org/debian bookworm/main amd64 inxi all 3.3.26-1-1 [525 kB]
Obter:10 http://deb.debian.org/debian bookworm/main amd64 tree amd64 2.1.0-1 [52,5 kB]
Baixados 3.416 kB em 1s (2.675 kB/s)
(Lendo banco de dados ... 355991 ficheiros e diretórios atualmente instalados.)
A remover linux-image-6.1.0-10-amd64 (6.1.38-2) ...
/etc/kernel/postrm.d/initramfs-tools:
update-initramfs: Deleting /boot/initrd.img-6.1.0-10-amd64
/etc/kernel/postrm.d/z50-raspi-firmware:
raspi-firmware: missing /boot/firmware, did you forget to mount it?
run-parts: /etc/kernel/postrm.d/z50-raspi-firmware exited with return code 1
dpkg: erro ao processar o pacote linux-image-6.1.0-10-amd64 (--remove):
 o subprocesso instalado, do pacote linux-image-6.1.0-10-amd64, o script post-re
moval retornou erro do status de saída 1
dpkg: demasiados erros, a parar
Erros foram encontrados durante o processamento de:
 linux-image-6.1.0-10-amd64
Processamento parou porque havia muitos erros.
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@Codee:~# inxi -SMA
bash: inxi: comando não encontrado
root@Codee:~# apt-get install –reinstall alsa-base pulseaudio
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto        
E: Impossível encontrar o pacote –reinstall
E: Impossível encontrar o pacote alsa-base
root@Codee:~# alsa force-reload
bash: alsa: comando não encontrado
root@Codee:~# mv ~/.config/pulse ~/.config/old_pulse
mv: não foi possível obter estado de '/root/.config/pulse': Arquivo ou diretório inexistente
root@Codee:~# alsamixer
cannot open mixer: Host está desligado
root@Codee:~# alsamixer -c 1
invalid card index: 1
try `alsamixer --help' for more information
root@Codee:~# gedit /etc/default/speech-dispatcher
bash: gedit: comando não encontrado
root@Codee:~# gedit /etc/modprobe.d/alsa-base.conf
bash: gedit: comando não encontrado
root@Codee:~# options snd-hda-intel dmic_detect=0
bash: options: comando não encontrado
root@Codee:~#

Essa mensagem de erro, me deixou curioso, isso ai é um raspiberry?

É um computador irmão, raspiberry é um celular.