Impossível instalar Grub no meu Desktop (Pop!_OS)

Obrigado por ter clicado para ler esse tópico e, ainda mais, caso possa me ajudar, após a leitura do meu (extenso) problema.

Configuração do meu PC:

CPU: Ryzen 5 3600
GPU: Radeon RX 570
Memórias: Corsair 16GB (2x8GB) DDR4 2666MHz
Placa mãe: Gibabyte B450M DS3H (Rev.1)
Armazenamento: M.2 NVMe 1TB e HD 1TB (dados de backup).

PARTE 1

Entrei no mundo GNU/Linux já faz quase um mês e, após testar o Ubuntu no meu notebook, decidi torná-lo minha distro principal do meu Desktop. No meio do caminho, acabei decidindo testar o Pop!_OS e aí o que os problemas começaram.

A minha intenção era fazer dualboot com Windows 10 no meu Desktop. Realizei procedimentos iguais ao ensinado pelo grande Diolinux. Como já tinha feito no Notebook com o Ubuntu e tudo tinha ocorrido bem, estava tranquilo que não teria dificuldades. Apesar da interface um pouco diferente do Ubuntu, consegui fazer as partições no Gparted. (Ext 4 para “/” e uma partição de Fat32 512MB para Inicialização da BIOS com o rótulo /boot/efi - estava baseando nesse link para a instalação do dualboot -, não criei partição de Swap).

Problemas encontrados na instalação:

A partição de 512MB era automaticamente formatada para ext4 e os caminhos alterado para “/bios”, ao invés de “/bios/efi”.

Isso resultava falhas na instalação. Somente consegui instalar alterando a partição da inicialização para: esquema de arquivos “liberto”, tipo de partição “BIOS Boot”, parametrizado como “bios_grub” (ao invés de “bios” e “esp”). Fiz isso na maior sorte do mundo, rsrsr.

E, finalmente, consegui instalar o Pop!_OS, porém somente conseguia acessá-lo caso entrasse no seleção de boot pela BIOS (pressionando F12, quando iniciava a máquina). Descobri, na tentativa de instalar o sistema da maneira “correta”, que o Pop!_OS não usa Grub. Eu tentei instalá-lo então por esse tutorial, mas sem sucesso. Tente alterar a partição de 512MB para a formatação correta, mas quando conseguia fazer isso e reiniciava o S.O., simplesmente não conseguia mais acessar o Pop!_OS. Tive que reinstalá-lo e alterar a partição de inicialização de BIOS iguais as que fez funcionar da última vez (ou seja, esquema de arquivos “liberto”, tipo de partição “BIOS Boot”, parametrizado como “bios_grub”).

Nesse ponto eu dei por vencido, pois como tinha apenas instalado a distro para fazer alguns testes (conferir compatibilidade com drivers da AMD, DaVinci Resolve, OpenCL, ROCm, outras dores de cabeça, que também tem tópico por aqui e que atualizarei em breve… Assim que conseguir resolver o problema discutido nesse tópico…), achei que era apenas uma confusão por conta do Windows 10 estar instalado na máquina e que, quando, mudasse de vez para as distros Linux e desinstalasse o Windows, esse problema deixaria de acontecer. Estava completamente enganado.

PARTE 2

No começo dessa semana eu decidi “chutar o balde” e mudar de vez para o GNU/Linux, após a “bateria” de testes que fiz nessas últimas semanas. Optei por escolher o Pop!_OS, pois apaixonei pelo design minimalista do sistema, apesar da incompatibilidade que tive com o DaVinci Resolve e minha placa de vídeo. Porém, no meio do caminho, eu mudei de ideia e quis instalar o Ubuntu, pois estava pensando em replicar a “bateria” de testes que tinha feito no Pop!_OS no Ubuntu, além do que Ubuntu usa o grub, logo ficaria mais fácil fazer dualboot com outro sistema. Após o backup dos meu dados e exclusão do Windows, instalei, logo em seguida, o Ubuntu. Formatei o NVMe novamente em GPT, criei as partições igual ao vídeo do Dio, assim como no meu Notebook, e, aparentemente tinha dado tudo certo. No entanto, quando iniciava o PC, o grub não aparecia, pensei que era porque não tinha outro sistema. Instalei o Pop!_OS depois e enfrentei o mesmo problema de antes para a sua instalação.

Não teve outro jeito se não fazer aqueles mesmo procedimentos que tinha descoberto para instalá-lo. Com sucesso da instalação, reinicie a máquina que foi direto para o Pop!_OS e estava funcionando normalmente. Reiniciei para entrar no Ubuntu pressionando F12 (seleção de boot da própria placa mãe) e simplesmente havia apenas uma opção, mesmo tendo criado partição diferente para o Pop!_OS. Achando que tinha errado a partição do sistema e acidentalmente tendo usado a do Ubuntu, entrei no gerenciamento de discos do Pop e não o Ubuntu estava intacto até montei a unidade para navegar pelas pasta, tudo certo, mas nada de aparecer a sua partição na inicialização ao pressionar o F12. Pensei em instalar o Grub pelo Pop!_OS e deram os mesmo erros quando estava com o Windows na máquina.

A minha placa mãe

Eu tô achando que a minha placa mãe é o problema. Sobre ela, suporta tanto UEFI como Legacy, através da opção CSM. Pra instalar o Grub, pesquisei pela internet a fora e vi comentários de usuários dizendo que o sistema tinha que estar em um ambiente UEFI puro, o que conseguiria ao desativar o “CSM support”. Outro problema surge aqui, pois não consigo mudar o CSM, já que sempre desativo-o, reinicio e entro na BIOS de novo, ele automaticamente retorna a ficar ativo, não importa se adiciono senha de administrador na BIOS ou deixo suporte para alguns itens em UEFI. Já carreguei os padrões de fábrica da BIOS e desativei o CSM, mas sem sucesso; já fiz o jumper na placa mãe para também “resetá-la” e desativei o CSM, mas sem sucesso; já tentei criar outra partição no SSD de 512MB com as configurações para criar um carregar de inicialização e tentar instalar o Grub, mas sem sucesso, mais uma vez.

A única opção que restou foi tornar as “chaves” do Secure Boot (quando desativo o CSM, essa opção aparece) para padrões de fábrica mas não faça a miníma ideia no que isso pode resultar.

Será que retornar os padrões da chave seria a solução?

IMAGENS

CSM e algumas outras opções para mudar para “Legacy only”, “UEFI only” e “Disable”;

Desativando CSM para ambiente UEFI puro;

Algumas opções desaparecem quando o CSM é desativado e a opção Secure Boot aparece no fim da página;

Opções dentro do Secure Boot, inclusive a para voltar para os valores de fábrica as “Keys”.

1 Curtida

Na verdade ae o Pop!_OS é enjoado com dual boot porque ele usa o systemd-boot diferente do grub do Ubuntu. O grub tem mais compatibilidade porque é mais “maduro” desde de 1995, enquanto o systemd-boot é de 2015. Então acaba encrencando. Eu já ví notícias que a System76 está trabalhando nestas questões de compatibilidade e melhorias do systemd-boot, mas só resta nós esperarmos quando essas melhorias virão.

2 Curtidas

Tem algumas placas que só ativam o UEFI puro se o Secure Boot estiver habilitado. Não sei o porquê disso…

Já que está com a mão na massa, tenta deixar ativado o secure boot pra instalação. Tanto o Ubuntu quanto o Pop não devem ter problemas quanto a isso.

2 Curtidas

Já tentei fazer isso, mas as seguintes mensagens aparecem:

(Eu tentei habilitar sim, apesar do ponteiro do mouse e da seleção de opções estarem sobre “Disable”.)

Como pode perceber, é preciso desativar o CSM e dar reboot para na nova inicialização ativar o Secure Boot, porém, como eu relatei no tópico, ao reiniciar, o CSM que desativei na última sessão retorna a ficar ativado, automaticamente.

Lembrou de salvar ali no “save & exit”? Às vezes isso passa batido! Parece idiota mas eu mesmo já dei esse mole uma pá de vezes

Sim! :heart:

1 Curtida

Clareem minha mente mas, para instalar o Pop!_OS em dualboot, o melhor a fazer nesta placa mãe é:
UEFI Only > Primeiro o Pop!_OS e depois outros Sistemas Operacionais. Se instalar um OS antes do Pop!_OS encrenca. Então é bom seguir esta ordem. Me corrijam se eu estiver errado.

3 Curtidas

Sim, eu cheguei a fazer isso, mas não consegui montar o Grub no Pop!_OS.

1 Curtida

Atualizando a minha situação, no momento:

Ontem à noite decidi instalar apenas o Ubuntu no meu NVMe para realizar as tais “baterias de testes” que tinha feito no Pop!_OS. Após a instalação quase que idêntica a ensinada pelo Dionatan, eu não conseguia inicializar o Ubuntu. Caía numa tela de como se não tivesse algum sistema operacional na máquina.

Após meia dúzia de tentativas de instalar o Ubuntu, eu então selecionei a opção de instalação automática - eu estava usando a opção personalizada nas tentativas anteriores, como ensinava o Dio no vídeo de Dualboot com o Windows. E veja só, o Ubuntu foi instalado corretamente! Baita alívio, e a pasta “/boot/efi” tinha finalmente alguma vez instalada. Apesar do Grub somente aparecer pressionando Escape, dei início a “bateria de testes”.

Outros problemas começaram a aparecer: a instalação do driver da minha placa de vídeo, ou corrompia o sistema operacional - sendo nem mesmo capaz de recuperá-lo ao desinstalar driver no modo de recuperação -, ou, quando tinha êxito ao instalá-lo alterando algumas coisas na hora de executar o script de instalação, o sistema ficara ligeiramente corrompido: conseguia acessar o GUI mas o Ubuntu comportava estranhamente. Tentei instalar o ROCm em vez do driver e acabou dando na mesma. Ainda me falta fazer teste com um outro driver e com o script do Dio, mas provavelmente também darão erro, eu acredito.

Isso é completamente desastroso: como pode o Ubuntu não conseguir instalar o driver da GPU que possui suporte oficial por parte da AMD, sendo que não há no Pop!_OS e conseguia instalar os drivers fazendo um “Workaround” e não dava falhas no sistema?

Isso reforça uma ideia minha: deve estar ocorrendo algum conflito de Hardware, não acham?

1 Curtida

:wave:t2:

Já tentou fazer este procedimento? Senão tenta seguir a sugestão do @DaniSheng :pray:t2:.

Outra sugestão, instalar o Pop!_OS direto, single boot e dentro dele criar uma VM com o Ubuntu.

:v:t2:

2 Curtidas

Já deixei de lado o Ubuntu, já que ele se corrompeu ou se comportou estranhamento em todas as vezes que eu instalei o driver oficial da minha GPU ou ROCm. Estou mô desapontado com isso, já que no Ubuntu deveria ter ocorrido tudo certo já que ele é a única distribuição Debian que tem suporte oficial aos drivers da AMD.

Já instalei de volta o Pop!_OS, vou tentar dualboot com o Mint agora e fazer novamente as bateria de testes, isso se conseguir instalar ao lado do Pop.

Uma coisa estranha que conferi nos arquivos do Pop!_OS foi que ele não criou a pasta “/efi” no diretório “/boot”, mesmo tendo escolhido a instalação padrão ao invés da avançada. :thinking:

1 Curtida

Quando a BIOS não segura as configurações, desconfio logo da bateria.

Mas, se ele segura outras configurações que você alterou, então o problema não deve ser esse.

Em todo caso, não custa nada verificar.

2 Curtidas

E como eu verificaria? Usando outra unidade no lugar? :thinking:

Bem visto esse detalhe. Como o BIOS precisa ficar configurado certo para os sistemas funcionarem corretamente, depois que desliga e liga no outro dia acontece problemas, o suspeito agora é a bateria CR2032!

Esse é um detalhe que sempre deixo passar, eu tenho de aprender isso, Hardware… Ficamos tão “avançados” focados no Software e de repente é o Hardware que esta sofrendo.

Troca a bateria para fazer os testes.

2 Curtidas

Ok, mas… Ela retem os ajustes.

Por exemplo: a mobo tem uma faixa de led que dá para configurar se deixa-a acesa ou apagada. No meu caso eu deixo apagado. Também já fiz ajustes de ordem de boot, e alguns outros itens na BIOS e eles sempre são salvos (o horário também mostrado corretamente sempre que entro na BIOS), exceto o CSM, não sei porque.

Não faz sentido ser a bateria, não acham?

2 Curtidas

Também achei que não deveria ser, caso outras configurações permaneçam conforme você alterou.

Sim, comprando outra bateria e trocando.

Custa pouco, e se não resolver você pode guardar para usar no futuro, quando precisar.

2 Curtidas

Caros colegas, tenho ótimas notícias! (FINALMENTE! :laughing:)

Eu gostaria detalhar as coisas que eu fiz até chegar a solução (não definitiva, ainda), mas levaria muita digitação, tempo e não seria nada prática, eu acredito. Além da solução do problema do Grub, eu tive problemas secundários que também irei mencioná-lo e também como corrigi-los. Colocarei as fontes também.

NOTA: A PARTIÇÃO DO MEU NVME ESTAVA EM MBR (EXPLICAREI SOBRE ISSO NA POSTAGEM SEGUINTE).

1 - COMO FAZER O GRUB APARECER NO POP!_OS

Execute os comandos (do mesmo vídeo que aparece no tópico sugerido por @RuKsu) :

sudo apt install grub-efi grub2-common grub-customizer
sudo grub-install

Observação: caso e “grub-install” dê o erro:

Installing for i386-pc platform.
grub-install: error: install device isn't specified

Não se preocupe. (Talvez seja porque a instalação do sistema não ocorreu em “efi”, e sim em “legacy - BIOS”.)

Abra o “Grub Customizer”, acesse a aba “General settings” e clique em “advance settings”.

Em “GRUB_TIMEOUT_STYLE”, o “value” estará “hidden”, mude para “menu” e também em “GRUB_TIMEOUT” coloque algum número que será o tempo em que o Grub permanecerá na tela caso não interaja com; nesse caso, deixei 10 segundos.

Clique em “close” e em seguida clique em salvar no topo à esquerda da janela principal da aplicação.

Reinicie o computador e confira se aparecerá (vai aparecer, sim! :wink:) E aqui está a fonte da solução.

2 - COMO FAZER APARECER MAIS DE UMA DISTRO NO POP!_OS

Eu instalei o Linux Mint em opções avanças ao invés de instalar ao lado (e não sei se uma distribuição diferente de Debian irá funcionar para essa solução). Eu apenas criei uma partição para o instalar o “/” do Mint.

Provavelmente você inicializará no Pop!_OS, após reiniciar o computador depois da instalação bem sucedida do Linux Mint.

Execute, portanto, esses comandos no terminal:

sudo update-grub
sudo apt install os-prober

Abra o “Grub Customizer” novamente e aguarde alguns segundos. Provavelmente ele irá atualizar sozinho a aba de lista de configurações. Pressione no ícone de refresh, se necessário. Clique em “Save” e feche a aplicação.

Rode no terminal novamente para conferir se a distro foi adicionada.

sudo update-grub

image

Reinicie o PC e tenho certeza que irá funcionar as alterações!

3 - COMO CONSERTAR ERRO "A start job is running for dev-disk-by x2duuid…"

Fiz uma breve pesquisa antes de digitar as linhas seguintes e já existe solução conhecidas para esse problema em PT-BR no fórum “Viva o Linux”, mas eu me basei no tópico desse fórum e desse.

Ele acontece quando você altera o tamanho da partição de swap que ambos as distros irão usar no instalador da distro a ser instalada, o que irá mudar a identificação UUID da partição swap.

Você provavelmente precisará aguardar 1,5 minuto para conseguir acessar a distro a ficar com o conflito da UUID da swap (no meu caso, era o Pop!_OS).

Para solucioná-lo, primeiro abra aplicação “Disk” (“Disco”, traduzida) ou similar na sua distro, e ache o “nome” UUID da partição swap.

image

Agora abra o terminal e execute:

sudo gedit /etc/crypttab

Em “UUID=”, apague a sequência depois do igual, copie a UUID da partição swap no “Disk” e cole no espaço que acabou de apagar. Clique em salvar e reinicie a máquina (não ligue para o aviso que aparecer no terminal após fechar o documento). Tenho certeza que terá conseguido resolver o problema.

Atualizando: se caso deseje que o sistema volte a usar essa partição como Swap, faça os passos seguintes:

No terminal: execute:

sudo gedit /etc/fstab

No última linha da nota você provavelmente perceberá que ela se refere a partição Swap que, provavelmente, estará sem a UUID desse tipo de partição. Portanto, copie novamente a sequência UUID da partição Swap e cole em frente ao sinal de igual “=” da UUID. Exclua caracteres se não tiverem espaço ao lado do sinal. Deverá ficar parecido com a imagem (não ligue caso a sua nota tenha “/boot/efi”, diferente de mim):

Por fim, salve a nota e reinicie seu computador para tornar as alterações 100% funcionais.

(Pode ser que, ao entrar na tela de início, após reiniciar, seja pedido, numa tela parecido com a do terminal, que você insira a sua senha. Faça o que se pede e tudo ficará funcional.)

(Me levou um tempão pra concluir esse post, rsrsr.)

2 Curtidas

Sobre o meu armazenamento NVMe estar formatado em MBR, isso aconteceu quando fui instalar o Pop!_OS no modo “automático”, e por algum diacho de motivo, ele não quis formatar em GPT (e não houve sinalização quando a isto, pelo menos eu não percebi na hora de instalar).

Isso é estranho, já que na vez que instalei o Ubuntu, ele instalou em GPT normalmente.

Agora resta saber se todas as soluções acima funcionarão com o disco em GPT, o que farei depois de fazer os tais testes no Mint.

Aguardem que volto com os resultados.

E eu tentarei a dica da bateria sim, @frc_kde!

1 Curtida

Novas atualizações sobre o problema! Elas não são animadoras. :neutral_face:

Eu tinha visto em outros fóruns. quando comecei a tentar encontrar respostas para esse problema, de que as GPUs possuem também a configuração de compatibilidade de BIOS ou UEFI.

Isso significa que, dependendo da configuração da placa gráfica, pode ser que seja impossível conseguir estabelecer um ambiente UEFI puro. E é isso o que está (muito provavelmente) acontecendo comigo.

Apesar da Radeon RX 570 ser de 2017 (uma situação que deveria somente acontecer com placas antigas, AMD), ela não parece possuir a compatibilidade de funcionar em um ambiente UEFI puro. Por isso o “CSM Support” sempre retornar a ficar ativo, mesmo após desabilitá-lo e ao salvar as configurações (ainda não fiz o teste da bateria, mas a causa do problema para fazer mais sentido com que descrevo). Infelizmente, não consegui fazer o teste de desabilitá-lo sem a placa de vídeo na MOBO, pois a saída de vídeo integrada que funciona é de conexão DVI, justo um cabo que não tenho (a saída HDMI somente funciona caso o processador tenha vídeo integrado, o que não é o meu caso - pelo menos foi isso o que entendi ao ler o manual, na página 6).

Parece que não sou único com esse problema, visto esses tópicos do site Tech Power Up (esse aqui é bem recente, foi postado hoje mesmo, no momento, sem solução) e do site Linus Tech Tips (também recente). O que é estranho, no entanto, que essa placa apresenta suporte a UEFI, nesse site. e também no link do "Tech Power Up, na imagem que mostra as configurações da Radeon RX 550 (no caso de lá). Outro e último ponto que gostaria de comentar é que no site da RX 570 vendido pela PCYES (que é a GPU que tenho), não há nada que cite suporte a UEFI por parte da placa, ao contrário do site da PowerColor.

Isso tudo é… Desanimador. :disappointed:

2 Curtidas

Caros colegas, acho que o tópico se encerra com a seguinte atualização.

Na verdade, o tópico foi já solucionado nesse post:

E quanto a impossibilidade de mudar a opção CSM da minha placa mãe, também já fora aqui:

No penúltimo post em relação a esse que digito, eu disse que iria testar a soluções que tinha “descoberto” num sistema em EFI, porém, não conseguia de forma alguma instalar o Pop!_OS nessas condições, acredito eu, por conta da impossibilidade de mudar o CSM da BIOS.

No entanto, descobri um modo de forçar a minha máquina a conseguir instalar a distro como se estivesse em um ambiente EFI somente (e a GPU funciona normalmente). Para isso, será necessário utilizar a ferramenta de multiboot “Ventoy”, já coberta pelo próprio grande Dionatan. É bem simples o uso da ferramenta.

No meu caso, eu formatei pendrive em GPT e sem Secure Boot ativado (já que com, a ferramenta não funcionou como deveria). Talvez haja necessidade de fazer esse procedimento para o funcionamento pleno (no meu Note é necessário). Enfim, o resto do uso da ferramenta é coberta no vídeo.

Ah, sobre a configuração do Systemd-boot, é bem simples, pelo menos foi comigo. O que tive que fazer foi ficar pressionado a tecla “barra de espaço” ante de iniciar o Pop!_OS e pressionar “Shift” + “=” para adicionar um tempo em segundos para o bootloader aparecer, parecido com o Grub. Mais detalhes, no próprio artigo da System76, em “Switching between Pop!_OS and Windows”.

Espero que eu consiga ajudar os futuros sortudos com esse mesmo problema através desse tópico.

2 Curtidas