Ubuntu + Gnome Box

Fala pessoal, boa tarde. Não sei se tiverem oportunidade ou se comentaram aqui sobre o Video do Dio referente ao BOX. Eu particularmente gostei e testei o BOX. Achei muito bom, mas fiquei com uma duvida. Eu estou usando o ubuntu e particionei o Hd para deixar uma partição especifica para montar as máquinas virtuais, mas o BOX não deixa escolher essa partição como disco da VM. Aparentemente ele considera a partição do Home e pronto…

Alguém que conheça mais o BOX sabe como eu posso fazer ele escolher outra partição como disco da VM ?

Abraço a todos !

Dá uma olhada neste tópico:

Ifmoreno,

Apenas para que outros possam acompanhar aqui, eu tentei a solução postada, com o link simbólico, mas infelizmente não funcionou.

O Boxes parece necessitar estar ou na mesma partição ou simplesmente não aceita link simbolico, não sei.

Vou procurar postar no git do gnome-boxes uma sugestão para que em próximas versões eles deixem escolher onde você quer instalar a máquina virtual.

Obrigado de qualquer forma.

Att.

Gilberto

Esta seria a melhor solução, claro.
Reveja o post acima, principalmente a postagem do @henriquead7
Veja se seu Boxes está em deb/rpm ou flatpak.
Os links simbólicos funcionam, sim. Com certeza. Sempre usei assim.

1 Curtida

Instalou via flatpak? Se sim vai ser necessário sobrescrever as permissões da sandbox pra acessar a partição externa:

flatpak override <package_name_here> --filesystem=<path_here>

AÍ você faz o symlink citado pelo @lfmoreno

Não da forma que ele está fazendo, basicamente isso não seria um furo na sandbox, seria um arrombo, quando se toda um app flatpak todo symlink vai apontar para ando dentro da sandbox, nunca fora dela (ou pelo menos deveria ser assim), o problema é que (pelo menos aparentemente) ele não forneceu acesso à partição para o flatpak

2 Curtidas

Sim, concordo.
Nunca usei o Boxes em flatpak.

1 Curtida

Natanael,

realmente a instalção é via Flatpak.
Eu tentar sobrepor as permissões como você está falando.

Assim que fizer eu aviso o resultado aqui… Obrigado !

1 Curtida

Natanael e Lfmoreno, boa noite.

No fim eu achei melhor desintalar via Flatpak e instalar .DEB.
Dessa forma funcionou bem com o link simbolico !

Obrigado pela ajuda de vocês !

2 Curtidas