Soluções para o fone de ouvido funcionar no Linux Mint

Bom dia/boa noite pessoal, eu instalei o Linux mint na minha máquina, achei muito ótima a distribuição, no entanto estou tendo muitas dúvidas em relação ao meu driver de áudio. Primeiro de tudo, o driver que funciona no windows é para o chip de áudio VT1075 da Via Technologies, que até onde vi, não existe para Linux, e eu tenho o .exe ainda; segundo, de qualquer forma que eu configure o sistema na parte de som para reproduzir no fone de ouvido ou caixa de som, ele reproduz na caixa de som e no fone de ouvido simultaneamente, ao invés de só no fone de ouvido quando está plugado ou configurado para reproduzir no fone de ouvido; terceiro, vi no Google sobre o alsamixer, que me parece ser um controlador universal do som do sistema, não sei explicar direito. Assim, pergunto a vocês:

— Como eu não vi o mesmo driver do Windows para Linux, seria possível instalar o .exe ou as informações dele, para funcionar o software de áudio no mint?

— Sobre o alsamixer, eu consigo configurar via terminal, o som somente no fone de ouvido e não na caixa de som, diminuindo totalmente a coluna “front” e deixando só a “headphone”. Seria possível fazer essas alterações automaticamente, para silenciar a “front” sempre que eu plugasse o fone de ouvido? Configurar tudo manualmente, toda vez que quero o som reproduzindo na caixa de som/fone de ouvido não me parece algo agradável.

— Vi também no Google, que se tivesse como habilitar a coluna “independ” (no alsamixer), iria resolver o meu problema, porém, toda vez que tento ativar, não ativa, continua desabilitado. Há uma opção para contornar esses problemas de alguma forma? Minha intenção, é deixar com que o Linux mint identifique quando eu plugasse o fone de ouvido, silenciasse a caixa de som, deixando a reprodução só no fone de ouvido. Ou, pelo menos, um botão para silenciar a caixa de som quando eu quisesse o som só no fone de ouvido, pois atualmente, ele reproduz nos dois ao mesmo tempo.

2 curtidas

Vamos por partes:

Não dá para instalar drivers de Windows em Linux, e nem precisa pois os drivers já estão no kernel por padrão.

Tenho um PC com placa de áudio da VIA e funciona normalmente.

Na questão da saída de som faça o seguinte:

No terminal:

sudo apt install alsa-utils

alsamixer

selecione a sua placa apertando f6

aperte f5 para aparecer todas as opções

navegue para o lado e ative a opção “auto-mute”

2 curtidas

Aqui, não aparece a coluna “automute”, nem após apertar o F5.

Em ordem, só aparece essas colunas, respectivamente (algumas não aparecem no print):

“Master; Headphone; PCM; Front; Front Mi; Surround; Center; LFE; Line; S/PDIF; S/PDIF D; S/PDIF 1; Beep; Capture; Capture; Channel; Digital; Dynamic; Independ; Input So; Input So; Loopback e Rear Mic.”

1 curtida

Olá @MaylaVettel seja bem-vinda ao Diolinux Plus :wave:t2: É parente do Sebastian Vettel? :relaxed:

Sou um pouco leigo em Mint mas você consegue chegar nesta janela(pavucontrol):

pavucontrol

Se caso não talvez se instalar ela, da para resolver via GUI o comando no terminal é:
sudo apt-get install pavucontrol

:pray:t2:

2 curtidas

Humm, então por algum motivo o seu sistema só está reconhecendo 1 saída…

Olha o meu:

Vou dar uma pesquisada e depois volto aqui.

2 curtidas

Manda aí:

cat aplay -l

1 curtida

Olha @RuKsu , instalei o pavucontrol, agora tenho um maior controle do áudio. Notei que em “dispositivos de saída” (output devices), possui a opção “porta”, que dá pra selecionar (aqui no meu computador em específico) “fones de ouvido” e “saída de linha (plugged in)”.

Quando seleciono o “fones de ouvido”, a música sai no fone de ouvido e na caixa de som. Quando seleciono “saída de linha (plugged in)”, a música sai apenas na caixa de som (era isso que eu precisava só que ao contrário!), com a diferença que na caixa de som fica mais alto que em relação a opção “fones de ouvido”, que a caixa de som fica mais baixa.

Na aba “Configuração” (configuration), me aparece “perfil” (profile) com um monte de opções. Apenas uma, que é a “Duplex Estéreo Analógico” funciona.

Tem alguma ideia do que pode estar acontecendo?

2 curtidas

Saída:

"cat: opção inválida -- “l”
Tente "cat --help" para mais informações."

1 curtida

Oops, o comando é só
‘aplay -l’

1 curtida

Saída:

1 curtida

Bom isso é um glitch que teriamos de resolver por configurar o default.pa. No terminal execute o comando:
xed admin:///etc/pulse/default.pa e mostre para nós o resultado.

1 curtida

Saída do terminal:

mayla99654@maylavettel-pc:~$ xed admin:///etc/pulse/default.pa

(xed:8234): dbind-WARNING **: 23:09:30.765: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

** (xed:8234): WARNING **: 23:09:31.814: A localização especificada não está montada

Abriu também um editor com um arquivo de texto. Devo mandar aqui também?

1 curtida

Yep, puder nos enviar os dados do bloco de notas. Iremos examina-lo e descobrir o bug, pois existem várias formas de tentativa de resolução. :pray:t2:

1 curtida

Aqui:

/etc/pulse/default.pa
#!/usr/bin/pulseaudio -nF
#
# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify it
# under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.

# This startup script is used only if PulseAudio is started per-user
# (i.e. not in system mode)

.fail

### Automatically restore the volume of streams and devices
load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore

### Automatically augment property information from .desktop files
### stored in /usr/share/application
load-module module-augment-properties

### Should be after module-*-restore but before module-*-detect
load-module module-switch-on-port-available

### Use hot-plugged devices like Bluetooth or USB automatically (LP: #1702794)
.ifexists module-switch-on-connect.so
load-module module-switch-on-connect
.endif

### Load audio drivers statically
### (it's probably better to not load these drivers manually, but instead
### use module-udev-detect -- see below -- for doing this automatically)
#load-module module-alsa-sink
#load-module module-alsa-source device=hw:1,0
#load-module module-oss device="/dev/dsp" sink_name=output source_name=input
#load-module module-oss-mmap device="/dev/dsp" sink_name=output source_name=input
#load-module module-null-sink
#load-module module-pipe-sink

### Automatically load driver modules depending on the hardware available
.ifexists module-udev-detect.so
load-module module-udev-detect
.else
### Use the static hardware detection module (for systems that lack udev support)
load-module module-detect
.endif

### Automatically connect sink and source if JACK server is present
.ifexists module-jackdbus-detect.so
.nofail
load-module module-jackdbus-detect channels=2
.fail
.endif

### Automatically load driver modules for Bluetooth hardware
.ifexists module-bluetooth-policy.so
load-module module-bluetooth-policy
.endif

.ifexists module-bluetooth-discover.so
load-module module-bluetooth-discover
.endif

### Load several protocols
.ifexists module-esound-protocol-unix.so
load-module module-esound-protocol-unix
.endif
load-module module-native-protocol-unix

### Network access (may be configured with paprefs, so leave this commented
### here if you plan to use paprefs)
#load-module module-esound-protocol-tcp
#load-module module-native-protocol-tcp
#load-module module-zeroconf-publish

### Load the RTP receiver module (also configured via paprefs, see above)
#load-module module-rtp-recv

### Load the RTP sender module (also configured via paprefs, see above)
#load-module module-null-sink sink_name=rtp format=s16be channels=2 rate=44100 sink_properties="device.description='RTP Multicast Sink'"
#load-module module-rtp-send source=rtp.monitor

### Load additional modules from GSettings. This can be configured with the paprefs tool.
### Please keep in mind that the modules configured by paprefs might conflict with manually
### loaded modules.
.ifexists module-gsettings.so
.nofail
load-module module-gsettings
.fail
.endif


### Automatically restore the default sink/source when changed by the user
### during runtime
### NOTE: This should be loaded as early as possible so that subsequent modules
### that look up the default sink/source get the right value
load-module module-default-device-restore

### Make sure we always have a sink around, even if it is a null sink.
load-module module-always-sink

### Honour intended role device property
load-module module-intended-roles

### Automatically suspend sinks/sources that become idle for too long
load-module module-suspend-on-idle

### If autoexit on idle is enabled we want to make sure we only quit
### when no local session needs us anymore.
.ifexists module-console-kit.so
load-module module-console-kit
.endif
.ifexists module-systemd-login.so
load-module module-systemd-login
.endif

### Enable positioned event sounds
load-module module-position-event-sounds

### Cork music/video streams when a phone stream is active
load-module module-role-cork

### Block audio recording for snap confined packages unless they have
### the "pulseaudio" or "audio-record" interfaces plugged.
.ifexists module-snap-policy.so
load-module module-snap-policy
.endif

### Modules to allow autoloading of filters (such as echo cancellation)
### on demand. module-filter-heuristics tries to determine what filters
### make sense, and module-filter-apply does the heavy-lifting of
### loading modules and rerouting streams.
load-module module-filter-heuristics
load-module module-filter-apply

### Make some devices default
#set-default-sink output
#set-default-source input
2 curtidas

Problema estudado, vamos aos primeiros testes.

La no pavucontrol selecione fone de ouvido e mantenha selecionado e com o plug conectado também, só para checar.
No terminal execute aquele comando xed admin:///etc/pulse/default.pa
No bloco de notas você vai chegar

(i.e. not in system mode)

.fail

Entre estas 2 linhas você vai colar os seguintes comandos:

### Load analog device
load-module module-alsa-sink device=hw:0,0
load-module module-combine-sink sink_name=combined
set-default-sink combined

Vai ficar assim:

# (i.e. not in system mode)
### Load analog device
load-module module-alsa-sink device=hw:0,0
load-module module-combine-sink sink_name=combined
set-default-sink combined
.fail

Depois você salva e no terminal executa o comando pulseaudio -k

Então faça os testes no pavucontrol para ver se resolveu. Senão reinicia a máquina e caso contrário vamos procurar outras soluções.
:pray:t2:

1 curtida

Calma, no meio dessas duas linhas?

Captura de tela de 2021-02-08 23-50-07

1 curtida

Yup. Certifica que no pavucontrol está selecionado o phones de ouvido.

1 curtida

Depois que eu fiz isso tudo, a configuração “fones de ouvido” e o resto, sumiu.

1 curtida

:joy: onde está o .fail troca para .nofail e roda o comando pulseaudio -k denovo. Mas antes disso, talvez precise reiniciar a máquina para puxar os novos modulos.

1 curtida

Okay, vou fazer aqui, obrigada, volto em instantes com novos resultados.

2 curtidas