[RESOLVIDO] [Ubuntu 20.04] Travando com processador em 100% de Uso

Contexto:

Travamento total do sistema ao abrir 4 ou mais aplicativos juntos

Equipamento:
Lenovo Ideapad 310,
Proc: i3 6100U, 2.30Ghz x 4 (2 Core físicos + 2 Core virtuais - 4 Threads),
RAM: 4 GB
SSD 240
Grafico: Intel HD 520 (Integrado)

Problemas percebidos
Quando abro o Chrome + zoom + terminal (ou Chrome + outro programa) ele trava total. Ao monitorar o sistema constato o uso dos 4 núcleos do processador em 100% quando o sistema trava. A memória permanece com um uso de aproximadamente 60%.O sistema travou de vez quando tentei assistir a aula no curse da trybe + slack + terminal. Ainda não consegui reparar…

Sistema:
Ubuntu 20.04 Lts em dual boot com Windows 10
O particionamento foi feito deixando 100 Gb para windows, 50 GB para o /, e mais ou menos 90 Gb para o /home.

Configurações que já fiz tentando resolver:

  • Peload
  • Remover itens desnecessários da inicialização
  • Remover animações com o gnome tweak tools
  • Desabilitar pesquisa
  • BleachBit
  • Ajustar o Swap para ativar a 90% da RAM
  • Aumentar o swap para 3GB
  • Instalação do zRam para otimizar a troca com Swap
  • Remoção de pacotes snaps e da loja snapd

Estou aceitando sugestões de outras distros que sejam mais leves :blush:

2 curtidas

Mint Cinnamon?

1 curtida

@EduRibeiro, olha na aba processos e veja o que anda comendo o processamento da CPU. Aí coloca aqui pro pessoal olhar e te aconselhar sobre o que fazer

2 curtidas

Blz, vou dar uma olhada :wink:

1 curtida

Gente esses são os processos quando o sistema fica prestes a travar. Processador atinge 100% de uso.

@Kogane sobre o Mint você consegue me passar o link de download dessa distro? Gostaria de testar. :blush:

Olha, teu Chrome comer 25% do processamento tá abusado! E o processo apontado é de renderização - imagino que esteja ativada a aceleração por hardware (ou o contrário). Experimente duas coisas:

  1. Abrir as mesmas abas do Chrome no Firefox e veja se há diferença
  2. Desativar (ou ativar) a aceleração por hardware

Daí coloca aqui os resultados

Linux Mint: https://www.linuxmint.com/

3 curtidas

Espelho de São Carlos
Espelho de Brasília
Espelho do Paraná

Escolha o que está mais perto de você, para uma taxa de download mais alta.

1 curtida

Mas tem o seguinte: antes de trocar de distro, precisa resolver o problema do uso de CPU, ou o mesmo irá se repetir em qq distro que seja…

2 curtidas

Obrigado @Rodrigo_Chile e @Kogane vou fazer os testes com Firefox e verificar a aceleração e posto aqui o resultado

2 curtidas

Quando for testar com o Firefox, recomendo desinstalar o chrome pois mesmo fechado ele consome alguns recursos da máquina.

1 curtida

Ou reinicia o PC, antes de abrir ele é inofensivo.

2 curtidas

Antes de tentar ajudar a solucionar é importante esclarecer uma coisa! Se vc instalou o Ubuntu e ele fica travando, a causa não é porq veio app X ou Y. Um computador não deve congelar por isso! Algo realmente está errado. Agr a pergunta: Ele congela completamente, sendo que vc precisa desligar no botão de energia?

2 curtidas

@anon71873041 obrigado por somar.

Sim ele chegou a travar a ponto de ter que desligar no botão de energia. Isso aconteceu umas 4x e todas o Chrome estava aberto junto com outros 3 ou 4 programas (slack, terminal, zoom, Spotify… etc). Também percebi que quando eu reproduzia algum vídeo ou abria mais de uma aba o estado piorava a ponto de congelar tudo.

Após o colega @Rodrigo_Chile pedir os processos percebi que existem dois processos do Google um renderer e outro GPU… Somando os dois da 35% de processador… Percebi que ao abrir um vídeo no YouTube os processos sobem para 49%.

Eu estou desconfiado mesmo que há uma má configuração da GPU que faz esses processos consumirem tanto…

vou tentar alterar a aceleração por hardware

1 curtida

Como tua GPU é dedicada, quem “carrega esse piano” é o processador… e nem sempre ele aguenta o tranco. Sem contar que o Chrome, com seus processos rodando em segundo plano, é comilão de RAM, daí joga pra swap, o que lerda as coisas… foi o que recomendei, testa com outro navegador, modifica aceleração por hardware, até achar o ponto ideal de uso

1 curtida

Não acredito que o problema esteja no Chrome. Uso um Notebook muito mais fraco que o seu (intel N3010 Celeron) e uso tanto o Chrome como o Firefox com aceleração de hardware e não tenho problema algum de congelamento. Recomendo vc tentar aplicar a flag “intel_idle.max_cstate=1” no arquivo /etc/grub/default para ver se os congelamentos vão continuar a ocorrer.
Se tiver duvidas sobre como aplicar o que falei avisa aqui q eu ensino.

2 curtidas

Sei que isso não é a causa principal dos travamentos no seu PC, mas eu aconselho a usar o ZSWAP em vez do ZRAM. Ele trabalha de forma similar ao ZRAM, mas de uma forma mais inteligente. Em vez de comprimir tudo na RAM e só usar a SWAP quando não tem mais memória, ele faz um gerenciamento melhor do que vai ficar comprimido na memória RAM e do que vai para a SWAP. Assim há um aproveitamento melhor da memória e da SWAP. Dê uma olhada neste artigo:

1 curtida

Galera eu consegui alguns resultados interessantes aqui, vou colocar listado todas a modificações que fiz.

  1. Ao digitar em uma nova guia “chrome://gpu/” acessei minhas configurações de GPU no Crhome, estavam assim:

    Aceleração por hardware Chrome

    • Fui em “chrome://settings/system” e desabilitei aplicativos em segundo plano e habilitei a aceleração por hardware.
  2. Também fiz alterações no “chrome://flags/

    • Ativei as opções “GPU rasterization”, “Hardware-accelerated video decode”, ao acessar o
      chrome://gpu/” novamente as configurações fcaram assim:
      Nova config GPU

    • Pra finalizar em “chrome://flags/” ativei também a opção " Destroy Profile on browser close" para liberar memória quando o fechar as abas.

  3. Depois abri simultaneamente os seguintes apps:

    • Terminal rodando um apt update
    • Zoom em uma reunião
    • Slack
    • Spotiffy
    • Chrome com umas 7 guias rodando vídeos em duas delas e outras com Google Earth
    • Captura de tela
    • Monitor do sistema
    • Visual Studio Code (só a interface)

Pra minha surpresa não travou o sistema, os videos rodaram e o zoom não picotou o áudio, mas o processador foi as alturas também, porém isso era esperado.

Esses foram os resultados:

(Quanto ao print do gráfico eu mando como resposta aqui, por que sou usuário novo e tenho limite de 3 mídias por mensagem)

Vou continuar testando, mas por enquanto não travou mais!

2 curtidas

O gráfico ficou assim, lá em cima.

Mas pelo menos não está travando :joy:. Super estranho pra mim esse comportamento. :ok_man:

1 curtida

Legal, obrigado pela dica, vou implementar também, :wink:

Legal quero testar também essa possibilidade, mas realmente não sei como aplicar :sweat_smile:.

Help :sweat_smile: