Problemas na Instalação do Manjaro 21.1.0 no modo UEFI com Dual Boot

Esta é a primeira vez que tenho um problema que me faz recorrer a um forum por isso, vou tentar explicar da melhor forma e a mais detalhada possível. Espero que alguém possa me ajudar.

Sempre utilizei sistemas com tabela particão em MBR, já troquei de S.O de todas as formas possíveis experimentei vários tipos de particionamentos e nunca tive problemas nem dificuldade. Mas recentemente me atualizei e passei a utilizar um SSD com particionamentos em UEFI.

Meu notebook veio com Windows (pra variar) e um SSD e possibilidade de instalar um HDD. Foi o que eu fiz para manter meus arquivos pessoais. Ao lado do Windows, instalei o Ubuntu e o Particionamento ficou da seguinte forma:

Agora resolvi usar o Manjaro com KDE. Acho uma distro um tanto que “enjoada” para instalar em dual boot. Pela internet encontro vários tutoriais mas poucos que tratam casos específicos.

Ao tentar formatar a partição Raiz do ubuntu para instalar o Manjaro, Mantendo a /Home sem formatação e a /boot/efi sem formatação o calamaris desmarca, não deixando formatar a raiz ou criar rótulos para as partições. ao tentar prosseguir com a instalação ele mostra a seguinte mensagem.

  • Mesmo sinalizando para usar tais partições.
  • Eu já desmarquei o secure boot e o fast boot na bios.
  • O Notebook é um Acer Aspire 3 com GPU + APU
  • Eu marquei a partição formatada em Fat32 como /boot/efi e sinalizei como boot mas não tem opção no instalador do Manjaro para sinalizar como ESP.
  • Partição com ubuntu marcada para formatar e sinalizada como “/”
  • Partição Swap sem alteração
  • Partição /home sinalizada para uso mas sem formatação
  • Duas Partições reservadas para windows um com sistema, outra reservada pelo sistema
  • Uma Partição com arquivos de recuperação vinda de fábrica.
  • Uma partição com /boot/grub (Não lembro o motivo de ter criado a partição do grub separada, se foi receio de formatar a partição EFI ou foi seguindo algum tutorial)

Enfim, estes são os detalhes que consigo lembrar.

Opa, na máquina virtual eu faço assim e funciona, a VM está setada em uefi

Ali onde está bios-grub, deve-se marcar “boot” (ao marcar o que está ali, deu erro, aí refiz e foi)

E está instalando:

EDIT: Lembre-se de NÃO formatar a partição boot/EFI, ou o bootloader do Windows vai embora!

2 curtidas

Agradeço mas é exatamente isso que estou tentando fazer. Com a diferença que a partição raiz já existe , com ubuntu instalado e quando marco ela para formatação, ela desmarca sozinha e fica em “Manter” depois que clico em OK. A mesma coisa acontece se eu tentar criar um rótulo para nomear a unidade o rótulo desaparece. Já a Partição EFI eu sinalizo ela da maneira como descreveu mas é exibido pra mim a mensagem da foto, como se eu não tivesse selecionado partição de boot.

1 curtida

Se não dá certo, o jeito pode ser fazer instalação lado a lado e depois marcar a partição correta como home - veja como aqui:

Pelo que eu andei pesquisando em fórum gringo, outros usuários estão relatando problemas com a versão do calanares usado no manjaro. Calamares adding incorrect flags during manual partitioning on /boot/efi partition

O jeito agora é esperar.

1 curtida

Voltando aqui para compartilhar a solução do meu problema. Aparentemente o instalador não “aceitava” a partição de 100 mb. Então, eu criei uma nova partição de 500 mb, particionada em fat32, ponto de montagem /boot/efi e sinalizada com “boot” somente. as versões atuais do calamaris, não necessita do marcador “ESP” .

Uma vantagem é que pude deixar a antiga partição de 100mb que continha o inicializador do windows intocada, assim, qualquer problema que pudesse ocorrer, seria simples voltar a etapa anterior. Após isso, foi só entrar no setup e colocar o inicialiador do manjaro em primeiro e tudo ocorreu bem.

Um adendo. Não sei por qual motivo, mas continua aparecendo a entrada do ubuntu no setup e a do manjaro não foi reconhecida pelo nome. Eu gostaria de corrigir isso, se alguém douber e tiver a solução, ficarei satisfeito, por ora, dou como assunto resolvido.

1 curtida

Por qual das entradas na BIOS o sistema tá carregando? Descobre isso e procura aqui no fórum um tópico sobre o efibootmgr que isso deve resolver tua dúvida como remover entradas obsoletas na BIOS

1 curtida

Ele entra por uma entrada desconhecida (Não detectou o nome) mas eu sei que é do manjaro. Ficando assim:
1 - Nome desconhecido (Grub, inicia normal, dual boot mas não funciona com secure boot)
2 - Windows
3 - ubuntu (que já foi removido mas a entrada manteve)
4 - hdd1 (Os sistemas estão instalado no ssd e tenho um hdd secundário com arquivos comuns, não sei porque surgiu uma entrada para ele agora)

Quando usava o ubuntu, aparecia somente a entrada dele e a do windows, como deveria ser. Não sei se é questão de popularidade mas percebo o quanto o Manjaro é “enjoado” no sentido se não ser um sistema pra quem começou agora no mundo linux. Eu que já sou usuário a bastante tempo, ainda quebro a cabeça.

Se não te incomodar, nem precisa se preocupar em renomear a entrada. O principal seria se livrar da entrada desnecessária do Ubuntu. Pra isso, segue o tuto abaixo:

E lembre-se, o Grub Customizer é uma furada em distros base Arch (aprendi isso a duras penas, tive de reinstalar o Garuda depois de um tópico com mais de uma centena de respostas e sem solução). Ok, eu sou suspeito pra falar (o título de Mago não corresponde aos meus reais conhecimentos, mas aceito a brincadeira), mas dps que fui pro Manjaro, passou a ser raro ter problemas e uso o terminal muito raramente (basicamente pra atualizar flatpaks quando o pamac pede e só tem deles pra atualizar, acaba sendo mais rápido)

1 curtida

Obrigado Rodrigo_Chile, ajudou bastante.
Realmente. Também tive problemas com o Grub Customizer em distros base Arch. Em especial o manjaro. Ele removeu a entrada do windows do grub na época que eu tinha 4 boot. O Mint que salvou.

1 curtida

Então a solução, foi basicamente alterar o tamanho da partição para 500 mb?

Isso mesmo. Lembrando que criei uma nova partição, assim, a partição que contém o inicializador do windows fica intocado.

1 curtida

Entendi, estava tendo o mesmo problema um dia desses, mas não me importei. Só avancei na instalação ahuahuahua, próxima vez que eu formatar mudo o tamanho da partição.

Sabe o que me deixou intrigado? Minha partição EFI foi criada pelo W10 automaticamente, tem 100 MB e 3 bootloaders, sem nenhuma das duas distros, Manjaro e Garuda, ter reclamado disso - fiz instalação manual e foi tudo OK (hahaha… descobri duas entradas ali à toa, dps vejo como deletar, ou não)

image

Se deletar e não der problemas, compartilha aqui.

Acho que seria com o efibootmgr, vou pesquisar como faz e digo

é só montar a partição efi e apagar sem pena, se houver entradas na bios removas com efibootmgr.

1 curtida

Farei a pesquisa e procederei cautelosamente, mas creio que é isso mesmo!

Eu criei esse tópico com uma dúvida em relação a instalação do Manjaro em Dual Boot substituindo uma distro pré instalada, o problema foi resolvido aumentando o tamanho da partição EFI. Em seguida, surgiu outro problema, o nome da distro não ser reconhecido na UEFI. Quando eu seleciono a ordem de boot, o gerenciador do manjaro, fica com nome desconhecido. E agora venho ressuscitar esse tópico pois a resposta para outra pergunta que eu tinha. relacionada a atualização para windows 11 Foi respondida e de quebra descobri a resposta para a dúvida deste post também.



https://wiki.archlinux.org/title/Unified_Extensible_Firmware_Interface/Secure_Boot#Using_a_signed_boot_loader

Aparentemente tem a ver com o kernel das distros baseadas em Arch não serem assinadas.
Isso impede, inclusive delas funcionarem com secure boot ativado.

1 curtida