Problemas com mesa digitalizadora no Pop!OS 20.10

tenho uma wacom intuos S(modelo sem bluetooth) e gostaria de usar ela no linux, o problema é que quando vou usar é como se a área ativa da mesa fosse só a metade da esquerda dela, já vi alguns videos e tentei várias coisas mas não consigo achar uma solução (a mesa funciona normalmente no windows então acredito que não seja defeito ou algo de hardware) alguém poderia me ajudar ?

1 curtida

Olá @pudim :wave:t2:

Esse é configuração do xsetwacom, então da uma olhada neste Tópico do @chimpa_theist:

O nome da mesa esta Huion mas deve funcionar para a Wacom. Está diminuir no Título mas tem um diagrama no final que mostra a Area toda. Qualquer coisa podemos tentar juntos.

Edited: Melhor, Executa este comando no terminal xsetwacom set 8 Area 0 0 44200 27600 Edited/

:pray:t2:

2 curtidas

eu tentei o comando e apareceu isso no terminal “‘Wacom Tablet Area’ does not exist on device.”

1 curtida

Entendo, bom digita no terminal o comando xsetwacom list devices qual será a saida?

eu achei coisas sobre no askubuntu How to configure Wacom tablet area on Ubuntu 14.04? - Ask Ubuntu
eu tava tentando a sujestão do user nephewtom,

usei o comando que vc falou pra ver o nome da minha mesa e depois usei: xsetwacom --get “Wacom Co.,Ltd. Intuos S stylus” Area
que o output foi : 0 0 15200 9500

depois usei o comando: xsetwacom --set “Wacom Co.,Ltd. Intuos S stylus” Area 0 0 15200 9500

mas continuou do mesmo jeito.

tbm tentei o use Rmano falou e n consegui ajeitar. ps: abre o link pra entender

1 curtida

É porque eu passei o comando direto para você sem saber o ID do dispositivo. Daí não funciona. Falha minha :sweat_smile: My bad…

Com o comando xsetwacom list devices não apareceu o ID do dispositivo? O retorno no terminal seria algo com:
HID: 123v:345t any name id: x type: anymodel

Oque está no ID que deve ser colocado no lugar do “8”, do comando direto que te passei:

xsetwacom set "8" Area 0 0 44200 27600

:pray:t2:

1 curtida

xsetwacom list devices

Wacom Co.,Ltd. Intuos S stylus id: 17 type: STYLUS
Wacom Co.,Ltd. Intuos S eraser id: 18 type: ERASER

eu fiz substituindo o 8 por 17 e tudo mais mas só dimnuiu a area, eu fiz o comando de novo usando a resolução que eu peguei anteriormente e continua só a metade da mesa funcionando, estou começando a achar que tem a ver com o meu modelo em especifico pq mesmo quando eu coloco pra ficar mapeado na resolução toda sempre mapeia minha tela inteira só em metade da mesa ent de fato ta mapeada a tela toda mas só em uma parte da area ativa, tipo a “altura” esta proporcionalmente correta mas a “largura” não. obg pela ajuda, vou fazer mais uns testes e ver se consigo resolver só eu acho ._.

1 curtida

Está rodando Xorg ou Wayland? O suporte para mesas digitalizadoras no Wayland ainda é precário

1 curtida

estou rodando Xorg

Estranho, lembro que conseguia rodar meu Wacom Bamboo no Ubuntu sem problema.
No site https://linuxwacom.github.io/, eles recomendam instalar alguns drivers, não sei se você já tentou ou já tem eles.