Problemas com DaVinci Resolve

Estou com problemas na instalação do DaVince Resolve, instalei varias vezes e nao consigo usar, usei o terminal para ver se conseguir resolver ou se descobria oque tava faltando
mas nao conseguir! alguem pode me ajuda??

Olá AlexAllan!

Por favor abre o ficheiro ~/alex/.local/share/DaVinciResolve/configs/log-conf.xml, vê o que está a faltar no log. Caso não entendas, por favor, comprime-o como um zip, arranca e joga o arquivo comprimido aqui exactamente para nós analisarmos.

1 Curtida

Desculpa-me, esqueci-me de aderir “com o editor de texto”.

Não era para executar. Era para abrir com o editor de texto (Gedit, etc.).

1 Curtida

Ahh, tentei te mandar o texto escrito e percebi que nao foi todo, irei manda um print, ok ?

@AlexAllan

AH, esse erro no fim do log mostrou que tu te esqueceste de executar o executável como sudo/root porque ele requer root.

2 Curtidas

então, executei com sudo via terminal e continua com a mesma coisa! mesmo ''erro"! a diferença agora foi que no final apareceu (Aborted)

Tens certeza que executaste o comando assim: sudo /opt/resolve/bin/resolve? A pasta /opt pertence à raiz / que requer acesso por meio de sudo.

Agora entendi, @AlexAllan, temos o mesmo problema. Instalei e testei aqui.

Por favor, lê os tópicos em seguida:

  1. Davinc resolve studio 16 não abre [RESOLVIDO]
  2. DaVinci Resolve não abre no Linux
  3. DaVinci Resolve não retorna erro ao rodar /opt/resolve/bin/resolve

Verifica a compatibilidade de teu processador, tua placa-mãe e de tua placa de vídeo com Proton e Vulkan requeridos pelo DaVinci Resolve. Também verifica se já instalaste todos os pacotes necessários citados nesses tópicos.

1 Curtida

Enfim…
Não conseguir fazer funcionar! li todos os tópicos mas nada deu certo, e acredite o erro aumentou

Podemos saber os detalhes do teu computador? Executa o comando inxi -Fxz no terminal, copia tudo e cola aqui, utilizando os códigos em Markdown:

   Eis os detalhes:
    ```bash
    $ inxi -Fxz
    blablabla
    ```

Intel Core Processor Integrated Graphics vendor: Hewlett-Packard driver: i915

Dual Core model: Intel Core i3 M 350 bits: 64 type: MT MCP arch: Nehalem rev: 5 L2 cache: 3072 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 18087

ta bom :?

De acordo com o artigo de compatibilidade de API Vulkan, parece que sim, mas precisamos saber o nome da microarquitectura do modelo da Intel. Por isso, é preciso passar-nos os detalhes completos.

Como utilizas Ubuntu, por favor instala o pacote inxi:

sudo apt install inxi
inxi -Fxz

hoje uso Distro: Linux Mint 19.1 Tessa base: Ubuntu 18.04 bionic
no Hp G42,notebook, cinnamon 4.0.10…

       CPU: Topology: Dual Core model: Intel Core i3 M 350 bits: 64 type: MT MCP arch: Nehalem rev: 5 L2 cache: 3072 KiB 
       flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 18087 
       Speed: 1464 MHz min/max: 933/2266 MHz Core speeds (MHz): 1: 1383 2: 1250 3: 1000 4: 1172 
        Graphics:  Device-1: Intel Core Processor Integrated Graphics vendor: Hewlett-Packard driver: i915  
        Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa resolution: 1366x768~60Hz 
       OpenGL: renderer: N/A v: N/A direct render: N/A

Tu não instalaste o pacote do OpenGL. Executa os comandos:

sudo apt install binutils-gold build-essential freeglut3-dev g++ libglew1.5-dev libglm-dev libglu1-mesa-dev mesa-common-dev mesa-utils

Então executa o comando:

glxinfo | grep "OpenGL version"

Copia e cola o resultado do OpenGL aqui.

Uau, ta! muito obrigado! to reeditando porque atingi o numero máximo de resposta, kkkk, mas muito obrigado mesmo!

2 Curtidas

Parece que Linux Mint não tem esse pacote. Por isso, acabei de actualizar a resposta, omitindo o pacote inexistente.

1 Curtida

Má notícia, teu computador não é compatível com OpenGL requerido pelo DaVinci Resolve.

Acabei de encontrar os detalhes do teu notebook. De acordo com o site CPU Upgrade – HP642 Intel Corei3 350 M, O nome da microarquitectura desse processador é Westmere.

Tenho outra má notícia: como esse processador é Westmere, de acordo com aquele artigo acerca da compatibilidade de Vulkan API, não é compatível com Vulkan, por isso, DaVinci rejeitou o teu computador e abortou o aplicativo. :frowning:

1 Curtida

Sei que pode ser “Noobisse” da minha parte, mas, será que se instalar uma versão mais antiga do DaVinci Resolve poderia funcionar? Ou é esse requisito do Vulkan + OpenGL não pode ser superado devido à idade do hardware do autor do tópico?

Pergunto, pois tive algumas tentativas de instalar uma versão de linux em um netbook de 2008 e com umas 20 horas de pesquisa e downloads de umas 15 ISOs, consegui configurar tudo o que precisava e evitei que os donos abandonassem aquele netbook, que hoje é a porta de acesso para a internet dos outros 5 PCs, além de ser o servidor de DNS, proxy e filtro Firewall e anti-vírus para a rede desses PCs.

Então, talvez alguma forma de instalar alguma versão do OpenGL pode salvar esse caso do autor do tópico… Será?

2 Curtidas

Olá @MarotoMT!

Sim, é possível que as versões mais antigas dos aplicativos funcionam nos computadores antigos e novinhos. Mas um computador tem de ter um ano ou 2 anos de idade depois de um ano da antiga versão, por exemplo, DaVinci 2007 se encaixa perfeitamente num computador do ano 2008 ou 2009. Também podes utilizar essa versão do ano 2007 nos computadores da última geração cujos não possuem processadores AMD e placas de vídeo NVIDIA Geforce requeridos pelo Vulkan e pelo OpenGL 3 e acima.

Podes utilizar os comandos que passei no comentário nº18.

2 Curtidas