Problema no Grub do OpenSUSE

Boa tarde gente! Eu instalei recentemente o OpenSUSE Tumbleweed na minha máquina. Porém quando eu ligo o pc aparece essa tela:

Eu tinha instalado o Linux Mint anteriormente, mas ele não mostrava essa tela, ele simplesmente iniciava. No caso do OpenSUSE quando eu ligo a máquina ele aparece isso direto (sem ligar o sistema).
E ai para eu carregar o sistema eu tenho que dar F9 para abrir o Boot Manager e selecionar ele. Teria como ele ir direto?

Percebi que mesmo eu fazendo uma formatação total com o OpenSUSE a opção de boot do Mint ainda está lá.

Se puderem me ajudar ficarei grato.

UEFI ou Legacy? Usou qual programa para criar o pendrive de boot?

Vamos lá:

  1. Na BIOS, procura pela entrada OpenSUSE e marque-a como primeira opção de boot. Isso deve resolver o problema com o grub;
  2. Olha o tutorial sobre remover entradas obsoletas de grub na BIOS e tira a entrada do Mint
2 curtidas

UEFI. No caso eu usei o programa próprio do Linux Mint para fazer o pendrive.

Eu fiz o processo deste tutorial mas não funcionou, parece que ele não “salva” não aplica…

Quanto a BIOS, eu achei essa opção porém não tem como trocar a ordem. Parece que ela está travada no Mint não troca pro OpenSUSE de jeito nenhum…

Se não consegue alterar na BIOS, é pq ela deve ter alguma tranca (senha para adm da BIOS) - pesquise pelo modelo que pode aparecer algo. Deve ser essa a causa de vc não conseguir modificar as entradas mesmo com sudo

1 curtida

Bem, consegui resolver reparando o grub e montando-o novamente.
Além de alterar na BIOS (UEFI) a ordem de boot padrão.

1 curtida

Este tópico foi fechado automaticamente 3 dias depois da última resposta. Novas respostas não são mais permitidas.