PJe Office no Linux

@aldebaranbm Alterei o Java e o erro persiste, acredito que seja um bug do próprio PJe, infelizmente eles não dão a mínima pro Linux então provavelmente vai ficar assim.

@marcioandre94 Eu instalei um Windows 7 numa Virtualbox da Oracle, aí tem que adicionar o usuário que vai usar a VM no grupo de usuários vboxusers pra poder habilitar o acesso a USB dentro da VM, aí vai no menu dispositivos e clica no Token ou Leitor de cartão, e pronto é só usar.

Comandos para adicionar o usuário que eu usei no meu caso

sudo usermod -a -G vboxusers $USER
sudo adduser $USER vboxusers

Cara achei algo interessante, já chegou a ver este Post? É relativamente recente…

Esse tutorial ensina a instalar pro e-saj e eproc, mas do PJe ele nem fala, essa parte toda eu fiz pra ter acesso aos demais, o PJe tem um programa próprio que fica na área de notificação.

Estranho, note que o Bruno A. R. (no dia 06/01/2019) ao que me parece postou um print com o mesmo erro que está dando aí, o autor do Post orientou ele a instalar um driver. O Bruno não postou um feedbak… você já testou o referido driver? Link para driver novo – Processo Judicial Eletrônico (PJE) – Casa do Pinduvoz

Amigo, segui o procedimento abaixo e até agora está tudo OK.

OBS.: Não verifiquei o PJe.

Guia rápido para instalação dos programas necessários para uso de certificado digital no Ubuntu 18.04. Em especial para o sistema “e-SAJ” (SafeSign/Websigner)

Instruções:

  1. Abra um terminal de comando e digite o seguinte comando para instalar os drivers p/ leitora de cartão: sudo apt install libccid pcscd

  2. Baixe e instale via Software Center os arquivos necessários:

a) libgdbm3 (Link: <ftp.br.debian.org/debian/pool/main/g/gdbm/libgdbm3_1.8.3-13.1_amd64.deb>);

b) libpng12-0 (Link <ftp.br.debian.org/debian/pool/main/libp/libpng/libpng12-0_1.2.50-2+deb8u3_amd64.deb>);

c) SafeSign (Link: http://www.digitalsigncertificadora.com.br/repositorio/downloads/SafeSignIC3.0.116-x86_64-ub14-tc-admin.deb;

d) WebSigner (Link: https://websigner.softplan.com.br/Downloads/2.5.1/webpki-chrome-64-deb;

  1. Instale no Firefox o plugin do WebSigner (Link: https://websigner.softplan.com.br; Para instalar siga as instruções da página.

  2. Clique no ícone do WebSigner no canto direito da barra superior do Firefox, e em seguida, clique no botão da direita ‘Crypto devices (PKCS #11…)’ (o que tem umas engrenagens no ícone), e marque a opção ‘libaetpkss.so.3 (Smart cards managed by SafeSign)’ e clique em OK.

  3. Plugue a leitora com o cartão e proceda com o teste:

a) Abra o programa SafeSign que você instalou e tente abrir o seu certificado digital.

b) Abra o eSAJ do seu tribunal local e verifique os requisitos do peticionamento eletrônico: https://esaj.tjsc.jus.br/petpg/abrirVerificacaoRequisitosPet.do;

CONCLUÍDO. Se você executou tudo corretamente, estará apto a peticionar no e-SAJ. Caso contrário, verifique se sua leitora de cartão está funcionando corretamente e refaça o passo-a-passo da instalação.

Esse não deu certo, pra piorar travou o PC kkkkkk, mas blz, vou mandar uma reclamação para o PJe.

Putz mano, meu intuito foi ajudar, como relatei, até uso certificado digital mas para outros fins :sweat_smile:

Bom o certificado está funcionando em outros sistemas como você relatou, estão como sugestão final, diria para colocar uma distro Live para correr em um Pendrive.

Eu quando quero testar algo recorro a uma Live do Debian, são raros os casos que preciso por exemplo instalar em um HD/SSD auxiliar. Uma VM Linux e sair testando tudo quanté coisa talvez te ajude, mas, certifique-se antes de que a leitora vai funcionar com outros sistemas dentro da VM.

Você citou que “nas versões mais antigas do Linux funcionava direito”, busque estas versões anteriores, instale-as ou rode em Live, se rodar, veja a versão dos pacotes. Isso ai está me cheirando algum tipo de incompatibilidade causada por atualização de um pacote/driver que você pode facilmente reverter.

Eu acho acredito sim que consegue resolver isso ai cara! Se já funcionou com você em outro momento, talvez seja um bom passa tempo fazer isto funcionar. Go ahead!

A versão mais recente do Java é 11 e não 8, apesar da galera ter dado altas dicas, recomendo atualizar o Java antes de tentar qualquer outra coisa.

Instalei a OpenJDK dos respositorios do Mint, deve ser a mais atual.

O OpenJDK não é a versão mais atual, você precisa instalar o Java da Oracle, que está na versão 11.

Houve algum avanço com o problema ? Fiz uma instalação limpa do Linux Mint 19.1 e instalei somente o Java da Oracle testei as versões 11 e 12 mas mesmo assim o erro continua. É difícil a vida de quem tenta advogar usando software livre atualmente, por causa do processo eletrônico, e a falta de suporte das certificadoras e dos desenvolvedores dos sistemas de peticionamento.

Realmente é complicado, mas acho q num caso como esse, além de pedir dicas aqui, q é o melhor, é necessário reclamar nos sites dos tribunais q devem prover soluções para quem ñ usa win, o cidadão ñ deve ser obrigado a usar e todos os tribunais devem se adequar a isso e só o farão se forem demandados.

Boa tarde.

Tenho uma máquina virtual só para rodar o Windows 10 e acessar os sites dos tribunais. O único que está funcionando aqui com o Linux é o do TJSP.

Aparentemente, o problema é a integração java/navegador/site. Até para instalar as cadeias ICP-Brasil no Linux é um parto.

Não houve mudança, continua na mesma, eu estou usando o windows 7 numa VM para poder acessar o PJe, mas é terrível, o tempo que eu perco com isso.

Já fiz reclamação no site, mas parece que não estão nem aí, já me falaram que funciona, que tem um problema e estão tentando resolver, e que era pra eu usar o Windows, enfim, nem quem deve proteger o cidadão está escutando o cidadão. CDC neles kkkkkk

1 Curtida

Boa tarde. Atualizando o meu post anterior. Eu consigo acessar todos os sites PJe e pelo Chrome. Só não consigo acesso aos sites sem PJe (ex. TJRJ/JF-eproc). CNJ e TRT abrem normalmente, assim como o TJSP.
Estou utilizando a última versão do PJeOffice (1.0.17) e Java Oracle 1.8.0_144 .

Tentei até com o Arch Linux, que por mais estranho que possa parecer tem um suporte melhor a alguns pacotes antigos do que o Ubuntu e devivados, graças ao AUR. Testei com o Java 8 e continua o mesmo erro, vou fazer reclamações também quem sabe eles não resolvem.

O irônico, como sempre no mundo Linux, é que o PJe parece rodar em servidores Linux, usando Red Hat ou alguma derivação dele, e a lei que regulamenta o processo eletrônico da preferência a utilização de software livre nesses sistemas. Só que para o acesso a esses sistemas não parece se ter essa preferência, o que é no mínimo contraditório e não ajuda em nada na democratização do acesso a justiça.

Estranho, tem como vc me dizer qual pacote de do token ou leitor de cartão vc usou, porque pelo tipo de erro que me aparece parece ser problema com o dispositivo, não um problema entre PJe, Linux e navegador

Meu token é o Aladdin.

Qual distro vc está usando ?

Uso o Linux Mint 19.1.