Monitor não funciona no Linux

Gente,

Já um tempo tenho problema com gráficos em distros linux, antigamente se a iso não tivesse graficos proprietários, nem dar boot dava (por isso só conseguia instalar o pop_os). O estranho que se eu suspendesse o sistema e voltasse funcionava qualquer uma.

Porém toda e qualquer distro que instalo hoje em dia, não da esse problema mais, mas depois que o sistema abre meu monitor principal fico piscando e bugando.
Segue video do problema https://drive.google.com/file/d/17M9F_YdTp3c6o1CD1IoU4L-0n8JFGwU3/view?usp=sharing

Já tentei alterar os drivers da NVIDIA para todos os que tavam disponíveis, e quando coloquei o driver open source ele bugou e nenhuma tela funcionou me obrigando a formatar de novo.

Minha config atual:
Ryzen 5 3500X
GTX 1660 6gb
2x 8gb DDR4 3200Mhz
Windows no SSD Nvme
Linux no SSD sata pichau PG256X
Monitor principal LG 29wk600
Monitor Secundário TV AOC 22" LE22H138 (antiga)
Monito Terciário LG l1753t-bf 17" (antigo 4:3)

https://kit.co/ayatokats/computador-principal

Beeleza ^^

Vou tentar aqui, mas sim to com o tpm habilitado por causa do Win11
o secure boot meu fica desabilitado e o ssd é em mbr.

mas vou tentar aqui de novo com o ubuntu 20.04 desabilitando o tpm

Boas vindas ao fórum :wave:
Já tentou instalar o Pop!_OS somente com o monitor principal plugado? Recomendo fazer isso e, após instalar, atualiza geral com sudo apt update && sudo apt full-upgrade && sudo apt autoremove && sudo apt autoclean. Após terminar de atualizar, caso tenha algum update dos drivers da Nvidia, reinicia a máquina e só assim recomendo que plugue os de mais monitores. Se mesmo assim o problema continuar, sugiro testar o Solus. Para instalar os drivers de vídeo da Nvidia, basta usar a ferramenta inclusa na distro, como mostra neste vídeo.

Sobre o TPM, creio não ser um problema. Só o secure boot que tende a dar estresse, por isso é sempre bom deixar desativado.

Usar GPT ou MBR, neste caso em específico, é efeito placebo, pouco importa. Só é necessário usar o GPT se tiver de dois 2tb para cima de armazenamento.

Não faça gambiarra ao menos que você extremamente precise.

Jamais, em hipótese alguma, utilize uma versão insider, ou beta, como sistema de produção sendo um usuário final!

1 curtida

Olá @AF_Designer tudo bem contigo? Temos vários relatos de tela piscando ou artefatos quando são usados monitores com diferentes taxas de atualização e/ou escalas fracionadas.

Faça alguns testes com estas configurações e veja se consegue contornar o problema.

:vulcan_salute:

1 curtida

Não, mas a diferença de taxa de atualização sim. Como o Eddie explicou a cima.

Suposição minha, é que seja algum problema com o X.org, mas isso ai é só palpite, não fundamentado em uma analise técnica mais a fundo.

@JG22 @Subaru Evitem desviar do tópico, o usuário solicitou ajuda para problema que está relacionado aos monitores.

2 curtidas

Oii obrigado pela resposta.

Fiz o teste instalando com o monitor principal sozinho também, mas não tive sucesso.

A questão da taxa de atualização faz sentido, esse monitor pode chegar a 75hz. Quando tento alterar a taxa de atualização, aparece nas configs 50hz, 59.98hz e 74.99hz, ele continua da mesmo forma (dependendo até piora e chega a desligar completamente o monitor).

Desinstalei os drivers atuais de video e instalei uns antigos e até a versão beta dos mais recentes e também não vi diferença. (o driver open source bugou e não iniciou meu sistema de novo).

Tentei instalar o ubuntu 20.04 lts, 21.04, o Pop_os 21.04 e o linux mint 20.

Nenhum foi.

Será que pode ser problema com a base dessas distros? Vou instalar o Solus para testar

Oi

Vc usa xorg ou wayland?
Qual seu ambiente desktop?
Qual é o drive que vc usa?

Por exemplo usando xrand

Screen Blinking

For some LCD screens (e.g. Samsung 2343NW, Acer XB280HK, iiyama ProLite XUB3490WQSU-B1…), the command cvt -r (i.e. with reduced blanking) is to be used. E.g with ProLite XUB3490WQSU-B1 and Thunderbolt HDMI 2.0 adapter on Dell XPS 13, with 60hz (59,94 selected) this screen is blinking (and the adapter+LCD screen works perfectly on Windows), you have to do :

cvt -r 3440 1440

Wich giving you :

# 3440x1440 59.97 Hz (CVT) hsync: 88.82 kHz; pclk: 319.75 MHz Modeline "3440x1440R" 319.75 3440 3488 3520 3600 1440 1443 1453 1481 +hsync -vsync

Then you have to do :

xrandr --newmode "3440x1440R" 319.75 3440 3488 3520 3600 1440 1443 1453 1481 +hsync -vsync

and

xrandr --addmode DP1 3440x1440R

Now you can select 59.97hz mode with the best screen resolution, wich not blinking anymore.

Se for gnome

(HiDPI) suporte de tela

O GNOME introduziu o suporte ao HiDPI na versão 3.10. Se sua suporte não fornecer o tamanho de tela correto por meio do EDID, isso poderá levar a elementos da interface do usuário dimensionados incorretamente. Como solução alternativa, você pode abrir o * dconf-editor * e encontrar a chave scaling-factor em org.gnome.desktop.interface. Defina como 1 para obter a escala padrão.

Se for Intel

Screen flickering

Panel Self Refresh (PSR), a power saving feature used by Intel iGPUs is known to cause flickering in some instances FS#49628 FS#49371 FS#50605. A temporary solution is to disable this feature using the kernel parameter i915.enable_psr=0.


esse é o sistema que me encontro atualmente.

Tentei o cvt

a saída que tive:

[email protected]:~$ cvt -r 2560 1080
# 2560x1080 59.98 Hz (CVT) hsync: 66.64 kHz; pclk: 181.25 MHz
Modeline "2560x1080R"  181.25  2560 2608 2640 2720  1080 1083 1093 1111 +hsync -vsync

o xrandr deu isso


[email protected]:~$ xrandr --newmode "2560x1080R"  181.25  2560 2608 2640 2720  1080 1083 1093 1111 +hsync -vsync
X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  16 (RRCreateMode)
  Serial number of failed request:  45
  Current serial number in output stream:  45

a configuração do monitor

Acho que xrandr nào funciona com o drive proprietsrio da Nvidia

Tentou o processo do HiDPI?

Continua na mesma. :frowning_face:

Parece que agora está piscando a tela mais vezes ainda.

Você está usando HDMI ou DisplayPort?
Se for HDMI, qual geração? Pode ser que ele não esteja conseguindo segurar a largura de banda necessária para transmitir a resolução gráfica por inteiro.

Atualmente DisplayPort 1.2 por causa das entradas da placa de video, mas fiz o teste com o HDMI 1.4 também e o resultado é exatamente o mesmo.

Chegou depois de mudar para 1 reiniciar o PC?

Sim sim,

Fiz a reinicialização normal.

https://www.nvidia.com/en-us/geforce/forums/gfn-general-chat/20/407871/upper-part-of-the-screen-extremely-randomly-flicke/

Qual o drive que vc instalou?

No caso eu testei todos os drivers dessa lista, atualmente esto com o mais recente.

Talvez não seja muito relevante, mas no windows eu também troquei os drivers pensando que poderia ajudar em algo, usei o driver studio mais recente e o game read mais recente também, não houve diferença nenhuma.

(só a título de curiosidade, há uns 3 meses eu tive esse problema ao instalar o linux no pc e simplesmente desisti, mas mantive instalado. Um mês depois, depois de atualizar no windows os drivers da nvidia umas 3 vezes, resolvi abrir o linux novamente e o problema não aparecia mais. Isso que me deu esperança de ser algo no windows, mas pelo visto não foi)

Chegou a testar os cabos? Pode ser apenas isso

Testei,
Na verdade o DisplayPort é novo e usei 3 HDMIs diferentes que tinha em casa.

Acho estranho isso acontecer somente em distros linux. Tanto no Windows 10 e no 11 estão funcionando perfeitamente.

1 curtida