Missing Operating System após instalar o Windows em dual boot

Eu possuo o Arch instalado no meu hd, criei uma partição para instalar o Windows 10 e, após instala-lo, abri o Pop OS em modo live (pq era a .iso que eu tinha na hora) e fiz com que o pc desse boot na partição com Linux, para poder iniciar o grub e eu acessar o Arch. Acontece que quando inicio pelo sda1, que é a partição com Linux, aparece “Missing Operating System” e eu não consigo iniciar o sistema, tive que voltar pro pop os e dar boot na partição com Windows.
O que é esse erro? Preciso re-instalar o grub?

Provavelmente sim, o Boot-Repair pode ser um bom aliado nessa horas, use uma distro em modo live com ele. Atualmente ele já vem instalado com o Mint 19.2

Edit: Missing operating system é mensagem quando o firmware da placa mãe tenta carregar o programa que está instalado no disco. Nesse caso ele não achou o que procurava e travou nesta tela. Geralmente essa mensagem acontece quando se tenta dar boot por um disco vazio ou que não contenha sistema operacional instalado, ou quando o tipo de boot está errado.

Para ajudar, precisava de mais informações:

  1. Como estão particionados os discos? GPT, MBR?

  2. Se possível manda a saída do

fdisk -l /dev/sda
  1. Você tinha o grub antes de instalar o Windows?

  2. Sua placa mae está configurada para UEFI ou Legacy? Como aparece a opção para boot padrão?

1 Curtida

Deu certo aqui, vlw Dio.

Em MBR, por causa do Windows.

Não posso no momento, msa se ainda quiser…

Sim, eu tinha o Arch instalado no pc e depois instalei o Windows em dual boot inclusive.

Legacy.

1 Curtida