Já editei o user-dirs.dirs com os novos locais, porém não consigo acessá-los diretamente na home

Já editei o user-dirs.dirs com os novos locais, porém não consigo acessá-los diretamente na home. Apenas pelo menu lateral no Nautilus.
image

Já reiniciei, desliguei, encerrei sessão, apliquei o user-dirs-update --force (volta todas as pastas para o padrão)
Existe uma maneira que isso possa funcionar?

Você terá que dar permissão ao seu usuário na pasta /mnt/dados.

Este caminho só com root por padrão.

Altere a permissão do grupo desta pasta e adicione um grupo que tem permissão de ler, escrever e executar.

Pode ser

chmod 770 /mnt/dados

Eu não lembro se tem a opção r, para aplicar nas subpastas de forma recursiva

chmod -r 770 /mnt/dados

Acredito que estas pastas dentro da sua /home ainda são as pastas antigas.

Se eu estiver certo, você terá que mover todo o conteúdo dentro delas para as respectivas pastas criadas dentro de /mnt/dados.

Depois disso, você precisará remover cada uma delas e criar um link simbólico para o destino correto.


rm -Rf Documentos Downloads [...] Vídeos
ln -s /mnt/dados/Documentos Documentos \
	&& ln -s /mnt/dados/Downloads Downloads \
         ...
	&& ln -s /mnt/dados/Vídeos Vídeos 

Veja que você terá que mandar remover todas que desejar e depois mandar criar o link simbólico para todas elas também.

Estou usando da forma que falou, com links simbólicos.
O que queria mesmo é redefinir sem o uso desses links.ao funcionou :smiling_face_with_tear::smiling_face_with_tear:

Definindo as permissões tbm não!

O grupo que está 7, seu usuário faz parte?

Tem que incluir seu usuário no grupo

Não é assim que funciona, quando você troca, aquela pasta passa a funcionar como a pasta equivalente, por exemplo, se você definir a pasta Downloads para /mnt/dados/Downloads, ao baixar um arquivo no navegador ela será salva em /mnt/dados/Downloads ao invés de /home/seu-usuario/Downloads, a única forma acessar por /home/seu-usuario/Downloads é com links simbólicos

2 curtidas

Pois é, notei que a única solução é com links. Enfim, vou continuar com os links simbólicos. Muito obrigado

Já tentou esse comando?

$ xdg-user-dirs-update --set DOWNLOAD  /mnt/dados/Downloads

Esses diretórios do usuário, acredito estar sendo redefinidos para $HOME/ cada vez que você reinicializa porque esses locais não estão disponíveis na inicialização da sessão quando xdg-user-dirs-update é executado automaticamente.

Uma possível solução é impedir xdg-user-dirs-update de executar na inicialização adicionando enabled=False ao seu user-dirs.conf.

Não está voltando ao padrão ao reiniciar a maquinha, mas sim quando faz o --force.
No mais as edições estão corretas e funcionando. A questão parece ser resolvida apagando as pastas existentes e criando links simbólicos para as novas que estão em /mnt/data

Se adicionar enabled=False no user-dirs.conf, ao passar --force ele retorna ao padrão novamente???

User-dirs.conf ou user-dirs.dirs?

Isso serve pra que? Coloca no início ou no final?

Vou fazer o teste com isso pra ver

Isso controla o comportamento do xdg-user-dirs-update que é executado no login do usuário.

/etc/xdg/user-dirs.conf → configuração global
~/.config/user-dirs.conf → configuração local

1 curtida

Agora não aparecem mais. De qualquer forma a solução parece ser com os links simbólicos

Uma pena… Acho que realmente a solução com links simbólicos fica sendo por agora a melhor mesmo…

Código de uma linha para ajudar com os symlinks…
* Execute na HOME

$ for x in $(awk -F'=' '{ gsub(/"/,x); if ($1 !~/^#/ && $0 !~/\$/) print $2}'  ~/.config/user-dirs.dirs); do rmdir $(awk -F "/" '{print $NF}' <<< "$x") ; ln -s "$x" .  ;done

Esse código ira ler a config user-dirs.dirs editada por você, e todos os diretórios, a qual você quer alterar, se existirem na sua home e for vazio ira remover e então criar o link, desde que o ponto de montagem /mnt/dados/ esteja montado…

Para ter certeza do que esta a fazer, altere os comandos rmdir pelo echo e ignore do ;ln até o outro ;.

Espero que ajude…

2 curtidas