Ícones de programas órfãos no Gnome

Já é o segundo caso de programa que desinstalo e que o ícone ou fica “órfão” (fica o ícone mas não o programa) ou a entrada do programa “vazio” (não tem o programa e não tem ícone nele mas tem a entrada). Um caso é o Photogimp - que no caso descompactei a pasta do GitHub e coloquei nas pastas da /home, mas ao desinstalar o Gimp, já que o patch não pegou, o ícone e a entrada ficaram no menu de aplicações, mas ao clicar não carrega (claro, não tem Gimp!).


O outro caso é o Signal, que instalei via repositório, pelas instruções do site. Mas como os PPA’s dele são antigos, deu erro na atualização. Aí removi via Terminal e desabilitei os PPA’s no app de atualizações do Ubuntu, e instalei um flatpak. Só que ao digital Signal na busca de programas, ocorre essa doideira:

O que tem ícone é o Flatpak, o outro é o “órfão”.
Tá, eu sei que vai aparecer alguém que me mande fazer uma instalação limpa, mas não tô muito afim por agora, vou deixar pra fazer no final do ano, quando tiver comprado um HD externo de 1TB, um SSD ou tiver saco de refazer tudo…
Então, como solucionar essas esquisitices?

1 curtida

Normalmente ficam ~/.local/share/aplications

Ou

/usr/share/applications

2 curtidas

Tá, o Photogimp é um capítulo à parte. Então, vamos ver se consigo resolver o Signal. Como era em .deb, vou colocar os prints de onde ele poderia estar e ver se é seguro deletar:


Em usr/share/applications ele não está:

Esse Signal aí, o da .local/share/applications poderia rodar então?

Tudo que está em local pode ser removido se quiser…, mas não recomendo, pode ter programa instala no usuário
Já em usr afeta geral. Tôdos os usuários.
Abre o arquivo com o editor de texto e veja em exec se é o programa…
Se for… manda bala nele…

Kkkk
Até

Caaaalma… abre o que? Onde?

Org.gimp. gimp

Acho que é isso…
Foi mal, estou no celular …

Procura por gimp ou photogimp

Vc pode usar o grep

grep -r -i photogimp .

Abri o “ícone” do Signal na .local/share/applications (na /home) e deu o seguinte no Pluma:


Aparentemente é um resíduo do Snap que já foi desinstalado

Pode ser…
Em vez de remover copie ou mova para uma outra pasta e veja o que acontece

Contudo estava falando do arquivo

org.gimp.GIMP.desktop

1 curtida

Opa, deu certo! Movi para outra pasta e a entrada órfã do Signal sumiu!! E o Signal abriu de boas (o Flatpak que estava instalado, já que a ideia era sumir com o resíduo do Snap)

Quanto ao Photogimp, primeiro vamos ver se consigo fazer funcionar… se não, aí é fuçar por ele (já que ele pede pra copiar pra ter pastas ocultas na /home) pra sumir com o dito cujo e reinstalar o Gimp tradicional mesmo