Hearthstone Lutris

Olá pessoal, alguém está tendo este problema com o Hearthstone no Lutris, ele instala abre mas fica apenas nesta tela congelada e não vai para frente.

Já testei outros jogos como o Starcraft 2 também da Blizzard e funcionou normalmente.

1 Curtida

Qual dos scripts de instalação vc usou?

Instalei a Battle.net pelo próprio Lutris e instalei direto por lá, assim como fiz com o Starcraft que funcionou.

Pergunta, já viu se todas as dependências foram instaladas? Na página do Heartstone no Lutris são indicados algumas dependências.

Pode dar detalhes em relação ao seu sistema?

Dei uma olhada nelas mas já estão instaladas

image

Não sei se vc já resolveu o problema, mas eu estava com o mesmo e achei uma solução. Pelo oq eu entendi, o lutris não estava com a timezone configurada. Clique com o direito sobre o jogo, vá em “Configure” e depois na aba “System Options”. Lá vc vai encontrar as “Environment variables”. Adicione a TZ e atribua a sua timezone. No meu caso, a tela sai desse estado congelado e começa a carregar, aparecendo o nome do jogo, o botão de configurações e os amigos online, mas a janela se fecha após isso. Mas tente essa solução, talvez funcione para vc. Ainda estou tentando resolver a minha situação. Se alguém souber como contornar isso, ficarei muito grato

Opa Matt, vou tentar sim, parece que é um problema entre o Lutris e o Hearthstone mesmo, os outros jogos tanto da Blizzard quanto fora dela estão funcionando Ok. Mas vou tentar e te respondo novamente.

A solução do meu foi apenas adicionar a timezone. O erro de estar fechando era causado pela versão do wine, q eu alterei durante os testes e esqueci de voltar pra original. Hearthstone voltou a funcionar normalmente.