Grub do popos desconfigurando ordem de boot ao iniciar o windows

Olá, sou relativamente novo no mundo do linux, estou utilizando á 1 mês o PopOS onde estou relativamente encantado, porém me veio uma situação que está afetando o dual boot, na ordem do boot, está o pop em prímeiro para puxar o grub e assim escolher o sistema operacional, iniciando pelo popos e reiniciando vai normal e retorna ao grub, porém ao dar boot pelo windows e reiniciar , a ordem simplesmente muda, deixando o windows em primeiro lugar, assim não dando mais acesso ao grub.
Para isso sendo necessário toda vez que for usar o windows, mudar a ordem.

1 Curtida

Está mudando a ordem na bios ou no grub?

Se for grub, é só desativar a opção salvar no /etc/default/grub, e depois atualizar o grub com update-grub

Está mudando a ordem na bios mesmo.

Ok…

É um note?
Qual é?
Deve ter alguma configuração na bios que salva pelo último acesso

É sim, é um lenovo ideapad 320 15IKB.

Ok

Veja este vídeo

Em startup acho que é isso

Terá no final boot ordem lock

Habilite está opção para enabled

Coloque a ordem que vc quer e habilite a opção. Com isso acho que resolve o seu problema

:+1:

1 Curtida

A minh bios é um pouco diferente ao do vídeo, infelizmente mechendo nela não há a opção ‘Boot order Lock’

Existe aba startup?
Existe aba boot?

No startup o que aparece?

O horário do pc está correto?

Pode ser que a bateria esteja fraca e com isso a bios é resetada

Não há aba startup, respectivamente INFORMATION, CONFIGURATION, SECURITY, BOOT E EXIT
estou utilizando a ultima bios disponibilizada da lenovo, 4wcn47ww

Os horários estão devidamente corretos em todos os sistemas e na bios.

O problema não ocorre ao fazer o processo no PopOS, apenas no WINDOWS, aonde muda a ordem.

Tem security boot?

Ele está ativado?

Tente desativar e veja se persiste o erro.

No vídeo ele fala em aba “Boot” ou “Startup”. Dê uma olhada na aba “Boot” do seu sistema, pode ser um pouco diferente, mas ter as opções necessárias.

Tem sim, fiz o teste ativado e desativado, e persiste.

Então, na aba BOOT há apenas
Boot Mode
Fast Boot
usb boot
pxe boot to lan
ipv4 pxe first

e logo abaixo a ordem de boot
na qual eu configuro da seguinte forma

-Pop
-Pop!_os 20.10
-Windows boot manager

Ao iniciar pelo popos e reiniciar ele volta no mesmo estado, tudo certinho. Porém ao fazer o processo pelo windows a ordem muda e fica:

-Windows boot manager
-pop
-Pop!_os 20.10

Fazendo assim iniciar o windows direto sem a possibilidade de escolha

Tem algo errado aí, galera, o Pop!_OS por padrão não usa o GRUB, e sim o Systemd-boot, essas soluções não vão funcionar

Lenovo né!

Atualizando para informar que o problema em si foi resolvido.
No prompt de comando do próprio windows, rodando o comando Bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi o problema some, mantendo a ordem normal independente do sistema iniciado.

2 Curtidas