Google Chrome no Linux fica tranvando

Quando vou rodar videos no Chrome no linux ficando em slow motion sendo que o video ta carregado e e independe para plataforma

1 curtida

Se n√£o me engano o chrome tem uma op√ß√£o de ‚Äúacelera√ß√£o por hardware‚ÄĚ (algo assim), veja nas configura√ß√Ķes dele se essa op√ß√£o est√° marcada, caso sim, desmarca ela. :slight_smile:
Dê uma olhada nesse tópico: Google Chrome travando - #12 by Lavrudinho

Outra opção é que pode estar faltando codecs, veja também esse tópico: Problemas com youtube no Chromium no Mint

1 curtida

Apenas no Chrome o vídeo fica travando? ou em outro navegador também?

1 curtida

So uso o chrome, viu as paginas no linux em ingles não estão traduzinado PT-BR mesmo com opção ativa, como resolvo isso vc sabe?

Você se refere a traduzir as páginas de algum site/blog em inglês para Português BR? :thinking:

Sim


ta ativado mais n√£o parece para traduzir

1 curtida

Tente usar uma extens√£o: Google Tradutor - Chrome Web Store

Quando eu usava o chrome, e não aparecia a opção de traduzir, eu selecionava para traduzir pela extensão. :slight_smile:

ent√£o jovem, infelizmente o google chrome/firefox e afins n√£o suporta ‚Äúvideo decode hardware acceleration‚ÄĚ isso significa que seu processador √© usado pra decodificar v√≠deos‚Ķ e se o seu processador for ruim ou sofreu acidentes (igual o meu que levou √°gua), seu computador vai travar com qualquer v√≠deo que voc√™ assistir do youtube ou qualquer outro lugar‚Ķ
felizmente isso se resolve com o chromium que se encontra no snap, use o chromium do snap que eu acho que seu problema estar√° resolvido

sudo snap install chromium

o chromium do snap, ao contrário do chromium dos repositórios do ubuntu ou do google chrome/firefox/opera/vivaldi…, suporta video decode hardware acceleration.
o chrome e o chromium não mudam muita coisa, provavelmente vc notará que o ícone é diferente (o ícone do chrome é colorido e do chromium não), tirando isso tudo é a mesma coisa!

recomenda-se tamb√©m instalar essa extens√£o pelo fato de muitas GPUs n√£o suportarem ‚Äúvideo decode hardware acceleration‚ÄĚ com o codec padr√£o do youtube (que √© o vp9/opus), a maioria delas suporta h264/aac

3 curtidas

esta dando esse erro aki

$ sudo snap install chromium
snap ‚Äúchromium‚ÄĚ is already installed, see ‚Äėsnap help refresh‚Äô

Não é um erro, Snapcraft disse que Chromium já está atualizado e te pediu para restaurar. EXecuta o comando snap refresh no terminal.

1 curtida

Quais os comandos para remover um programa, eu so remove e outro remove a pasta entre outra coisas

Esse erro acontece quando você utiliza tanto o Google Chrome Stable e Beta, como o Chromium com o Xorg. No Wayland ou utilizando KDE este erro não ocorreu em minhas bancadas… O erro esta ligado ao fato de que o google-chrome vem por padrão habilitado para utilizar gpu, se você não tiver uma placa de vídeo dedicada você vai enfrentar estes possíveis problemas:

  • Alguns v√≠deos travaram mesmo estando j√° pr√©-carregados ficaram girando um loading infinito nos videos do Youtube.
  • Gifs ou anima√ß√Ķes em sites ex. Facebook far√£o com que o navegador trave ou fique lento.

Mensagens de erro:
As mensagens de erros podem variar de acordo com o sistema em quest√£o, os erros abaixo s√£o no Ubuntu.

  • Google Chrome Stable,
    Google Chrome Beta:
[2307:2307:0106/185502.822827:ERROR:sandbox_linux.cc(364)] InitializeSandbox() called with multiple threads in process gpu-process.
[29617:29617:1003/171104.939355:ERROR:sandbox_linux.cc(379)] InitializeSandbox() called with multiple threads in process gpu-process
  • Chromium
[2863:2863:0106/185533.087795:ERROR:sandbox_linux.cc(364)] InitializeSandbox() called with multiple threads in process gpu-process.`

Solução:
Edite o Desktop Entry do Google Chrome, Fica em /usr/share/applications/
Abra o arquivo .desktop digitando no terminal:

sudo nano /usr/share/applications/google-chrome-stable.desktop

Procure por Exec=/usr/bin/google-chrome-stable e adicionar --disable-gpu após, ficaria assim:

Exec=/usr/bin/google-chrome-stable --disable-gpu

Obs: O Desktop Entry do google tem três linhas com Exec=/usr/bin/google-chrome-stable altere todos colocando no final --disable-gpu. O você pode ainda adicionar --disable-software-rasterizer.

√Č s√≥ salvar e reiniciar o google-chrome.

Arquivo google-chrome.desktop j√° alterado e testado no Arch Linux, Ubuntu, LinuxMint, Fedora, OpenSUSE, Debian.

https://gist.github.com/eduardon9tt/88e940fe4589b0be1776f95b9059fdf9

Obs: Está solução foi testada em varias maquinas e está sendo repassada em diversos locais da internet inclusive no fórum do Ubuntu. Apesar disso se você não tem conhecimento sobre o assunto, tenha cuidado qualquer alteração errada no Desktop Entry pode ocorrer um erro quando for executar a aplicação em questão.

2 curtidas

Instalei o Chromium mais o problema continua o video fica em slow motion e travando sendo q o video ta carregado

Pode ser algo relacionado ao driver de vídeo. :thinking:
Você usa qual distro? Usa notebook com placa de vídeo híbrida?


√Č um not, o q √© Placa de video Hibrida?

1 curtida

√Č quando o notebook tem digamos duas placas de v√≠deo (o mais comum de se encontrar √© a combina√ß√£o Intel+Nvidia) que seria o Integrado do processador e o outro um dedicado, o integrado do processador serve para aumenta a dura√ß√£o da bateria e o dedicado geralmente √© usado para jogar

2 curtidas

√Č, seu notebook n√£o tem placa de v√≠deo h√≠brida.
Você já instalou os codecs de áudio/video?
Abre o menu do Mint, vá em Multimídia e veja se não tem a opção de instalar os codecs multimídia :thinking:

Instalei o Mesa-Driver so, devo instalar algum outro?

No meu caso para estar funcionando e os pacotes que eu tenho instalados são esses e a aceleração por hardware estar ativado (uso Arch Linux), no Mint acho que tem outro nome.

  • lib32-libva-mesa-driver
  • lib32-mesa
  • lib32-mesa-demos
  • mesa
  • mesa-demos
  • mesa-vdpau
  • intel-compute-runtime
  • intel-gmmlib
  • intel-gpu-tools
  • intel-graphics-compiler
  • intel-media-driver
  • intel-ucode
  • lib32-libva-intel-driver
  • lib32-libva1-intel-driver
  • libva-intel-driver
  • libva1-intel-driver

Mas antes de procurar esses pacotes poste o resultado desses comando

glxinfo | grep -i render

Esse comando irá verificar se a aceleração por hardware estar ativado

Resultado:

$ glxinfo | grep -i render
direct rendering: Yes
GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
GLX_INTEL_swap_event, GLX_MESA_copy_sub_buffer, GLX_MESA_query_renderer,
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: Mesa DRI Intel¬ģ HD Graphics 620 (Kaby Lake GT2)
GL_ARB_compute_shader, GL_ARB_conditional_render_inverted,
GL_NV_conditional_render, GL_NV_depth_clamp,
GL_ARB_compute_shader, GL_ARB_conditional_render_inverted,
GL_MESA_window_pos, GL_NV_blend_square, GL_NV_conditional_render,
GL_EXT_render_snorm, GL_EXT_robustness, GL_EXT_sRGB_write_control,
GL_OES_element_index_uint, GL_OES_fbo_render_mipmap,