FPS extremamente baixo no Arch Linux

Jogo Albion Online que não me ofereceu suporte exatamente por não jogar Linux. Essa é a minha última tentativa para continuar jogando esse jogo.
Segue o problema.

O FPS é extremamente baixo. Fica no máximo 10 FPS e isso prejudica muito em dungeons, ZvZ, GvG, etc. Como posso resolver isso?

Arch Linux.
Intel UHD Graphics 620
Se precisarem de qualquer outra informação, posto aqui sem problemas.

1 Curtida

Amigo, sua GPU é a mesma da minha. Como está o desempenho desse seu computador com outros jogos atualmente (sejam nativos, em emuladores ou via Wine)?

É que estou com um probleminha e queria saber como estão as pessoas com essa GPU.

1 Curtida

Está melhor. O problema mesmo é com esse jogo em especial. O que me incomodou mais foi a falta de suporte. Muito triste. E o pior é que eu viciei nessa budega, rapaz. Um jogaço!
Eu testei usando o Xfce que é mais leve que o GNOME e o desempenho do jogo foi exatamente o mesmo.

2 Curtidas

Ta com vulkan instalado? talvez dê para usar DXVK ou D9VK

1 Curtida

Estou sim.
Obrigado pela sugestão, Esdras.

1 Curtida

usa o driver da intel? xf86-video-intel
o vulkan está instalado corretamente?

instalou todos pacotes do vulkan
https://wiki.archlinux.org/index.php/Vulkan

sudo pacman -S vulkan-tools vulkan-icd-loader lib32-vulkan-icd-loader vulkan-intel
E ao rodar vulkaninfo não deu erro?

Melhorou de no máximo 10 para 20.
O resultado do vulkaninfo:
https://justpaste.it/5x6r4

Fala @Ma-chan e @rasolar, vocês já chegaram a mudar o governor da cpu para ver se problema persiste? Caso não conheçam, recomendo dar uma olhada no programa cpufrequtils, em alguns casos, ele consegue dar um up na performance tanto em jogos quanto em tarefas do dia a dia. Tem também a ferramenta GameMode da Feral Interactive.

1 Curtida

informaçẽs
https://wiki.archlinux.org/index.php/intel_graphics
https://wiki.archlinux.org/index.php/Hardware_video_acceleration
https://wiki.archlinux.org/index.php/Vulkan

Para kms
https://wiki.archlinux.org/index.php/Kernel_mode_setting#Early_KMS_start
insira i915 no mkinitcpio.conf
e crie novamente a imagem no initrd

veja o Hardware video acceleration

para sua placa nãoé se é intel-media-driver ou libva-intel-driver

pacman -S libva-intel-driver libva-utils libvdpau-va-gl vdpauinfo libva-utils

no arquivo ~/.profile
adicione

  • Para libva-intel-driver use i965 .
  • Para intel-media-driver use iHD .

export LIBVA_DRIVER_NAME=i965
export VDPAU_DRIVER=va_gl

ou

export LIBVA_DRIVER_NAME=iHD
export VDPAU_DRIVER=va_gl

Instale o mesa, lib32-mesa
pacman -S mesa lib32-mesa

E por último mude o drive da intel pelo modesetting
crie o arquivo em

/etc/X11/xorg.conf.d/20-modesetting.conf

e adicione

Section “Device”
Identifier “Intel Graphics”
Driver “modesetting”
EndSection

caso não tenha configurado a placa
tente ao contrario pois já está utilizando o modesetting
Instale o xf86-video-intel
pacman -S xf86-video-intel

E crie o arquivo
/etc/X11/xorg.conf.d/20-intel.conf

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "TearFree"		"true"
   Option      "DRI"			"3"
   Option      "AccelMethod"		"sna"
EndSection

Lembrando que não pode utilizar os dois ao mesmo tempo, escolhe um e apague o arquivo que não for utilizar

1 Curtida

O FPS melhorou um pouco na minha ilha pessoal. Agora marca 37, mas em mapas com muitas pessoas como nas cidades continua muito baixo.
Segui todas as instruções postadas. Agradeço de coração por estar tentando me ajudar.
Se for 20 nego de um lado mais 20 nego do outro se matando meu FPS mal vai me permitir me mover.
Na cidade (captura de tela tirada 17h da tarde):

1 Curtida

Eu mudei através de um script encontrado no blog do edps.

ok…

veja se harware acceleration está ok.

veja no link
https://wiki.archlinux.org/index.php/Hardware_video_acceleration

para vaapi évainfo
e vdpauinfopara vdpau

sobre o drive tenta nos dois e veja o melhor

tenta configurar dri
adriconf

pacman -S adriconf

Parece que o vainfo está ok. A saída dele só para você confirmar.
https://justpaste.it/34mbl
O vdpauinfo eu não entendi. A saída dele para você verificar.
https://justpaste.it/4qyra

Instalei o adriconf, porém não sei como configurar. Você conhece algum tutorial? Algo desse tipo?

sobre o vdpau

ATTENTION: default value of option vblank_mode overridden by environment.

tente criar o dri e veja se continua

abra o adriconf
vá em arquivo e salvar

basicamente ele funcionará como default

se continuar em profile ou bashrc
adicione
export vblank_mode=0

info
https://forums.gentoo.org/viewtopic-t-932988-start-0.html

alguns jogos requer mais processamento da GPU e outros da CPU, seu processador é Intel tbm??

Na ilha pessoal o FPS ficou no máximo 37.
Na cidade fica entre 15 a 20.
Isso fazendo todas essas configurações e mais uma que encontrei neste tópico.
Um adendo importante é que reinstalei o sistema hoje durante a madrugada.

O processador é Intel, mano. i5.

Tenta baixar os gráficos do jogo, coloca no baixo, se tiver um ganho de fps significativo você vai aumentando a qualidade.

Os gráficos estão no baixo. Na realidade essa foi a primeira coisa que eu fiz.

ok…
Você instalou o intel-ucode , xorg-server e xorg-xinit ?
sudo pacman -S intel-ucode
depois
sudo grub-mkconfig -o /boot/grub/grub.cfg

O .xinitrc configurado
por exemplo

get_session(){
	local dbus_args=(--sh-syntax --exit-with-session)
	case $1 in
		awesome) dbus_args+=(awesome) ;;
		bspwm) dbus_args+=(bspwm-session) ;;
		budgie) dbus_args+=(budgie-desktop) ;;
		cinnamon) dbus_args+=(cinnamon-session) ;;
		deepin) dbus_args+=(startdde) ;;
		enlightenment) dbus_args+=(enlightenment_start) ;;
		fluxbox) dbus_args+=(startfluxbox) ;;
		gnome) dbus_args+=(gnome-session) ;;
		i3|i3wm) dbus_args+=(i3 --shmlog-size 0) ;;
		jwm) dbus_args+=(jwm) ;;
		kde) dbus_args+=(startkde) ;;
		lxde) dbus_args+=(startlxde) ;;
		lxqt) dbus_args+=(lxqt-session) ;;
		mate) dbus_args+=(mate-session) ;;
		xfce) dbus_args+=(xfce4-session) ;;
		openbox) dbus_args+=(openbox-session) ;;
		*) dbus_args+=($DEFAULT_SESSION) ;;
	esac

	echo "dbus-launch ${dbus_args[*]}"
}

exec $(get_session)

Qual a sua interface?