Existe algum conversor de .DEB ou .RPM para .PKG para distros derivadas do Arch que NÃO utilize o Terminal?

Queria saber se existe algum programa conversor para derivados do Arch (Manjaro, EndeavourOS, ArcoLinux, etc) que funcione de forma gráfica sem o uso do Terminal? Sei que muitos dirão que é mais prático pelo Terminal, mas, prezo pela automatização dessas funções.

Acho que não, tem o Alien mas usa o terminal

1 Curtida

Não confio muito nessas coisas, sempre fico achando que vai crashar todo o sistema. rsrsrs
Creio que, se a exemplo do LibreOffice, começassem a soltar os programas como appimage, resolveria esse problema de incompatibilidade dos sistemas de pacotes das distros e beneficiaria toda a comunidade, principalmente os iniciantes.
Preciso usar um programa de gerenciamento de redes, que eu não consegui instalar no Manjaro de nenhuma forma, e acabei tendo que instalar o Win10 numa vm só por causa dele.

2 Curtidas

Tem um muito legal, o nome dele é AUR.

Pode fazer como meu script de cabos virtuais, usar o Zenity/KDialog para fornecer informações que vão alimentar o script. Exemplo:

PACOTE=$(zenity --file-selection)
debtap -Q "$PACOTE" && xdg-open "$(dirname "$PACOTE")"
1 Curtida

Oxi, eu ia falar isso porque uma quantidade imensa de pacote AUR é esse processo de transformar deb e rpm pra instalar no arch…

Como se faz isso? Existe uma receita pra fazer?

O formato .DEB nada mais é que um .a (normalmente utilizado para bibliotecas estáticas) que inclui dois .tar dentro, um com os arquivos em si (data.tar.xz) e outro com as somas de verificação e scripts de pré- e pós-instalação (control.tar.xz).

No geral, o seu PKGBUILD vai ter como source o .deb do programa (que é extraído automaticamente). Em seguida você instrui a extração do data.tar.xz e, se necessário, faz ajustes específicos para o Arch Linux.

Um bom exemplo disso é o PKGBUILD do Google Chrome:
https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=google-chrome

EDIT: Correções do @Natanael.755

4 Curtidas

Um detalhe importante, um .deb é um arquivo .a (sim o mesmo das bibliotecas estáticas), ou seja o tar não consegue extrair o .deb, pra extrair um pacote Debian, use:

ar x pacote.deb
2 Curtidas

A propósito, estou testando o ArcoLinux e o EndeavourOS com DDE como alternativas eventuais ao Deepin e esse tópico foi criado justamente por não encontrar dicionários e tradutores em Pt-Br para WPS Office “prontos” para Arch, tenho encontrado apenas os tradicionais .DEB e .RPM ou links antigos e expirados de arquivos para Arch e derivados. Sabe de algum método diferente para deixar o WPS em Pt-Br?

adiciona o repositório do manjariando que tem pacote de tradução pra pt-br lá!

1 Curtida

E esse repositório é “tranquilo” quanto a estabilidade?

Tem funcionado bem pra mim, eles sempre atualizam os mirrors, quando algum cai, é trocado por outro (e tem mirror no sourceforge)

1 Curtida

Vou adicionar aqui então.

Aqui deu erro:
“Não foi possível satisfazer as dependências:
-Incapaz de satisfazer dependência ‘pacman-mirrors’ requerido por repo-manjariando.”

Consegui pelo AUR, aparentemente é necessário ser persistente, pois, vários pacotes dão erro e só se consegue instalar após repetidas tentativas (me refiro apenas ao AUR).

1 Curtida

Eu também apanhei pra adicionar, mas nem lembro como uma hora consegui

Pois é, percebi que especialmente no AUR é preciso de insistência.

Comigo o que uso do AUR tem funcionado, o que tive problemas pra conseguir instalar foi o repo do Manjariando. Mas no fim funcionou

1 Curtida