Como reativar partição swap

Não tem nenhum com esse código. Aparece
/dev/nvme0n1p4: UUID=“fc077fbf-718f-4fab-9999-1f3e72752473” BLOCK_SIZE=“4096” TYPE=“ext4” PARTUUID=“e1f1f8c9-a00f-4214-ae6e-ed64dbfa5111”

/dev/nvme0n1p1: UUID=“A875-333A” BLOCK_SIZE=“512” TYPE=“vfat” PARTLABEL=“EFI system partition” PARTUUID=“725bb2a9-5914-40e3-869b-382835aae3c8”

/dev/nvme0n1p3: BLOCK_SIZE=“512” UUID=“DC3A77A33A77797A” TYPE=“ntfs” PARTLABEL=“Basic data partition” PARTUUID=“207dab59-f01b-49f9-998e-e74f2bb6283c”

/dev/nvme0n1p5: UUID=“9270-1F6F” BLOCK_SIZE=“512” TYPE=“vfat” PARTUUID=“f6715740-5e93-47d5-88ff-a58ad480315c”

/dev/nvme0n1p6: UUID=“87341afa-0a50-40c3-b190-bb044a993514” TYPE=“swap” PARTUUID=“0116587d-b5d4-4b73-9da5-65bba469e603”

Deixa pra lá. Já ajudou demais. Acho que vou formatar e começar do zero. Muito muito obrigado mesmo pela paciencia

troca o /dev/nvme0n1p6 por UUID=87341afa-0a50-40c3-b190-bb044a993514 no arquivo fstab pra ver, antes de formatar

src

No caso eu coloco assim: UUID=87341afa-0a50-40c3-b190-bb044a993514 none swap defaults 0 0

ou devo deixar apenas: UUID=87341afa-0a50-40c3-b190-bb044a993514

isso mesmo

Infelizmente não resolveu meu amigo. Desculpa todo o trabalho. Muito obrigado mesmo pela ajuda e paciência

1 curtida

Desconfio que ainda está o UUID da partição swap antiga no seu arquivo /etc/default/grub Acerte isso se for o caso. Pra conferir manda o cat /proc/cmdline

Também pode ser alguma unidade do systemD que está tentando montar automaticamente alguma partição que não existe mais. Verifique qual unidade falhou com sudo systemctl list-units --failed Daí desative essa unidade com sudo systemctl disable XXXXX.service (na dúvida, coloque a saída do comando anterior que a gente analisa qual unidade deve desativar).

Um ponto adicional é que não precisaria criar uma nova partição EFI pro ubuntu. Você poderia usar a mesma que já existe se há espaço disponível pros poucos megabytes que o GRUB ocupa. Mas não precisa mudar não, fica só a dica para uma próxima instalação.

1 curtida

Obrigado pela ajuda. Tentei rodar o comando que sugeriu e apareceu isso:

[email protected]~$ sudo systemctl list-units --failed
UNIT LOAD ACTIVE SUB DESCRIPTION
0 loaded units listed.

e a saída do cat /proc/cmdline/
?

initrd=\EFI\ub-fc077fbf-718f-4fab-9999-1f3e72752473\initrd.img root=UUID=fc077fbf-718f-4fab-9999-1f3e72752473 ro quiet loglevel=0 systemd.show_status=false splash

e a saída de sudo systemd-analyze critical-chain

The time when unit became active or started is printed after the “@” character.
The time the unit took to start is printed after the “+” character.

graphical.target @1min 34.768s
└─multi-user.target @1min 34.768s
└─plymouth-quit-wait.service @1min 30.606s +4.160s
└─systemd-user-sessions.service @1min 30.593s +7ms
└─network.target @1min 30.585s
└─NetworkManager.service @1min 30.474s +103ms
└─dbus.service @1min 30.471s
└─basic.target @1min 30.460s
└─sockets.target @1min 30.460s
└─uuidd.socket @1min 30.460s
└─sysinit.target @1min 30.449s
└─systemd-timesyncd.service @663ms +175ms
└─systemd-tmpfiles-setup.service @632ms +25ms
└─local-fs.target @621ms
└─boot-efi.mount @572ms +48ms
└─dev-nvme0n1p5.device @569ms

Vamos ver qual unidade que está demorando demais pra iniciar:

systemd-analyze blame

Não sei se muda alguma coisa, mas agora que percebi que falei errado. No caso meu sistema é o pop_os 20.10 e não o ubuntu. Apareceu isso:

4.160s plymouth-quit-wait.service
523ms fwupd.service
496ms accounts-daemon.service
337ms ufw.service
283ms dev-nvme0n1p4.device
244ms systemd-logind.service
208ms networkd-dispatcher.service
202ms systemd-resolved.service
186ms upower.service
175ms systemd-timesyncd.service
157ms udisks2.service
146ms update-notifier-download.service
127ms apparmor.service
122ms [email protected]
107ms systemd-journald.service
103ms NetworkManager.service
98ms avahi-daemon.service
97ms bluetooth.service
96ms polkit.service
96ms systemd-udev-trigger.service
85ms system76-power.service
82ms ModemManager.service
80ms lvm2-monitor.service
lines 1-23…skipping…
4.160s plymouth-quit-wait.service
523ms fwupd.service
496ms accounts-daemon.service
337ms ufw.service
283ms dev-nvme0n1p4.device
244ms systemd-logind.service
208ms networkd-dispatcher.service
202ms systemd-resolved.service
186ms upower.service
175ms systemd-timesyncd.service
157ms udisks2.service
146ms update-notifier-download.service
127ms apparmor.service
122ms [email protected]
107ms systemd-journald.service
103ms NetworkManager.service
98ms avahi-daemon.service
97ms bluetooth.service
96ms polkit.service
96ms systemd-udev-trigger.service
85ms system76-power.service
82ms ModemManager.service
80ms lvm2-monitor.service
78ms networking.service
77ms systemd-rfkill.service
76ms keyboard-setup.service
74ms switcheroo-control.service
72ms systemd-udevd.service
71ms apport.service
67ms dev-disk-by\x2duuid-87341afa\x2d0a50\x2d40c3\x2db190\x2dbb044a993514.swap
64ms thermald.service
62ms gpu-manager.service
61ms wpa_supplicant.service
60ms e2scrub_reap.service
58ms grub-common.service
53ms gdm.service
48ms boot-efi.mount
46ms secureboot-db.service
45ms binfmt-support.service
34ms grub-initrd-fallback.service
32ms colord.service
32ms rsyslog.service
25ms systemd-tmpfiles-setup.service
25ms systemd-tmpfiles-clean.service
24ms systemd-modules-load.service
21ms plymouth-start.service
21ms warsaw.service
lines 1-47

4.160s plymouth-quit-wait.service
523ms fwupd.service
496ms accounts-daemon.service
337ms ufw.service
283ms dev-nvme0n1p4.device
244ms systemd-logind.service
208ms networkd-dispatcher.service
202ms systemd-resolved.service
186ms upower.service
175ms systemd-timesyncd.service
157ms udisks2.service
146ms update-notifier-download.service
127ms apparmor.service
122ms [email protected]
107ms systemd-journald.service
103ms NetworkManager.service
98ms avahi-daemon.service
97ms bluetooth.service
96ms polkit.service
96ms systemd-udev-trigger.service
85ms system76-power.service
82ms ModemManager.service
80ms lvm2-monitor.service
78ms networking.service
77ms systemd-rfkill.service
76ms keyboard-setup.service
74ms switcheroo-control.service
72ms systemd-udevd.service
71ms apport.service
67ms dev-disk-by\x2duuid-87341afa\x2d0a50\x2d40c3\x2db190\x2dbb044a993514.swap
64ms thermald.service
62ms gpu-manager.service
61ms wpa_supplicant.service
60ms e2scrub_reap.service
58ms grub-common.service
53ms gdm.service
48ms boot-efi.mount
46ms secureboot-db.service
45ms binfmt-support.service
34ms grub-initrd-fallback.service
32ms colord.service
32ms rsyslog.service
25ms systemd-tmpfiles-setup.service
25ms systemd-tmpfiles-clean.service
lines 1-44

Não consegui detectar qual unidade do systemd está causando a lentidão no boot… Está além das minhas capacidades. Mas acredito que o problema agora não tenha nada a ver com o swap, mas sim com a inicialização do systemD.

Tem um post bem completo sobre otimização, de repente vale dar uma olhada especialmente na parte que vc pode gerar uma imagem com o encadeamento de unidades. [Distro/Desktop] Otimizando o systemd - 8 passos (adic. 5 passos e removido 1) 07/09/20 Ou aguardar se alguém que saiba mais possa dar uma luz.

Muito obrigado. Já estava querendo formatar. Bom que agora já tenho mais estímulo kkkk. Abraços

qual a saída do comando

cat /etc/mtab

ou

cat /etc/mtab | column -t

e mande também o comando do

lsblk -f

seria interessante também o comando

findmnt -u -t ext4,ext3,vfat,fat,btrfs -o uuid,target

Obrigado pelas dicas. Não poderei testar, pois ontem formatei e instalei de novo. De toda forma muito obrigado :slight_smile:

Swap é uma parte sensível do sistema.
Se alguma coisa pediu root então é perigoso.

Você poderia executar o comando ?

cat /etc/fstab

Ahhh !

Deixa pra lá.

Só vi agora que você instalou de novo.

Devia ter alguma coisa errada, pois a mensagem fala do uuid c8dccecc8… e ele não aparece no blkid.