Como instalar warsaw corretamente, acesso Caixa Internet Banking

Boa tarde, até semana passada estaava conseguindo logar no site da Caixa Internet Banking
Porém agora não consigo, já removi e resintalei o warsaw já limpei os navegadores, já reinstalei eles
Já usei o programa do proprio site da Diebold porém nada, eu instalo ele, ele aparece normal na central de programas, porém em nenhum navegador ele funciona, testei no W10 lá está normal, o problema mesmo é no ambiente linux.
Alguém com o mesmo problema? Alguma luz?
Não, não vou usar o W10 pra acessar o Internet banking então não precisa dar essa sugestão.
Ubuntu 18.04.4 LTS x64

1 Curtida

Eu percebi que ele sempre dava problema quando ficava muito tempo ligado o computador. Então quando eu queria usar (na época que eu usava Debian) eu fazia o seguinte:

a) Fechar o navegador (eu usava firefox)
b) sudo systemctl stop warsaw
c) ps ax | grep war
d) sudo kill -9 (PID dos processos warsaw/core e warsaw/wsatspi)
e) sudo systemctl start warsaw
f) Abria o navegador e entrava no site do banco.

Explicação:
b) Terminar execução do daemon warsaw via systemctl (nunca dava certo, o warsaw é imortal pelo sistema)
c) Listar todos os processos que possuem “war” no nome dele. Assim você identifica eles pelo PID para matá-los no próximo passo. As vezes tinham vários processos!!!
d) Matar os processos do warsaw de modo bruto (opção -9) como root
e) Iniciar daemon do warsaw pelo modo gracioso.

Se por acaso essa solução funcionar, uma opção é desativar o warsaw no boot (sudo systemctl disable warsaw) e iniciá-lo apenas quando for usar o site do banco (sudo systemctl start warsaw).

2 Curtidas

Eu já nem uso mais o PC para usar o Internet Banking da Caixa, faço tudo pelo celular. Mesmo assim acabei de testar e está normal aqui (no Fedora) Pode ser uma boa pra ti usar o celular, ao menos enquanto não consegue resolver.

Escrevi um artigo lá no blog Diolinux sobre isso há algum tempo atrás, e existem 3 métodos relativamente diferentes para instalar o Warsaw. Já tentou ambos? Talvez funcione.

1 Curtida

Acabei de testar, infelizmente não funcionou =\ já até “purguei” ele e resintalei e tal

1 Curtida

Jedi! blz cara!?

Cara até pensei em usar no celular, porém preciso dar acesso a ele pelo internet banking ou talvez indo até o banco usar o caixa eletrônico, o problema é comigo, poís no notebook da minha esposa está funcionando normal, vou dar uma olhada no blog pra ver esses métodos, já fiz pelo terminal, pelo .deb do site da caixa e pelo .deb da Diebold, mas vou lá dar uma olhada!

Ps: não tinha uma opção aqui no fórum de “juntar” respostas?

O procedimento do site sempre funciona aqui (voce deve acessar o site duas vezes, uma para baixar o pacote e outra para validar), mas evite instalar e desinstalar senão toda vez tera que refazer o procedimento e inclusive tendo que habilitar a máquina novamente.

1 Curtida

O procedimento do site sempre funciona aqui, mas evite instalar e desinstalar senão toda vez tera que refazer o procedimento e inclusive tendo que habilitar a máquina novamente.


Passo 1 baixar o pacote


Passo 2 validar o pacote e instalar as configurações da caixa.

Em momento algum é necessário fechar o navegador, só lembrando que talvez você tenha que recadastrar o usuário que agora é o CPF :wink:

1 Curtida

Aew cara! então eu já havia feito esse procedimento, eu havia procurado no fórum antes de fazer a postagem. mesmo com o warsaw instalado, o site da Diebold tbm diz que não está instalado, igual na img que postei lá em cima.

Mas notei uma coisa agora, quando reinicio o PC o warsaw some da lista de programas instalados la na loja de programas, usando o terminal com o comando “ps -ef |grep -v grep |grep -i warsaw” ele me retonar o seguinte
manji@ubuntu1804:~$ ps -ef |grep -v grep |grep -i warsaw
root 12141 1 0 18:01 ? 00:00:01 /usr/local/bin/warsaw/core
manji 12154 1 0 18:01 ? 00:00:00 /usr/local/bin/warsaw/core

Não sei se estou certo, mas acho que era pra retornar 3 linhas.

rod@gentoo ~ $ ps -ef | grep war
rod 16270 16252 0 18:11 pts/2 00:00:00 grep --colour=auto war
root 18685 1 0 fev06 ? 00:00:14 /usr/local/bin/warsaw/core
rod 18689 1 0 fev06 ? 00:00:04 /usr/local/bin/warsaw/wsatspi

1 Curtida

Não mesmo, verifique a versão do openssl teoricamente se a versão estiver correta tem que funcionar.
o outro serviço só depois que reinicia a máquina se eu me lembro que é o daemon wtsapi, as novas versões não requerem reinicio de imediato graças ao systemd. Antigamente erra um porre.

Tenho instalado no Fedora 31 e no Rawhide, mais tarde vou instalar o Ubuntu para testes daí verifico se o problema ocorre.

1 Curtida

EStou baixando o 18.04 pois só tenho versões mais novas, assim que terminar aqui testo em uma VM e posto os resultados aqui nesta mensagem.

Estou com essa versão
manji@ubuntu1804:~$ openssl version -a
OpenSSL 1.1.1 11 Sep 2018
built on: Tue Nov 12 16:58:35 2019 UTC
platform: debian-amd64
options: bn(64,64) rc4(8x,int) des(int) blowfish(ptr)
compiler: gcc -fPIC -pthread -m64 -Wa,–noexecstack -Wall -Wa,–noexecstack -g -O2 -fdebug-prefix-map=/build/openssl-kxN_24/openssl-1.1.1=. -fstack-protector-strong -Wformat -Werror=format-security -DOPENSSL_USE_NODELETE -DL_ENDIAN -DOPENSSL_PIC -DOPENSSL_CPUID_OBJ -DOPENSSL_IA32_SSE2 -DOPENSSL_BN_ASM_MONT -DOPENSSL_BN_ASM_MONT5 -DOPENSSL_BN_ASM_GF2m -DSHA1_ASM -DSHA256_ASM -DSHA512_ASM -DKECCAK1600_ASM -DRC4_ASM -DMD5_ASM -DAES_ASM -DVPAES_ASM -DBSAES_ASM -DGHASH_ASM -DECP_NISTZ256_ASM -DX25519_ASM -DPADLOCK_ASM -DPOLY1305_ASM -DNDEBUG -Wdate-time -D_FORTIFY_SOURCE=2
OPENSSLDIR: “/usr/lib/ssl”
ENGINESDIR: “/usr/lib/x86_64-linux-gnu/engines-1.1”
Seeding source: os-specific

:sob: estou quase pensando em formtar kkkkk
Vou aguardar seu teste, mas como disse ali em cima, o notebook da minha esposa que tbm é o ubuntu 18.04.4 LTS está funcionando normalmente o warsaw, o problema deve ser em algo no meu sistema

Na base Arch um usuário descobriu que é necessário o gtk2 ao menos no primeiro acesso/configuração ao banco, então verifique se isso é relevante na sua distribuição.

Saudações.

2 Curtidas

Cara eu ia fazer o teste agora, mas o 18.04 não vai com a minha cara, não queria gravar no pendrive mas aqui na VM eu abro o firefox e ele trava kkkkkk isto só acontece com o Ubuntu não acontece com nenhuma derivada. Tô estressado de tentar rodar o ubuntu na VM.

1 Curtida

Isto está como dependência no arquivo control do pacote.

Package: warsaw
Version: 1.13.1-2
Architecture: amd64
Maintainer: Diebold Nixdorf OFD Desktop <supportgas@dieboldnixdorf.com>
Installed-Size: 33240
Depends: libdbus-1-3, procps, zenity, libc6, zlib1g, libgtk2.0-0, libgdk-pixbuf2.0-0, libpango-1.0-0, libglib2.0-0, libx11-6, libstdc++6, libgcc1, libnss3, libxi6, libatspi2.0-0
Suggests: python3-gpgme | python3-gpg
Section: non-free/net
Priority: optional
Description: Package warsaw provides the needed software to use some banking services
 The package warsaw will easily add the required software to let you use some
 of the internet banking services of popular financial organizations in South
 America. If you are unsure if you need this package please call your service
 desk and ask them for instructions.

Bom vou gravar a imagem do Ubuntu no pendrive e testar, mas pelo que o @Manji disse no da esposa dele funciona, pode ser arquivos de configuração no $HOME.
Eita depois de eita @Manji já tentou remover o pacote e os arquivos de configuração do $HOME e ir no site da Diebold novamente?

.config/cef/

Eu sei disso, por esse motivo eu coloquei para ele verificar se isso é relevante na distribuição dele.

Saudações.

1 Curtida

Aqui no meu pc é .config/cef_user_data já no da minha esposa não tem a pasta cef nem /cef_user_data
Dentro tem uma pasta Dictionaries e dentro um arquivo pt-BR-3-0.bdic
Posso dar uma purgada no warsaw do site da Diebold e ver se esses arquivos some e tal

@tioguda até semana passada estava normal, ontem quando precisei entrar deu esse erro, pensei que era alguma atualização hoje nenhum dos meus navegadores funciona, mesmo estando instalado
Warsaw virou e disse “essa semana não kkkk”

@Xterminator, não precisa se estressar não kkkk, não tem problema isso é só mais um motivo pra deixar o ubuntu e partir pra uma distro nova, manjaro, fedora ou coisa do tipo

@Manji sem problemas cara, mas se conseguir resolver é melhor podem surgir outras pessoas com o mesmo problema, já gravei o pendrive “tomara que não trave” só vou buscar uma breja antes kkkk.

cd pub && more beer

Verifica na pasta /tmp/upd, aqui os arquivos ficam nela, ao apagar essa pasta você pode refazer as configurações como se tivesse acabado de instalar o warsaw.

Na base Arch aconteceu +/- no mesmo periodo, espero que eles lacem uma atualização para corrigir isso, já que a ultima att foi em maio do ano passado.

Saudações.

Tive um problema identico ao seu, mas no meu caso só o Chrome apresenta o problema, no Firefox está normal