1 package can be upgraded. Run 'apt list --upgradable' to see it,no deepin

olha gostaria de saber que menssagem é essa que aparece quando eu dou um apt update???Captura%20de%20Tela_%C3%81rea%20de%20Sele%C3%A7%C3%A3o_20190911121532
ja dei esse comando que ele indica e aparece isso Captura%20de%20Tela_dde-desktop_20190911121721

São os pacotes disponíveis pra atualizar. Só rodar sudo apt upgrade

Quer dizer que existe um pacote para ser atualizado (instalado)
Roda o comando sudo apt upgrade que instala.

Informando que há pacotes para atualizar. Dê um sudo apt upgrade, assim como o @filipemosca e o @Diney mencionou, para baixar e instalar as atualizações :slight_smile:

1 Curtida

então eu rodei esse comando e aparece que não tem nada pra atualizar,e quando eu rodo apt update continua aparecendoCaptura%20de%20Tela_dde-desktop_20190911125523

1 Curtida

sudo apt update && sudo apt upgrade -y

Em suma, tente rodar um update depois o upgrade.
Se não funcionar tente pelo gerenciador de atualizações do próprio deepin.

1 Curtida

Veja! Acabei de atualizar 2 pacotes aqui no meu Deepin.

1 Curtida

deepin-screen-recorder_tilda_20190911135219

1 Curtida

Como @Cleverson mencionou.
Se não funcionar tente pelo gerenciador de atualizações do próprio deepin.

1 Curtida

Não tenho certeza se faz alguma diferença entre usar apt ou apt-get, mas tente:
sudo apt-get update && sudo apt-get upgrade -y :thinking:

Às vezes o apt faz graça pra atualizar com o sudo apt upgrade, então você tem que executar o sudo apt dist-upgrade, ai sim ele vai atualizar esse(s) pacote(s) chato.

2 Curtidas

Resolveu meu problema!!
Obrigado.

Isso acontece porque o comando “apt upgrade” apenas atualiza os pacotes, ele não pode remover nem reinstalar os pacotes, e às vezes acaba sendo necessário fazer exatamente isso para realizar uma atualização. Por isso tem algumas vezes que só dá pra atualizar algum pacote com o “apt dist-upgrade”.

Na vdd, é só usar o comando:
sudo apt full-upgrade -y