X Error of failed request: GLXBadFBConfig: Lutris não roda Wow

Bom pessoal, já sou nativo no Linux a algum tempo e me deparei com essa “solução mágica” que é o lutris, não uso o windows a um bom tempo e quando vi a possibilidade de jogar meus jogos prediletos com o linux, então nem pensei duas vezes, o que ocorre é que a instalação do wow esbarra nesse problema de configuração, não sei exatamente o que aconteceu, tipo meu hardware é bem modesto, mas acredito que possa rodar esse jogo, minha distribuição é Xubuntu 20.04 LTS e tenho uma placa intel hd graphics 2000 e um processador intel celeron B800, é triste sei disso, mas no momento não posso fazer muita coisa infelizmente…

eu dei uma pesquisada e isso não tem nada a ver com a sua configuração, é um bug do mesa 21 q ainda não foi corrigido

Como o Fhilipe disse, isso é um bug, e eu também presenciei o mesmo problema. Porém eu consegui solucionar fazendo downgrade no pacote lib32-mesa. Eu utilizo uma distribuição baseada em Arch Linux, e para fazer Downgrade é só você entrar nesse repo,baixar o Mesa na versão 20.3.4-3, e depois dar o seguinte comando:

sudo pacman -U "O pacote que foi baixado"

Em distros derivados do Ubuntu é só dar o comando:

sudo apt-get install "pacote" "número da versão"

Em alguns casos, você só precisa dar esse comando:

export MESA_GL_VERSION_OVERRIDE=4.5 | export LIBGL_ALWAYS_SOFTWARE=1

Espero que isso possa ajudar.