Wi-Fi sempre caindo no Ubuntu 20.04

Pessoal, boa tarde.

Utilizo o Ubuntu há anos e o este problema tem sido uma constante em meu atual notebook.
Mantenho dual boot com o Windows 10 e o problema se dá com o Wi-Fi no Ubuntu. Quando ele cai – e cai frequentemente –, dificilmente reconecta sozinho. Preciso desligar o Wi-Fi, religar e, quando ele reconecta, ganho mais alguns minutos, ou segundos, enquanto ele não cai novamente. No Windows, nada disso acontece, o que me afasta da possibilidade de um problema de hardware.

Abaixo, as saídas do neofetch e as infos do controlador de rede.

description: Interface réseau sans fil
produit: QCA9565 / AR9565 Wireless Network Adapter
fabricant: Qualcomm Atheros
identifiant matériel: 0
information bus: [email protected]:01:00.0
nom logique: wlp1s0
version: 01
numéro de série: a4:fc:77:7e:fd:75
bits: 64 bits
horloge: 33MHz
fonctionnalités: pm msi pciexpress bus_master cap_list rom ethernet physical wireless
configuration : broadcast=yes driver=ath9k driverversion=5.8.0-44-generic firmware=N/A ip=192.168.1.124 latency=0 link=yes multicast=yes wireless=IEEE 802.11
ressources : irq:16 mémoire:d1100000-d117ffff mémoire:d1180000-d118ffff

Desde já, agradeço!

2 curtidas

Ah, o famigerado Qualcomm Atheros… experimenta os kernels 5.4 e 5.10 e veja se melhora

Tem vídeo do Dio ensinando a trocar o kernel em distros Ubuntu-based, olha no YT!

1 curtida

Just to save some time for the OP

2 curtidas

@Rodrigo_Chile muito obrigado pela sugestão. Instalei o 5.10, mas pelo visto ele está com problemas no Bluetooth. Agora estou com o 5.4 e usarei ele por um tempo para ver se noto diferença. Como noto as quedas principalmente em videochamadas (e as faço majoritariamente durante a noite) esperarei 24h para comemorar. Espero voltar apenas para agradecer. Abraço!

1 curtida

Grato, @JG22 !

2 curtidas

A propósito:

1 curtida

Sim, o 5.10 me deu dor de cabeça com o bluetooth tbm (uso o mesmo Qualcomm Atheros aqui) - mas como estou no Manjaro, um amigo fez o patch sugerido num relatório de erros do Arch e deu certo. No 5.11, no Manjaro parou de funcionar; já no Garuda, com Kernel 5.11-tkg-bmq, voltou a funcionar (vai entender?)

Acredito que o no 5.4 funcione normalmente sim… mas avisa

1 curtida

@Rodrigo_Chile , boa noite! Rapaz, mais de um dia com o kernel 5.4 e a diferença é bizarra. Está muito melhor, muito mesmo. Confesso que não havia cogitado essa solução antes, nem a havia visto em outros fóruns. Muito obrigado, mesmo!

1 curtida

Feliz em poder ajudar!

Este tópico foi fechado automaticamente 3 dias depois da última resposta. Novas respostas não são mais permitidas.