VS Code travando no Linux Mint 20

Olá Pessoal, já pesquisei na internet e aqui no fórum mas não encontrei solução para o meu problema. Eu instalei o VS Code pelo site oficial mas vez ou durante a ‘codagem’ ele trava por alguns segundos (às vezes passa de 30 segundos travado) e depois volta ao normal. Mas isso acontece algumas vezes e incomoda bastante. Eu normalmente uso o VS-Code em paralelo com o Google Chrome em sites de vídeo-aulas que assisto. Achei que o problema só acontecesse se eu ligasse o computador com VS-Code, Chrome, app do whatsapp e telegran e o spotify ligados juntos, mas mesmo ligando só o chrome e o vs-code o problema continua.

Já alterei o chrome para não Executar aplicativos em segundo plano quando o Google Chrome estiver fechado e não Usar aceleração de hardware quando disponível mas não resolveu.

Vi aqui no fórum pessoas dizendo que resolveram instalando a versão SNAP, mas aqui também não resolveu.

Será que é falta de memória?

Meu computador:
Linux Mint 20.1 CInnamon
Versão do Cinnamon: 4.8.6
Kernel: 5.4.0-65-generic
Processador: Core I5-4590 @ 3.30GHz x 4
Memória: 3.8Gb
HD: 2002.1 Gb
Placa de Vídeo: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated

Instalação:
/dev/sda1 fat32 /boot/efi 476Mb
/dev/sda2 ext4 / 107,51Gb
/dev/sda3 swap 3.81Gb
/dev/sda4 ext4 /home 819.72Gb

Obrigado a todos pela ajuda.

É falta de memória sim, o VS Code é feito em Electron, que é basicamente um Chromium embutido.

O Chrome sozinho já puxaria toda a memória, com o VsCode, a coisa complica. Sua solução é aumentar a quantidade de memória ou então testar outro editor de texto.

Um editor que é bem leve é o Sublime Text, ele é nativo e consome bem pouca memória.

Você também pode usar o Gedit/Xed que vem no Cinnamon por padrão.

Se for ainda mais hardcore, pode usar o Vim no terminal.

Tudo vai depender do que você está programando, uma IDE pode ser útil também.

Oi nando3d

Eu achei estranho porque só uso o VS Code para coisas simples de JS por enquanto. Não instalei quase extensão nenhuma nele. Vou comprar mais memória sim. Isso já estava nos meus planos. Mas como não vi ninguém reclamando de algo tão específico pensei que pudesse ter algo de configuração no Linux pra fazer.

Além disso eu usava o VSCODE no Windows há uns meses atrás e não tinha esse travamento.

Sublime Text eu já usei. Ele realmente é bem leve.

Gedit/Xed não conhecia.

Da última vez que testei Linux Mint 20.1, ele dava travada e também era lento em comparação com outras distros. Então estou usando Ubuntu 20.10, está funcionando muito bem.

Depois tu dá uma testada nas outras distros (por exemplo: Pop! OS, Zorin OS, Kubuntu, Xubuntu e etc) para ver se acontece mesmo problema. Eu não acho que seja problema de memória.

Pois é, Guilherme. Acho que vale à pena testar outras distros sim, antes de comprar mais memória. Seria uma economia por agora. Entrei no site do Ubuntu, como sugeriu, mas só encontrei versões para AMD64
Ubuntu 20.04.2.0 LTS (Focal Fossa) Serve para Intel também, né?

Vou ver o Kubuntu também. As outras distros que citou eu não conheço.

Chato é refazer todas as instalações e configurações de uma nova distro, mas se parar o travamento, acho que vale o esforço.

1 Curtida

Sim serve para Intel.

Tem que como fazer dual boot entre duas distros (ou até mais), já que vc tem armazenamento grande. Assim dá para aproveitar a distro que vc já tem instalado e configurado no PC.
Mas não sei se dá para fazer dual boot com as coisas que vc já configurou. Talvez dê certo.

Desculpe a ignorância e sei que já estou saindo do tópico

Basta eu reparticionar a HOME e incluir outra partição para a nova distro, né? E escolher outro nome de usuário na mesma home para essa nova distro, certo? A partição SDA1 que coloquei EFI seria comum às duas distros, né?

Enquanto aguardo mais opiniões sobre esse problema no Linux Mint, vou fazer esse dual boot para testar.

1 Curtida

Provavelmente porque no Windows, o VS Code roda com aceleração de hardware ativada.

Talvez desabilitando, você ganhe performance:

  • Abra a Paleta de comandos (Ctrl + Shift + P).
  • Execute o comando Preferences: Configure Runtime Arguments .
  • Este comando abrirá um argv.json arquivo para configurar argumentos de tempo de execução. Você já pode ver alguns argumentos padrão lá.
  • Adicionar "disable-hardware-acceleration": true .
  • Reinicie o VS Code.

Desativar restauração do estado do projeto na inicialização

O VS Code restaura automaticamente o estado do projeto da sessão anterior. Isso pode prolongar o tempo que leva para carregar um projeto.

Você pode desativar algumas das configurações de restauração para acelerar o tempo de carregamento:

  • Workbench › Editor: Restore View State : Ativado por padrão.
  • Files: Restore Undo Stack : Ativado por padrão.
  • Workbench: Startup Editor : Controla qual editor é mostrado na inicialização. O padrão é welcome page . Você pode definir isso para none evitar que qualquer editor apareça na inicialização.

Desative recursos caros que afetam o desempenho de edição

  • Minimap: Editor › Minimap: Enabled. Habilitado por padrão.
  • Word wrap: Editor: Word Wrap. Desabilitado por padrão.
  • CodeLens: Editor: CodeLens. Habilitado por padrão.
  • Format on Save: Editor: Format On Save. Desabilitado por padrão.
  • Format on Paste: Editor: Format On Paste. Desabilitado por padrão.

Legal nando3d. Você me forneceu várias opções de configuração para fazer. Vou testar por um tempo para ver se resolveu e volto aqui para dar feedback. Obrigado mesmo.

1 Curtida

Sim, pegar parte da home para nova distro, porém vc pode usar a mesma home que vc criou para Linux Mint, mas tem que colocar o mesmo nome de usuário.

@nando3d, alterei o Runtime Arguments mas o travamento aconteceu enquanto codava em javascript, assim que abri o spotify. Fiz isso de propósito para testar.

Desativar restauração do estado do projeto na inicialização

Isso não fiz porque não tenho problemas na inicialização do VS Code

Desative recursos caros que afetam o desempenho de edição

Verifiquei que só tinha o MInimap habilitado. Então deixei do mesmo jeito.


@Guilherme_Henrique
Obrigado pela ajuda. Não sabia que podia usar o mesmo nome de usuário de home para duas distros diferentes. Achei que uma sobrescreveria a outra. Já baixei aqui e vou instalar para ver como ele se comporta com o Ubuntu 10.4.

EDIT:
O ubuntu 10.4 torna o computador bem mais lento. Abrir qualquer programa leva vários segundos. O Linux MInt 20.1 está bem mais otimizado para o meu computador.

Vou testar o Manjaro XFCE. Assim que puder mando notícias.

2 Curtidas

O Manjaro começou bem. Instalei o vscode oss via instalador. Depois desinstalei e instalei a versão snap. Tudo ok. Antes eu tinha instalado o node via snap com sucesso. Instalei a extensão node.js Exec. Criei um arquivo teste para exibir ao digitar F8 no vs code e estava tudo funcionando. De repente deu uma travada e desde então esse f8 passou a não exibir o console.log(‘teste’) no output do vs code.

Aparece:
Info: Start process
Info: End process

Sem aparecer nada entre eles. Deveria ter aparecido a palavra teste entre eles. Usando a opção debugar (F5) aparece um aviso de que a versão do node estaria desatualizada:

" The node version in “/snap/bin/node” is outdated(version), we require atleast Node 8.x"

Isso não é verdade. A versão é 12. alguma coisa. E o próprio vs-code me avisa isso quando coloco -version dentro dele.


Continuo na luta para fazer o vs code parar de dar suas travadinhas durante os estudos usando Mint, mas como no Manjaro XFCE fluiu bem estou acredito no @nando3d de que deve ser falta de memória mesmo. No windows 7 funcionava bem, talvez por ser bem mais antigo mesmo. Se alguém tiver mais alguma dica, manda aí por favor.

1 Curtida

Instalei o mint 20 xcfe e funcionou bem melhor. Muito raramente o vscode dá umas travadinhas mas além de menos constante também leva menos tempo para destravar. Consegui usar vários programas simultaneamente sem problema. Isso vai adiar a compra de memória por enquanto.

Existe um modo de instalar o mint xfce na partição onde está o mint cinnamon, mantendo os programas já instalados e configurações já feitas? Acho que não mas não custa perguntar. Pretendo usar o mesmo nome de home. Seria só porque tenho TOC com a organização das partições que uso. rsrs

1 Curtida

Tem um jeito de instalar a interface XFCE, rodando esse comando no terminal:
sudo apt install mint-meta-xfce

Aí tu muda de interface lá pela tela de login.

Mas não fica perfeito, fica faltando algumas coisas, pelo menos foi o que aconteceu comigo quando instalei outra interface.
Então tu vê aí para ver se já tá bom para vc.