Virtua box dando erro

#1

Bom dia a todos sou iniciante no linux, instalei o virtual box coma iso do deepin 15.9 seguindo passo a passo do video VirtualBox - Testando sistemas operacionais SEM FORMATAR! E aparecem esses erros Falha ao abrir uma sessão para a máquina virtual Deepin 15.9.

The virtual machine ‘Deepin 15.9’ has terminated unexpectedly during startup with exit code 1 (0x1).

Código de Resultado: NS_ERROR_FAILURE (0x80004005)
Componente: MachineWrap
Interface: IMachine {5047460a-265d-4538-b23e-ddba5fb84976}

Me desculpem se postei algo errado é meu primeiro post, agradeço a todos que poderem ajudar,

1 Like

#2

A solução está ali no erro, rodar o comando em azul como root. :slight_smile:
Experimente:

sudo /sbin/vboxconfig

1 Like

#3

obrigado, tentei aqui, estou quebrando a cabeça, rsrsrs, ja reiniciei e ele me dá essa menssagem…

nekrwolf@nekrwolf-HP-14-Notebook-PC:~$ su
Senha:
root@nekrwolf-HP-14-Notebook-PC:/home/nekrwolf# sudo /sbin/vboxconfig
vboxdrv.sh: Stopping VirtualBox services.
vboxdrv.sh: Starting VirtualBox services.
vboxdrv.sh: Building VirtualBox kernel modules.
vboxdrv.sh: failed: modprobe vboxdrv failed. Please use ‘dmesg’ to find out why.

There were problems setting up VirtualBox. To re-start the set-up process, run
/sbin/vboxconfig
as root.
root@nekrwolf-HP-14-Notebook-PC:/home/nekrwolf# /sbin/vboxconfig
vboxdrv.sh: Stopping VirtualBox services.
vboxdrv.sh: Starting VirtualBox services.
vboxdrv.sh: Building VirtualBox kernel modules.
vboxdrv.sh: failed: modprobe vboxdrv failed. Please use ‘dmesg’ to find out why.

There were problems setting up VirtualBox. To re-start the set-up process, run
/sbin/vboxconfig
as root.

ai usei o comando dmesg como ele pediu pra encontrar outro caminho, mas fiquei mais confuso, vou mandar só uma parte do painel depois do dmesg pq é enorme.

root@nekrwolf-HP-14-Notebook-PC:/home/nekrwolf# dmesg
[ 0.000000] microcode: microcode updated early to revision 0x24, date = 2018-04-02
[ 0.000000] Linux version 4.18.0-15-generic (buildd@lcy01-amd64-029) (gcc version 7.3.0 (Ubuntu 7.3.0-16ubuntu3)) #16~18.04.1-Ubuntu SMP Thu Feb 7 14:06:04 UTC 2019 (Ubuntu 4.18.0-15.16~18.04.1-generic 4.18.20)
[ 0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-4.18.0-15-generic root=UUID=6cdaead2-1dfb-4c48-ba3f-211fd6d7ddf3 ro quiet splash vt.handoff=1
[ 0.000000] KERNEL supported cpus:
[ 0.000000] Intel GenuineIntel
[ 0.000000] AMD AuthenticAMD
[ 0.000000] Centaur CentaurHauls
[ 0.000000] x86/fpu: Supporting XSAVE feature 0x001: ‘x87 floating point registers’
[ 0.000000] x86/fpu: Supporting XSAVE feature 0x002: ‘SSE registers’
[ 0.000000] x86/fpu: Supporting XSAVE feature 0x004: ‘AVX registers’
[ 0.000000] x86/fpu: xstate_offset[2]: 576, xstate_sizes[2]: 256
[ 0.000000] x86/fpu: Enabled xstate features 0x7, context size is 832 bytes, using ‘standard’ format.
[ 0.000000] BIOS-provided physical RAM map:

0 Likes

#4

Por onde você instalou ele? Instala pela Loja de aplicativos, Desinstala completamente primeiro o que você tem e depois instala novamente os 3 da imagem

1 Like

#5

desinstale essa versão, entre no site do virtual box e aperte em download virtual box 6.0 depois em Linux distributions depois em All distributions copie o link da pagina vai ser algo parecido com isso https://download.virtualbox.org/virtualbox/6.0.4/VirtualBox-6.0.4-128413-Linux_amd64.run istale o uget vai em criar novo download, pasta coloque download máximo de conexão 16 vai vim um arquivo no formato .run abra o terminal de um ls depois cd Downloads de ls de novo vai achar um arquivo parecido com esse nome VirtualBox-6.0.4-128413-Linux_amd64.run de um sudo chmod +x VirtualBox-6.0.4-128413-Linux_amd64.run depois de um sudo sh ./VirtualBox-6.0.4-128413-Linux_amd64.run depois e só confirmando que você vai ter o virtual box funcionado.

1 Like

#6

obrigado,Rogerio e Diego mas ainda sem solução.

0 Likes

#7

obrigado,Rogerio e Diego mas ainda sem solução.

1 Like

#8

@Ricardo99 tente isso

sudo apt-get install build-essential module-assistant

sudo m-a prepare

sudo /etc/init.d/vboxdrv setup

Se tudo tiver dado certo vc vai ver algo assim

astecinfo@astec $ sudo /etc/init.d/vboxdrv setup
Parando os módulos do kernel do VirtualBox … feito.
Recompilando os módulos do kernel do VirtualBox … feito.
Iniciando módulos do kernel VirtualBox … feito.

1 Like

#9

Se nenhuma das configurações que o pessoal passou aqui funcionar… dá uma olhada nas configurações na Bios do seu pc e vê se acha algo sobre virtualização e marca ou desmarca (altera) esta opção. Da uma olhada nesta configuração aqui do VirtualBox (imagem) e tenta marcado e desmarcado… eu não acho que deve ser isso mas tenta ai.

0 Likes

#10

Obrigado pessoal, amanhã vou tentar, aí falo no que deu.

0 Likes

#11

Boa tarde pessoal, em partes o problema foi resolvido, as duas ultimas dicas que são do Astec e do Rogerio nao tentei, desinstalei o mint e instalei o deepin e funcionou, mas agradeço a todos que ajudaram, valeu.

1 Like

#12

Bom dia amigos, resolvido instalação do virtual box no mint 19 cinnamon, eu tinha desinstalado o mint e fui pro deepin, mas meu notbook não é aquelas coisas e ficou com ins lags rsrsrs…sistema
Ficou assim instalei pelo gerenciador de aplicativos normalmente de pois tbm pelo instaldor baixei o virtualbox-guest-dkms, reiniciei a maquina e tudo funcionou.


Mais uma vez agradeço a todos pela ajuda e paciência.

1 Like