Vídeo .mkv com "glitches" no VLC

Oi pessoal,

Recentemente baixei uns episódios de um anime pra assistir com uns amigos, mas quando eu reproduzia ele ficava com uns glitches no vídeo e congelava em alguns momentos, mas o áudio continuava funcionando normal. Ele chegava até ficar normal, mas por pouco tempo

Reinstalei todos os codecs possíveis e atualizei o sistema antes disso. O que poderia ser?

Olá @Nyora :wave:

Você estaria logado usando Xorg? Se sim, tenta usar o Wayland.

:v:

1 Curtida

Sim, uso xorg. Acho que nem tenho Wayland, e se tiver não sei como usar. Uso Openbox, não sei se ele suporta Wayland.

:smile: O mundo da Informática me fascina. Por enquanto eu não tenho como tentar uma solução mas estou estudando sobre o openbox agora mesmo, se eu descobrir algo te aviso. Enquanto isso vamos aguardar se alguém já conseguiu resolver este detalhe.

Outra coisa, se puder, posta para nós as especificações do pc, tipo cpu, gpu.

:v:

1 Curtida

Tentou pra ver se isso se repete com outro player? Pode ser problema com os teus codecs, com os codecs instalados no vlc, ou mesmo no arquivo em si, que foi mal convertido ou com defeitos no download
Digo isso pq estou no Plasma (e no Gnome ocorre o mesmo): baixo mkv e rodo pelo vlc sem problemas, mas como é por torrent, os arquivos vem com integridade testada. As vezes que vi coisa assim, é pq era defeito do vídeo em si

Testei com mpv e realmente funcionou normal. Muito estranho.

Eu não tenho uma listinha com todos os pacotes que preciso instalar, principalmente os codecs que são muitos pra lembrar de cabeça, então eu sigo o esses passos do It’s FOSS. Fora isso, instalação do VLC padrão pacman -S vlc e só…

Isso que você fala sobre codecs instalados no VLC?

Olha, o VLC aqui está em castelhano, mas ele tem uma aba de configuração de codecs

Caberia fuçar aqui

No mais, é isso aí, vc instalou os codecs… pode tentar reinstalar pra ver se algo deu errado, atualizar o sistema, reiniciar e abrir só o vlc - vídeos em mkv pedem um tanto de processamento e o vlc é mais pesado que outros players…

O meu está da mesma forma.

1 Curtida

No meu ocorre esses glitches no VLC quando rodo vídeos com resolução acima do que é suportado pelo meu hardware.

Aí testa algumas mudanças - como forçar ou desligar a aceleração por hardware… segundo um artigo que achei aqui (não me parece lá muito confiável), diz em desligar a aceleração e que vc troque de player (o vlc não se daria mt bem com mkv) ou converta para outro formato (avi ou mp4)
Se vc conseguir rodar bem no Celuloid, creio ser já um avanço

Um amigo meu perguntou se suportava, porque o vídeo é em 1080p. Mas mesmo assim, no mpv funcionou normal.

Então seguindo essa linha de raciocínio, não é problema nem do vídeo e nem resolução que não é suportado…

1 Curtida

Vou tentar isso.
Valeu pelas dicas :wink:

1 Curtida