Upgrade do KDE Neon para "20.04 Focal Fossa"

Isto não é um “tutorial” ─ apenas algumas observações da minha experiência pessoal.

Como “cada caso é um caso”, é importante frisar que:

  1. Não tenho hardware crítico. tipo NVidia, Wifi, Bluetooth etc. ─ Apenas Intel i5 + mobo com iGPU Intel.

  2. Não uso PPA, Flatpak, Snap2, AppImage, jogos etc. ─ Só os repositórios-padrão + GoogleEarth

Por outro lado, também não uso Discover, nem outras “lojinhas”, e evito clicar em “atualizadores” GUI. ─ Costumo remover Discover, unattended-upgrades, Snapd etc. ─ Em geral, uso apt update para checar atualizações, e Synaptic para atualizar, instalar, remover, pesquisar pacotes.

Só no caso específico do KDE Neon, deixo de remover o PackageKit, pois os desenvolvedores insistem em que usemos o comando pkcon ─ coisa que só faço ao me preparar para um upgrade, por via das dúvidas. ─ O PackageKit usa o apt, e quando o apt diz que está tudo atualizado, até hoje o pkcon nunca discordou.

Neste caso, me certifiquei de que o KDE Neon estava atualizado, e iniciei o script, para salvar as saídas:

$ history
...
  283  2020-08-13_20-49-06 date && sudo apt update && date
  284  2020-08-13_20-49-30 sudo pkcon refresh
  285  2020-08-13_20-52-27 script

Em seguida, um único comando, para upgrade:

Script started on 2020-08-13 20:52:27-0300
...
$ date && sudo do-release-upgrade && date
Thu 13 Aug 20:52:32 -03 2020

... ... ... ... ... ...

System upgrade is complete.

Restart required

To complete the upgrade, a system restart is required.
If you select 'y' the system will be restarted.

Continue [yN] n
Thu 13 Aug 23:31:19 -03 2020

$ exit

Script done on 2020-08-13 23:31:48-0300

Ao final de alguns minutos, fui informado de que o upgrade do KDE Neon implicaria em remover 31 pacotes (na verdade, acabou removendo 296), instalar 641 pacotes novos, atualizar 2.132 pacotes, — download total de uns 2 GiB, — e demoraria cerca de 1 hora, a julgar pela velocidade da conexão até aquele momento.

Na prática, o download começou com uma média de 3,7 MiB/s (máximo 5,3 MiB/s), para os pacotes do repositório do KDE Neon; mas logo decaiu para uma faixa de 100 a 500 KiB/s, para os pacotes do repositório Ubuntu no Brasil; e o processo todo acabou demorando mais de 2h 30min (20:52 ~ 23:31).

A navegação no Chromium, a música local no VLC, o monitoramento pelo Conky e quase tudo mais continuou funcionando normalmente, durante todo esse tempo. — Apenas a Captura de tela (shortcut PrtScn + gnome-screenshot) deixou de funcionar por alguns minutos, entre 23:00 e 23:20; e o Dolphin e o Gwenview (abertos desde o início) não recuperaram o acesso às pastas, depois disso; — mas o Kate continuou salvando as anotações, até o final.

Ao reiniciar o computador, o UEFI-Bios me direcionou para o Grub do KDE Neon (por ser o mais recente), e ele carregou… o Linux Mint 20! (também 20.04 Focal Fossa). ─ Em suma, os dois se embaralharam.

Vale notar que desabilitei a detecção de outras distros (os-probe), tanto no Mint quanto no KDE Neon, ─ por isso, carregam direto, sem exibir o “Menu de inicialização”.

Isso não foi problema para mim, pois uso o Grub do openSUSE. ─ Bastou entrar no utilitário do UEFI-Bios, colocar de novo o Grub do openSUE no topo da lista ─ e depois atualizá-lo, para incluir eventuais alterações do KDE Neon.

À primeira vistta, nada tinha mudado no KDE Neon. ─ No dia 13 de Agosto, o upgrade não alterou nada no KDE, nem no Kernel.

(Só nos dias seguintes, o KDE recebeu atualizações).

Meu Chromium (.deb) não foi removido, nem substituído por nenhum “.snap2”. Apenas, agora ele aparece no apt / Synaptic como “obsoleto”, pois não é mais encontrado nos repositórios. ─ Portanto, tenho algum tempo para pensar no que vou fazer. ─ Provavelmente vou substituir pelo Google Chrome, tal como fiz no Mint 20.

O repositório do GoogleEarth foi automaticamente desabilitado, ao iniciar o upgrade, e bastou habilitá-lo de novo depois. ─ O GoogleEarth continua funcionando normalmente.

Não examinei as alterações no Wine, mas meu velhíssimo Dreamweaver continua funcionando.

A boa notícia é que agora o corona-cli funciona, ─ o que não acontecia antes, devido a algumas dependências.

O Gimp passou da versão 2.8 para 2.10, ─ mas para isso eu já estava preparado, desde o final de 2018. ─ Como esperado, algumas configurações foram preservadas e outras tive que refazer.

Mais alguns detalhes:

2 Curtidas