Ubuntu 20.04 não desliga

Oi gente, tudo bem?

Toda vez que eu vou desligar o meu notebook, aparece essa mensagem: “[ 5632.954451] reboot: Power down” . As vezes aparece outras juntos, mas na maioria das vezes somente essa.

Como que eu corrijo isso?

Meu notebook é em dual boot com o Windows 10.

Você poderia fornecer mais detalhes sobre o hardware? Qual o fabricante e modelo? Pode ser que o modelo seja muito recente e o kernel ainda não dê suporte ou que a fabricante fugiu dos padrões do ACPI (isso é muito comum, porque geralmente só validam com o Windows).

1 Curtida

Copiei do terminal

OS: Ubuntu 20.04.1 LTS x86_64
Host: Inspiron 3442
Kernel: 5.8.0-34-generic
Uptime: 3 mins
Packages: 2439 (dpkg), 10 (snap)
Shell: bash 5.0.17
Resolution: 1366x768
DE: GNOME
WM: Mutter
WM Theme: Adwaita
Theme: Yaru-dark [GTK2/3]
Icons: Yaru [GTK2/3]
Terminal: gnome-terminal
CPU: Intel i5-4210U (4) @ 2.700GHz
GPU: Intel Haswell-ULT
Memory: 1748MiB / 7865MiB

Infelizmente eu não sei, mas comigo eu ja reparei que acontecia coisa parecida. Eu desligava e ele ligava de novo. Notebook Dell Inspiron, mas mudei para o Ubuntu Bugie e até agora não aconteceu mais.

@knimer :wave:Então talvez ele teria de forçar no grub, acpi=force.

@Wagner_Brito :wave: você tem conhecimento, confortável com terminal? Pois você teria de acessar o grub ver como está a linha GRUB_CMDLINE_LINUX_DEFAULT= deve estar quiet splash e adicionar acpi=force depois update o grub com sudo update-grub ficaria:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"

depois

sudo update-grub e reinicia o computador.

Recomendo que faça o back up de tudo antes de tentar tals comandos.

Obs.: O caminho do arquivo é /etc/default/grub e o grub versão 2.

:v:

Bem, primeiro veja se tem algum erro indicado. Remova o “quiet” e “splash” dos parâmetros do kernel para ver as mensagens de inicialização ou desligamento:

Se quiser testar a informação do colega, vc também pode editar igual no vídeo e ver se resolve. Se resolver vc pode colocar no arquivo como recomendado pelo @RuKsu

1 Curtida

@Wagner_Brito Segue as instruções do @Deleterium para ver as mensagens é bem melhor assim. A minha sugestão é mais um “tapa buraco” porém é melhor resolver o problema.

@Deleterium Sou meio ruim de explicações :sweat_smile:, eu leio várias vezes oque eu escrevo mas mesmo assim depois que eu posto e leio denovo, fica confuso, :joy:. Fico feliz e muito obrigado por fazer uma explicação melhor :pray:

@Wagner_Brito Se conseguir resolver atribua a solução ao @Deleterium quaisquer coisas nos avise.

:v:

Oi pessoal.

Desculpe a demora para responder, eu fiquei um pouco enrolado aqui no meu emprego. Mas vamos lá, eu consegui arrumar.

Primeiro eu fiz sugestão do @RuKsu e adicionei o acpi=force no grub
GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash acpi=force”

Dei o update no grub e desliguei o computador. Apareceu a mesma mensagem de antes.
Voltei no grub e tirei o “quiet splash”. Dessa vez deu certo, o notebook desligou totalmente.

Espero que isso não estrague algo, não sei o que significa o “quiet splash”.

1 Curtida

Ficamos felizes em que o problema foi resolvido :smile: :pray: .

Curiosidade e conhecimento:
“quiet” é um comando que não deixa aparecer aquelas mensagens “correndo” quando você liga ou desliga o computador.
“splash” é um comando que mostra o logotipo no lugar de mostrar aquelas mensagens.

:v:

1 Curtida

Quando você deu o update-grub e desligou, a modificação ainda não estava valendo. Por isso que apareceu a mensagem.

Você pode colocar as opções “quiet splash” de novo, que deve continuar desligando normalmente.

2 Curtidas