Ubuntu 18.04/19.04 e problema com placa de vídeo híbrida Intel Nvidia Geforce 820M - Dell Inspiron 3442

Seguinte, me considero ainda meio novo no mundo Linux, mas to me esforçando pra aprender,

eu tenho um Dell Inspiron 14 3442 (adquirido em 2013), híbrido Intel + Nvidia, e estou tendo dificuldades para usar a GPU Nvidia GeForce 820M (site Dell). Alguns aplicativos mostram a mensagem dizendo que não foi possível utilizar o OpenGL e irá utilizar o X.org, e além disso, mesmo eu alterando as configurações no nvidia-settings, tanto em usuário normal quanto rodando “sudo nvidia-settings”, essas configurações não ficam salvas. Gostaria de saber o que está acontecendo e como fazer o Ubuntu utilizar ela, pois me parece que em drivers VGA ele ta utilizando o driver da Intel ao invés do Nvidia.

To utilizando o Ubuntu 19.04, mas isso também ocorreu no 18.04.2 LTS. No entanto, no 19.04 ele não apresentou os engasgos de tela que ocorriam no LTS e o 19.04 ja baixou e instalou os driver Nvidia durante a instalação do SO.

Quando instalo o driver mais recente pelo repositório do Ubuntu ou após add o ppa (Installing drivers · lutris/lutris Wiki · GitHub) o aplicativo Nvidia-Settings se limita apenas a mostrar duas opções no PRIME profiles: ( ) Nvidia Performance mode e ( ) Intel Power Saving mode. (igual desse post Ubuntu vs placa de video)

Em uma das tentativas, formatei e instalei por terminal o “nvidia-prime” e depois instalei o drive pelo aplicativo de Driver do Ubuntu, mas deu na mesma.

A grande dúvida é: o ubuntu ta realmente usando o driver e a Nvidia ??? Como faço pra saber isso ?

Meu note:

Dell Inspiron 14 3442 (2013)
HDD 1TB
Processador Quarta Geração Intel Core i5 (linha processador U - U-Processor Line)
8 GB RAM DDR3L
GPU nVidia GeForce 820M 2 GB DDR3L

Desde já agradeço a todos que se disponibilizarem a me ajudar !!!

– Quando rodo “lspci”:

– “nvidia-smi”

– “sudo nvidia-xconfig”

– apt search nvidia-*


Links visitados e tentativas:







NVIDIA DRIVERS Linux x64 (AMD64/EM64T) Display Driver (**teoricamente o drive da suporte pra placa 820M)
Estou com problemas em salvar configuração do Nvidia settings no ubuntu 9.10
https://www.diolinux.com.br/2018/10/como-instalar-drivers-nvidia-ubuntu-tutorial.html

Essa placa de video ai é só funciona com o driver 390.129, é mesma da minha.

2 Curtidas

Só uma pergunta, vc ta usando o Secure Boot ??? Se estiver, tenta desabilitar ele e reinstala o sistema e ve se melhora.

1 Curtida

E se a pesquisa estiver certa que fiz, a sua GPU suporta o driver mais novo da NVIDIA, conforme o print.

1 Curtida

Eu to usando tabela de partição GPT, “Fast boot” - [ativado], “Boot list option” - [UEFI], “Secure Boot” - [desativado], “Load Legacy Option Rom” - [desativado].

Sobre o print abaixo, eu creio que também fez a pesquisa certa e vendo um vídeo seu sobre o assunto eu também cheguei nessa página, mas após instalar tanto o 418, como o 430, a tela do Nvidia-settings fica igual desse post (Ubuntu vs placa de video).

Certoo. Tenta entao desativar o Fast Boot e mudar a partição GPT. E sobre so ter essas duas opções, é pq o driver da NVIDIA não foi instalado corretamente. Deixa só o UEFI instalado e na hora da instalação, faça o particionamento manual, deixando uns 700MB pra partição EFI. E logico, marcando a opção do Ubuntu instalar os drivers proprietários e tals. Qq coisa, vá no meu canal e veja o video sobre instalação de hibridas, talvez possa ajudar tb.

1 Curtida

Se a sua placa for a mesma da minha é da arquitetura Fermi a nvidia parou de dar suporte, só continuará lançando patches de segurança. Portanto só funciona até driver 390, até aonde eu sei.

3 Curtidas

Entendi. Eu já tinha visto o vídeo no seu canal e tava seguindo a recomendação de procurar pelos drivers mais novos e tudo mais, inclusive, parabéns !!! Me ajudou muito e aprendi várias coisas novas. Além disso, li um artigo da IBM falando da superioridade da GPT e fiz a instalação manual de tudo, da partição UEFI, da root “/”, da “/home”, “swap”.

Recentemente fiz uma instalação limpa do Ubuntu 18.04.2 LTS, antes de instalar o driver, instalei o “nvidia-prime”, add os ppas que o artigo do Lutris e da Steam recomendaram (e consta também num artigo do blog Diolinux) e depois instalei o driver 390.129 e deu certo.

Em uma outra partição instalei um driver acima do 390 e voltou a ficar com apenas as duas opções que comentei antes, então acho muito provável que minha placa seja da geração “Fermi” como o “Marcos_Conti” me respondeu abaixo.

Mas agradeço de qualquer forma a atenção e a ajuda !

2 Curtidas

Cara, muito obrigado !!! Não tava sabendo onde procurar e achar essa informação sobre geração das placas e etc.

Recentemente fiz uma instalação limpa do Ubuntu 18.04.2 LTS, antes de instalar o driver, instalei o “nvidia-prime”, add os ppas que o artigo do Lutris e da Steam recomendaram (e consta também num artigo do blog Diolinux) e depois instalei o driver 390.129 e deu certo.

Em uma outra partição instalei um driver acima do 390 e voltou a ficar com apenas as duas opções que comentei antes, então acho muito provável que minha placa seja da geração “Fermi” também !

Agora ta tudo certo !!!

Obrigado pela ajuda e disposição !

1 Curtida

De nada qualquer coisa estamos ai.

1 Curtida

eu tenho a mesma placa, e também não consigo instalar nenhum outro driver além do 390, mesmo no site da nvidia dizendo que o driver 430 seja compatível com a placa

1 Curtida