Ubuntu 18.04.02 lts rede cabeada não funciona

Instalei o Ubuntu 18.04.02 LTS em um notebook Samsung RV415 e a internet cabeada não funciona, só funciona a rede Wi-FI quando coloco o cabo de internet o sistema não reconhece, e nas configurações de rede não mostra a opção de rede cabeada eu tenho outro notebook que tem a mesma versão do ubuntu instalada e que mostra essa opção nas configurações e reconhece a rede cabeada assim que eu coloco o cabo de rede a unica diferença e que um e tem o processador intel e o outro amd

alguém pode me ajudar? eu preciso utilizar a rede cabeada nesse notebook pois o local que irei utilizar ele só tem internet cabeada não tem Wi-FI.

observe nessa imagem que nesse notebook aparece normalmente e eu não faço ideia porque no outro notebook não aparece alem de não reconhecer a rede imposibilitando que eu utilize a internet via cabo

Você tem que abrir um terminal para investigar o problema, somente pela inteface fica um pouco limitado. Realize a execução dos seguintes comandos no terminal.

  • root@dexter ip link esse comando verifica se a interface está UP ou DOWN, além de outras informações.

  • root@dexter:~# ip -s link show esse comando verifica o tráfego e estatística de pacotes

Posta a saída dos comandos aqui para que possamos examinar com você!

-

a saida

Não apareceu a interface de rede “cabeada”, aparentemente seu Ubuntu não a reconheceu. Vamos testar um último comando para verificar, testa ai: ip addr show e ifconfig -a

~$ ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 90:a4:de:bf:3c:a5 brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.14/24 brd 10.0.0.255 scope global dynamic noprefixroute wlp3s0
       valid_lft 82569sec preferred_lft 82569sec
    inet6 fe80::6f32:ceae:305:8253/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
~$ ifconfig -a
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Loopback Local)
        RX packets 786  bytes 70545 (70.5 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 786  bytes 70545 (70.5 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.0.0.14  netmask 255.255.255.0  broadcast 10.0.0.255
        inet6 fe80::6f32:ceae:305:8253  prefixlen 64  scopeid 0x20<link>
        ether 90:a4:de:bf:3c:a5  txqueuelen 1000  (Ethernet)
        RX packets 90498  bytes 121272726 (121.2 MB)
        RX errors 0  dropped 0  overruns 0  frame 18985
        TX packets 64787  bytes 6408628 (6.4 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 16  

Então, acho que temos um problema, a interface de rede pode estar com algum defeito ou Ubuntu não reconheceu o drive/módulo dela.
Quando você conecta o cabo na placa de rede do seu notebook os leds apresentam conectividade, ou seja, piscam?
Vamos descrobir qual é o fabricante da sua placa de rede, poste a saída do comondo lspci

Quando eu conecto o cabo é como se não estivesse cabo conectado

~$ lspci
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 14h Processor Root Complex
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 6310]
00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler HDMI Audio
00:04.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 14h Processor Root Port
00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode]
00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller (rev 42)
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) (rev 40)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 LPC host controller (rev 40)
00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge (rev 40)
00:14.5 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
00:15.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB700/SB800/SB900 PCI to PCI bridge (PCIE port 0)
00:15.1 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB700/SB800/SB900 PCI to PCI bridge (PCIE port 1)
00:15.2 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB900 PCI to PCI bridge (PCIE port 2)
00:15.3 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB900 PCI to PCI bridge (PCIE port 3)
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 0 (rev 43)
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 1
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 2
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 3
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 4
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 6
00:18.6 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 5
00:18.7 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 7
03:00.0 Network controller: Broadcom Inc. and subsidiaries BCM4313 802.11bgn Wireless Network Adapter (rev 01)

Não tem LED no notebook mas os led do roteador não pisca indicando que não está transmitindo dados

Faça a instalação desse firmware bcmwl-kernel-source e depois rode o comando lshw -class network para verificarmos se Ubuntu reconheceu o módulo.

1 Like
~$ sudo apt-get install  bcmwl-kernel-source
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
bcmwl-kernel-source is already the newest version (6.30.223.271+bdcom-0ubuntu4).
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.

@william agora foi certo
atingir o limite de mensagem que o iniciante tem por dia por isso editei essa publicação :sweat_smile:

~$ sudo lshw -class network
[sudo] senha para igreja-primitiva: 
  *-network                 
       descrição: Interface sem fio
       produto: BCM4313 802.11bgn Wireless Network Adapter
       fabricante: Broadcom Inc. and subsidiaries
       ID físico: 0
       informações do barramento: pci@0000:03:00.0
       nome lógico: wlp3s0
       versão: 01
       serial: 90:a4:de:bf:3c:a5
       largura: 64 bits
       clock: 33MHz
       capacidades: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuração: broadcast=yes driver=wl0 driverversion=6.30.223.271 (r587334) ip=10.0.0.14 latency=0 multicast=yes wireless=IEEE 802.11
       recursos: irq:16 memória:fea00000-fea03fff

@william O resultado deste comando ~$ lshw -class network está aqui logo a baixo:
eu já atingir meu limite diário de escrever respostas ai próximas respostas estarei editando as respostas existentes para responder

~$ sudo lshw -class network
[sudo] senha para igreja-primitiva: 
  *-network                 
       descrição: Interface sem fio
       produto: BCM4313 802.11bgn Wireless Network Adapter
       fabricante: Broadcom Inc. and subsidiaries
       ID físico: 0
       informações do barramento: pci@0000:03:00.0
       nome lógico: wlp3s0
       versão: 01
       serial: 90:a4:de:bf:3c:a5
       largura: 64 bits
       clock: 33MHz
       capacidades: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuração: broadcast=yes driver=wl0 driverversion=6.30.223.271 (r587334) ip=10.0.0.14 latency=0 multicast=yes wireless=IEEE 802.11
       recursos: irq:16 memória:fea00000-fea03fff

Opa, o comando é separado lshw -class network, foi erro meu.

@william

~$ sudo lshw -class network
[sudo] senha para igreja-primitiva: 
  *-network                 
       descrição: Interface sem fio
       produto: BCM4313 802.11bgn Wireless Network Adapter
       fabricante: Broadcom Inc. and subsidiaries
       ID físico: 0
       informações do barramento: pci@0000:03:00.0
       nome lógico: wlp3s0
       versão: 01
       serial: 90:a4:de:bf:3c:a5
       largura: 64 bits
       clock: 33MHz
       capacidades: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuração: broadcast=yes driver=wl0 driverversion=6.30.223.271 (r587334) ip=10.0.0.14 latency=0 multicast=yes wireless=IEEE 802.11
       recursos: irq:16 memória:fea00000-fea03fff

Estou quase desistindo de tentar resolver esse problema, no windows 8 ele funcionava ai no ubuntu 18.04.02 LTS ele não funciona Talvez deva tentar o Linux Mint ou voltar para Windows