Touchpad archlinux não funciona

Olá pessoal, tudo bem?

Mais um tópico da minha saga de instalação do archlinux.

Bom, instalei o Arch Linux recentemente, porém o touchpad não funciona corretamente. Os botões e o controle do mouse estão normais, mas o clique na área do touchpad não está funcionando.

Alguém pode me ajudar? Parece algo besta mas me faz perder um pouco de produtividade.

Então vamos ver como está a configuração do seu computador.

Baseado no arch wiki
https://wiki.archlinux.org/index.php/Touchpad_Synaptics

O xf86-input-synaptics não está mais sendo atualizado então nào recomenda fazer a instalação por ele.
Veja se tem ele instalado e pode removê-lo

sudo pacman -Rsn xf86-input-synaptics

Agora a instalaçào recomendada é pelo libinput
https://wiki.archlinux.org/index.php/Libinput

Como você usa o Xorg.

Instale ou veja se está instalado o xf86-input-libinput e o xorg-xinput

pacman -Qs xf86-input-libinput xorg-xinput

pacman -S xf86-input-libinput xorg-xinput

No Xorg por padrão já vem com a configuração (40-libinput.conf) instalado sem ter a necessidade de adição ou modificação.

crie um link simbólico

# ln -s /usr/share/X11/xorg.conf.d/40-libinput.conf /etc/X11/xorg.conf.d/40-libinput.conf

Uma maneira de verificar quais dispositivos são gerenciados pelo libinput é o arquivo de log do xorg. Por exemplo, o seguinte:
$ grep -e “Using input driver ‘libinput’” /path/to/Xorg.0.log

básica configuraçào
No arquivo

/etc/X11/xorg.conf.d/30-touchpad.conf

Section "InputClass"
    Identifier "devname"
    Driver "libinput"
   Option "ClickMethod" "clickfinger"`
EndSection

algumas opções
You may define as many sections as you like in a single configuration file (usually one per input device). To configure the device of your choice specify a filter by using one of the filters in the INPUTCLASS SECTION xorg.conf(5), e.g.

  • MatchIsPointer "on" (trackpoint)
  • MatchIsKeyboard "on"
  • MatchIsTouchpad "on"
  • MatchIsTouchscreen "on"

The input device can then be configured with any of the lines in the CONFIGURATION DETAILS section of libinput(4). Common options include:

  • Option "Tapping" "on" : tapping a.k.a. tap-to-click
  • Option "ClickMethod" "clickfinger" : trackpad no longer has middle and right button areas and instead two-finger click is a context click and three-finger click is a middle click, see the docs.
  • Option "NaturalScrolling" "true" : natural (reverse) scrolling
  • Option "ScrollMethod" "edge" : edge (vertical) scrolling
    Adicione o salve
2 Curtidas

Dependo do seu ambiente gráfico, isso é infelizmente o padrão, como é no meu (KDE Plasma).

Verifique se opção como “Simular clique com toque” ou algo parecido estão marcados no painel de controle.

só fazendo uma correção na mensagem anterior.

eu tinha dado o exemplo com synaptics

Mano, super obrigado! Deu certo agora!

1 Curtida

Surgiu mais um problema, que é com o botão direito do touchpad. Ao invés de abrir aquele menu de opções quando clico nele, ele está com a ação normal de clique

Veja as opções no manual
https://jlk.fjfi.cvut.cz/arch/manpages/man/libinput.4

Tente com buttonareas

Option “ClickMethod” “buttonareas”

Teria que ler o manual

Outra opção é remover

Option “ClickMethod” “buttonareas”

E Veja Se ele pega automaticamente

testa com esta configuração

Section "InputClass"
    Identifier "devname"
    Driver "libinput"
   Option "Tapping" "on" 
   Option "MatchIsTouchpad" "on"
EndSection

Descobri o que que era…

Eu entrei no Ajustes do Gnome e estava desativado. Mudei para Área.

Obrigado!