Telegram Desktop, versão flatpak, saltando na frente da tela

Enfrento esse há um tempo, tanto que desinstalei anteriormente por conta disso, mas agora reinstalei e estou precisando das soluções que só a versão desktop tem.

Basicamente é o seguinte: Toda vez que chega uma nova notificação, independentemente de que janela eu esteja visualizando na tela ou área de trabalho eu esteja, ele muda o foco para a área de trabalho onde ele está, trazendo pra frente de qualquer outra coisa que esteja aberta na tela no momento que a notificação chega.

Não faço ideia do que pode ser isso, creio não ser nada com o sistema, afinal acabei de fazer uma instalação limpa, uso o Pop Os 20.04, mas posso estar enganado, é só um palpite. Já procurei no próprio Telegram se há alguma opção que modifique esse comportamento, mas não encontrei nada parecido com isso, enfim, é isso, se alguém já se deparou com esse problema e puder me ajudar, ficaria muito grato.

Olá @oemissu,
Isso pode acontecer em múltiplos sistemas que não possuem um funcionalidade de “prevenção de roubo de foco”, eu não sei exatamente como o Pop OS lida com isso ou como o Telegram se comporta no sistema mas, se você pesquisar no Google, DuckDuckGo, etc. por: “prevent focus stealing” relativos ao seu Desktop Environment, provavelmente encontrará algo.


Eu pensei em uma possível solução, mas não garanto que irá funcionar não tenho como testar agora mas, caso queira tentar segue o tutorial:

Abra o terminal e digite o seguinte comando:

gsettings set org.gnome.desktop.wm.preferences focus-new-windows 'strict'

Informações sobre o comando:

  • Definirá um novo valor para a chave focus-new-windows uma preferencia do gerenciador de janelas do Gnome. O valor padrão normalmente é smart.

Outra chave que poderia alterar é a focus-mode para click:

gsettings set org.gnome.desktop.wm.preferences focus-mode 'click'

Após definir os valores reinicie o sistema para ter certeza que foi aplicado.


Para resetar os valores:

gsettings reset org.gnome.desktop.wm.preferences focus-new-windows
gsettings reset org.gnome.desktop.wm.preferences focus-mode

Espero que lhe ajude de alguma forma, até mais!

2 Curtidas

Apenas fazendo um adendo a minha primeira resposta.

Eu acabei lembrando que alguns D.E. como XFCE possuem um forma de lidar quando uma aplicação/janela “raise itsel”, não sei ao certo como colocar em pt-br mas, acho que seria algo como “sair do segundo plano”.

E lidará como isso das seguintes formas, quando uma janela “sai do fundo” pode:

  1. Trazer a janela para a area de trabalho atual.
  2. Mudar para área de trabalho da janela em questão.
  3. Fazer nada.

Fiz uma pesquisa e achei uma chave para o gsettings também relativa a isso é a auto-raise

Para desativar:

gsettings set org.gnome.desktop.wm.preferences auto-raise 'false'

Para resetar:

gsettings reset org.gnome.desktop.wm.preferences auto-raise

Espero que lhe ajude de alguma forma, até mais!

Não tenho como testar agora, quando chegar em casa eu testo sua sugestão, mas de antemão lhe desejo um muito obrigado, valeuzão mesmo

Outra opção é mandar o Telegram utilizar o sistema de notificações do seu próprio ambiente gráfico:

Menu Três Barras → Notificações → Usar Notificações Nativas

As notificações do Telegram não vão ficar mais com a aparência “distinta”, vão parecer com uma notificação padrão do seu ambiente gráfico, mas acho que vai eliminar esse problema.

2 Curtidas

Valeu, cara
Deu certo com a alteração da chave do “focus-mode” já

Obrigado mesmo

1 Curtida

@Eduardo_MS devo informar, infelizmente, que voltou o tal comportamento, testei de novo as mudanças nas chaves e estas não surtem efeito após o reinício do sistema, quando testei a primeira vez funcionou, mas agora não mais, só pude vir aqui agora fazer a essa atualização.

Até instalei o dconf-editor para gerenciar as chaves de forma gráfica, pra checar se elas voltavam ao padrão ao reiniciar, mas não.

Inclusive testei o que @Capezotte sugeriu e o que me acontece é que aparecem 2 notificações, a do Telegram sobreposta a do sistema.

Buscando por mais informações, encontrei em alguns fóruns, seguindo as sugestões do @Eduardo_MS, e me parece, pelos comentários, um problema bem antigo em sistemas que usam GNOME e, até hoje sem uma solução definitiva, cada distro lida de uma foma diferente e aqui no Pop! OS 20.04 não encontrei nada referente, procurei ajuda nos grupos da comunidade do Pop! OS no Telegram, mas até agora sem resposta nenhuma.

Vou reabrir o tópico desmarcando como solucionado, para que alguém que tenham outra informação possa talvez ajudar.

O Pop_OS! tem uma base Ubuntu mais algumas extensões. Pode testar soluções específicas de Ubuntu na maioria dos casos.

1 Curtida

Olá @oemissu,
Fiz uma analise no código e repositório do Telegram Desktop e aparentemente ele dependia do libnotify até mais ou menos, dezembro de 2019, e foram relatados diversos problemas similares ao seu, não apenas no Gnome mas, no KDE também.

Foi feito um merge no projeto que aparentemente solucionava este problema mas, mesmo assim vi alguns usuários relatando o mesmo problema que o seu. E um deles instalou por coincidência a libappindicator-gtk3, e relatou que o problema havia desaparecido após isso, e outro usuário relatou o mesmo.

Logo sugiro instalar a libappindicator no seu sistema para tentar mitigar este problema:

  • Debian / Ubuntu:
apt install libappindicator3-1
  • Arch Linux:
pacman -S libappindicator-gtk3
  • Open Suse:
zypper install libappindicator3-1

Lembre de reiniciar após instalar a libappindicator.


Espero ter lhe ajudado de alguma forma, até mais!

1 Curtida

No Pop!_OS há um problema com janelas pequenas sempre aparecendo sobre as demais janelas, ao invés de ficarem presas somente a janela principal do programa da qual ela pertence. Um exemplo disso é o Gerenciador de pacotes Synaptic, que no Pop!_OS a pequena janela de pesquisa fica sobre as janelas de outros programas em vez de ficar somente acima da janela principal do Synaptic.
Para resolver isso, é só desativar a extensão Pop Shell e reiniciar a sessão (ou o PC).
O único problema é que desativando o Pop Shell você ficará sem a função “tiling window”, mas se você não usa não terá problema.

1 Curtida

Estou procurando, mas não vão muita além das comentadas aqui as soluções que encontro, estou sem esperanças de encontrar uma solução para esse problema em específico.

Nesse link, um usuário copiou pelo menos 4 links de outros fóruns com esse mesmo problema.

Acabei de testar aqui, ainda sem sucesso :confused:

Olá, desabilitei, reiniciei o pc e nenhuma mudança sobre a questão :confused:

Fui ver sobre o assunto e realmente o problema é do próprio app mesmo. Tanto no Plasma quanto no Gnome tem relatos sobre isso e minha dica anterior não resolveria de qualquer forma.

Não há relatos no Plasma desde que eles fizeram a transição de biblioteca indicada pelo Eduardo_MS. Eu mesmo uso também o Flatpak do Telegram e não tenho esse problema, mesmo tentando induzi-lo de várias formas.

Eu tenho esse problema com o Mint, já no meu ubjntu funciona normalmente