Steam não inicia no Arch Linux

Sempre que eu tento abrir a steam acontece isso

Running Steam on arch rolling 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
/home/gmmacedo/.local/share/Steam/ubuntu12_32/steam
Installing breakpad exception handler for appid(steam)/version(1579321278)
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Installing breakpad exception handler for appid(steam)/version(1579321278)
Installing breakpad exception handler for appid(steam)/version(1579321278)
(steam:7362): Gtk-WARNING **: 18:43:54.876: Unable to locate theme engine in module_path: “adwaita”,
/usr/share/themes/Adwaita-dark/gtk-2.0/main.rc:733: error: unexpected identifier ‘direction’, expected character ‘}’
(steam:7362): Gtk-WARNING **: 18:43:54.881: Unable to locate theme engine in module_path: “adwaita”,
/usr/share/themes/Adwaita-dark/gtk-2.0/hacks.rc:28: error: invalid string constant “normal_entry”, expected valid string constant
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Steam: An X Error occurred
X Error of failed request: GLXBadContext
Major opcode of failed request: 154
Serial number of failed request: 49
xerror_handler: X failed, continuing
Steam: An X Error occurred
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 154
Value in failed request: 0x0
Serial number of failed request: 48
xerror_handler: X failed, continuing
Steam: An X Error occurred
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 154
Serial number of failed request: 50
xerror_handler: X failed, continuing
assert_20200123184353_1.dmp[7400]: Uploading dump (out-of-process)
/tmp/dumps/assert_20200123184353_1.dmp
/home/gmmacedo/.local/share/Steam/steam.sh, linha 722: 7362 Falha de segmentação (imagem do núcleo gravada)$STEAM_DEBUGGER “$STEAMROOT/$STEAMEXEPATH” “$@”
assert_20200123184353_1.dmp[7400]: Finished uploading minidump (out-of-process): success = yes
assert_20200123184353_1.dmp[7400]: response: CrashID=bp-957254ff-8f63-42c4-9439-28ef72200123
assert_20200123184353_1.dmp[7400]: file ‘’/tmp/dumps/assert_20200123184353_1.dmp’’, upload yes: ‘‘CrashID=bp-957254ff-8f63-42c4-9439-28ef72200123’’

1 Curtida

Instala o pacote steam-native-runtime e verifique se o problema persiste.

# pacman -S steam-native-runtime --needed

Eu acabei de desinstalar justamente para tentar ver se esse era o problema

Acabei de instalar ele (novamente) e instalar o driver mais atualizado mas continua com o mesmo erro

Se utilizar nvidia, instala o lib32-nvidia-utils talvez resolva seu problema, caso não de certo pode utilizar o steam via flatpak.

Não sei se vc possui o multilib ativado, pois o steam requer algumas bibliotecas de 32 bits, caso não possua, ative o multilib.

Muito obrigado, o multilib já estava ativado sim (acho que nem instalaria a steam se não tivesse) foi só instalar essa lib que funcionou.

1 Curtida

Eu tive um erro parecido, mas meu hardware é AMD.
O que eu devo instalar?

Não sei te responder sobre seu erro sem os logs, pois mesmo sendo parecido os problemas podem não ser os mesmos, não sou usuário ubuntu então fica difícil te falar sobre quais pacotes são necessários para o steam funcionar de maneira correta, mas pode tentar dar um apt info <nome_do_pacote_steam> para verificar quais as dependências.