Som do Kubuntu 20.04 parecendo "cd riscado", como resolver?

Pessoal, boa tarde!
Meu Kubuntu 20.04 há alguns meses vem dando problema no som, não é o tempo todo mas é muito frequente, tem dias que é muito irritante.
Quando coloco vídeo/música ou streaming para tocar, ele dá umas falhas como se fosse um cd riscado, tem umas interrupções frequentes no áudio.
Esse link joga para uma gravação do problema que fiz agora a pouco.

Amostra de Problema.mp3

(são 4 falhas que captei no tempo de apenas duas músicas!).
Quanto mais exijo do computador, mais o áudio falha. Mesmo o pc “vazio” dá esse problema.

O problema ocorre tanto no Chrome quanto no Firefox, quando se trata de streaming, e persiste no VLC em arquivos do computador.
Já testei usar cabo p10 no lugar do HDMI, mas o problema continua.
Já baixei outra imagem do site do Kubuntu e formatei o pc, o erro continua.
Já instalei o Xubuntu-desktop sobre o KDE (na esperança que isso corrigisse o erro) mas o problema continua.

Alguém sabe como corrijo isso?

O pc aqui é um I5, 6Gb de ram, com SSD.
Kubuntu 20.04.
image

Abre o terminal e rode os seguintes comando, por favor: inxi -b e inxi -A
Poste o output para nós, por gentileza.
Caso não tenha o inxi instalado: sudo apt install inxi -y

1 curtida


Essas são as saídas.

Olá!

Por favor, copie as duas saidas e cole aqui nos comentarios. siga esse tópico: Como fornecer boas informações? , faça isso para que nós consigamos ler e possivelmente identificar o problema mais facil.

1 curtida
[email protected]:~$ inxi -b
System:    Host: ricardo-desktop Kernel: 5.11.0-37-generic x86_64 bits: 64 
          Desktop: KDE Plasma 5.18.5 Distro: Ubuntu 20.04.3 LTS (Focal Fossa) 
Machine:   Type: Desktop Mobo: LOGIN model: H61H2-M2 v: 1.0 
          serial: <superuser/root required> BIOS: American Megatrends v: 4.6.4 
          date: 04/12/2012 
CPU:       Quad Core: Intel Core i5-2310 type: MCP speed: 1596 MHz min/max: 1600/3200 MHz 
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
          driver: i915 v: kernel 
          Display: x11 server: X.Org 1.20.11 driver: modesetting unloaded: fbdev,vesa 
          resolution: 1920x1080~60Hz 
          OpenGL: renderer: Mesa DRI Intel HD Graphics 2000 (SNB GT1) v: 3.3 Mesa 21.0.3 
Network:   Device-1: Realtek RTL8188EE Wireless Network Adapter driver: rtl8188ee 
          Device-2: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet driver: atl1c 
          Device-3: Realtek type: USB driver: rtl8821cu 
Drives:    Local Storage: total: 1.13 TiB used: 768.83 GiB (66.6%) 
Info:      Processes: 272 Uptime: 1h 53m Memory: 5.65 GiB used: 1.01 GiB (17.9%) 
          Shell: bash inxi: 3.0.38 
[email protected]:~$ inxi -A
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio driver: snd_hda_intel 
          Sound Server: ALSA v: k5.11.0-37-generic 
[email protected]:~$ inxi -a
CPU: Quad Core Intel Core i5-2310 (-MCP-) speed/min/max: 1596/1600/3200 MHz Kernel: 5.11.0-37-generic x86_64 
Up: 1h 53m Mem: 1034.1/5787.9 MiB (17.9%) Storage: 1.13 TiB (66.6% used) Procs: 272 Shell: bash 5.0.17 
inxi: 3.0.38 
[email protected]:~$
[email protected]:~$ inxi -F --filter
System:    Kernel: 5.11.0-37-generic x86_64 bits: 64 Desktop: KDE Plasma 5.18.5 
          Distro: Ubuntu 20.04.3 LTS (Focal Fossa) 
Machine:   Type: Desktop Mobo: LOGIN model: H61H2-M2 v: 1.0 serial: <filter> BIOS: American Megatrends 
          v: 4.6.4 date: 04/12/2012 
CPU:       Topology: Quad Core model: Intel Core i5-2310 bits: 64 type: MCP L2 cache: 6144 KiB 
          Speed: 1596 MHz min/max: 1600/3200 MHz Core speeds (MHz): 1: 1596 2: 1612 3: 1606 4: 1596 
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics driver: i915 v: kernel 
          Display: x11 server: X.Org 1.20.11 driver: modesetting unloaded: fbdev,vesa 
          resolution: 1920x1080~60Hz 
          OpenGL: renderer: Mesa DRI Intel HD Graphics 2000 (SNB GT1) v: 3.3 Mesa 21.0.3 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio driver: snd_hda_intel 
          Sound Server: ALSA v: k5.11.0-37-generic 
Network:   Device-1: Realtek RTL8188EE Wireless Network Adapter driver: rtl8188ee 
          IF: wlp1s0 state: down mac: <filter> 
          Device-2: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet driver: atl1c 
          IF: enp2s0 state: down mac: <filter> 
          Device-3: Realtek type: USB driver: rtl8821cu 
          IF: wlx00e0232038ef state: up mac: <filter> 
Drives:    Local Storage: total: 1.13 TiB used: 768.85 GiB (66.6%) 
          ID-1: /dev/sda vendor: Samsung model: HD103SJ size: 931.51 GiB 
          ID-2: /dev/sdb vendor: Kingston model: SA400S37240G size: 223.57 GiB 
Partition: ID-1: / size: 218.57 GiB used: 45.21 GiB (20.7%) fs: ext4 dev: /dev/sdb5 
Sensors:   System Temperatures: cpu: 43.0 C mobo: N/A 
          Fan Speeds (RPM): N/A 
Info:      Processes: 240 Uptime: 2h 33m Memory: 5.65 GiB used: 1.76 GiB (31.2%) Shell: bash inxi: 3.0.38 
[email protected]:~$ 

O máximo que posso indicar é a sugestão da Arch Wiki para som falhando no PC, porém nunca tive esse problema para afirmar que adianta de alguma coisa:

https://wiki.archlinux.org/title/PulseAudio/Troubleshooting#Choppy/distorted_sound

Adicionar no final do /etc/pulse/daemon.conf

avoid-resampling = yes
default-sample-rate = 48000

Não funcionou.
No Kubuntu 20.04 não é possível trocar o PulseAudio por outro tipo de servidor de áudio?
Ou mesmo trocar o driver de áudio instalado?

Tenta usar o Fedora 35 KDE, que usa o Pipeware ao invés do PA.

No momento é inviável eu fazer essa migração.

Eu tive um problema bem parecido com o teu e colocar o fone na entrada traseira resolveu (se tiver na traseira coloca na frente). Não custa tentar…

:wave:t2:

Como o Kubuntu é uma distro flavor do Ubuntu acredito que eles usam o Systemd. Dá para acreditar que eu estou na dúvida sobre isso? :relaxed: :joy:

Bom sendo o Systemd, para instalar o pipewire, executa os seguintes comandos no terminal:

sudo apt install pipewire-audio-client-libraries

Então cria o arquivo para ele com este comando:
touch /etc/pipewire/media-session.d/with-pulseaudio

Criar/copia o serviço com este comando:
cp /usr/share/doc/pipewire/examples/systemd/user/pipewire-pulse.* /etc/systemd/user/

Executamos estes comandos para desativar o PA e ativar o Pipewire:
systemctl --user daemon-reload
systemctl --user --now disable pulseaudio.service pulseaudio.socket
systemctl --user --now enable pipewire pipewire-pulse

Feito estes comandos check se o Pipewire está ativo com este comando:
pactl info | grep '^Server Name'
Se aparecer um nome assim “PulseAudio (On PipeWire 0.3.19)” então está ativo.

Agora vamos bloquear o Pulse Audio de reiniciar indevidamente como o comando:
systemctl --user mask pulseaudio

Reiniciamos o Pipewire com o comando:
systemctl --user restart pipewire pipewire-pulse

Feito tudo isso, melhor reiniciar o computador para garantir. E para ter certeza roda aquele comando com o grep:
pactl info | grep '^Server Name'

Veja se depois disso resolveria o problema de som.

Resources from Debian Wiki

:vulcan_salute:t2:

Não fez diferença… :man_facepalming: :man_facepalming:

Vou tentar! Muito obrigado!

1 curtida