Sem acesso com qualquer usuário nas TTYs (modo texto)

#1

Bem… nos terminais modo texto (tty1, tty2, etc), acessando com CTRL ALT Fx para alternar entre modo gráfico e modo texto, não consigo autenticar qualquer usuário, seja root ou usuário comum.
Até gravei dois vídeos curtos demonstrando o que acontece:
Video 1: https://www.youtube.com/watch?v=IY8I4iDesH8
Video 2: https://www.youtube.com/watch?v=BduiCYzD1-8

Então, depois de analisar o log /var/log/auth.log, verifiquei a seguinte situação:
Feb 6 10:25:54 ti-elvio-lm login[3533]: pam_unix(login:auth): conversation failed
Feb 6 10:25:54 ti-elvio-lm login[3533]: pam_unix(login:auth): auth could not identify password for [root]
Feb 6 10:25:55 ti-elvio-lm login[3533]: [module:pam_lsass]LsaPamGetCurrentPassword failed [error code: 49919]
Feb 6 10:25:55 ti-elvio-lm login[3533]: [module:pam_lsass]pam_sm_authenticate error [login:root][error code:49919]
Feb 6 10:25:57 ti-elvio-lm login[3533]: FAILED LOGIN (1) on ‘/dev/tty1’ FOR ‘root’, Authentication failure
Feb 6 10:25:57 ti-elvio-lm login[3533]: pam_securetty(login:auth): cannot determine username
Feb 6 10:26:01 ti-elvio-lm login[3533]: FAILED LOGIN (2) on ‘/dev/tty1’ FOR ‘UNKNOWN’, Error in service module
Feb 6 10:26:01 ti-elvio-lm login[3533]: pam_securetty(login:auth): cannot determine username
Feb 6 10:26:04 ti-elvio-lm login[3533]: FAILED LOGIN (3) on ‘/dev/tty1’ FOR ‘UNKNOWN’, Error in service module
Feb 6 10:26:04 ti-elvio-lm login[3533]: pam_securetty(login:auth): cannot determine username
Feb 6 10:26:06 ti-elvio-lm login[3533]: FAILED LOGIN (4) on ‘/dev/tty1’ FOR ‘UNKNOWN’, Error in service module
Feb 6 10:26:06 ti-elvio-lm login[3533]: pam_securetty(login:auth): cannot determine username
Feb 6 10:26:09 ti-elvio-lm login[3533]: FAILED LOGIN (5) on ‘/dev/tty1’ FOR ‘UNKNOWN’, Error in service module
Feb 6 10:26:09 ti-elvio-lm login[3533]: TOO MANY LOGIN TRIES (5) on ‘/dev/tty1’ FOR ‘UNKNOWN’
Feb 6 10:26:09 ti-elvio-lm login[3533]: pam_mail(login:session): cannot determine username
Feb 6 10:26:09 ti-elvio-lm login[3533]: pam_unix(login:session): close_session - error recovering username

Só me ative a esse problema pois precisei acessar para fazer alguma tarefa em modo texto, daí percebi que não tinha acesso.

Bem, eu tenho esse PC com Linux Mint Cinnamon 19.1 64bits autenticando em um domínio Windows Server 2012.

Ao tentar os comandos su ou sudo su está tudo certo. Também acessando via ssh de outro PC, também consigo acessar normalmente como root ou como usuário normal.

Pesquisei mas não consegui achar nada muito claro para solucionar essa questão.

Caso alguém tenha alguma sugestão/dica, agradeço desde já.

0 Likes

#2

Elvio,

Certamente tem algo de errado na tua stack no PAM.

O que eu faria é instalar o mesmo Linux em uma VM e copiar a configuração do PAM pra original. Se funcionar, sei que o problema é lá.

Dai, ia adicionando linha a linha das tuas personalizações com o AD, até dar o problema.

Att,
Mateus

0 Likes

#3

Grato pela sugestão.

Olha só… um tópico aberto dia 03/02/19 em um fórum do KDE (forum.kde.org)…
No login on the text console more possible
… trata dessa questão.

Nesse tópico no KDE, leva a mais dois links:
https://bugs.launchpad.net/ubuntu/+source/shadow/+bug/1812095
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1813683

Pelo visto é algum bug no Kernel. Como tenho kernel atualizado, provavelmente está com esse problema.

No meu PC e no meu notebook de casa, vou habilitar o root.
No note, talvez eu volte algumas verões do kernel para testar.

Vou analisar e testar e, provavelmente, essa questão se resolva nas próximas atualizações do kernel mesmo.

Encontrei mais uma referência no fórum do linux mint… a sugestão é voltar uma ou duas versões do kernel mesmo:
Unable to login on virtual terminals: Entering username “auto-enters” blank passwords; gretty crashing

Valeu.

0 Likes

#4

Olá!

Fiz um teste no meu notebook, em casa e, a solução foi fazer o downgrade do kernel 4.15.0-45 para 4.15.0-43 e funcionou.
Consigo acessar no tty sem problemas.

Valeu.

0 Likes