Seletor de cores do GNOME não funciona no Linux Mint

Olá.

Instalei esse seletor de cores, mas não estou conseguindo fazê-lo funcionar no meu sistema(Linux Mint 20.3 com Cinnamom).

Clico no ícone de conta-gotas, mas ele não reconhece nenhuma cor.

Peek 03-09-2022 19-56

1 curtida

Você instalou via flatpak ou apt? Se foi via flatpak, muito provável de ser a falta do acesso fora do sandbox. Não sei se basta fazer um override da /home. Se quiser uma alternativa, gosto bastante do Colorpicker. Usei bastante quando estava em ambiente GTK (Pop!_OS)

1 curtida

Olá @lucas2k02, tudo bem contigo?

Eu não tenho nenhuma instalação do Mint no momento, mas, fiz vários testes no modo live-pendrive e nenhum dos programas que eu testei funcionaram.

Instalei praticamente todos os que estavam na loja, apenas o do Deepin não foi possível instalar. Existe a possibilidade que estes programas usem algum recurso implementado de forma distinta no Cinnamon e por isso não conseguem capturar a cor da tela.

Minha sugestão é recorrer diretamente ao canal de suporte do Cinnamon ou do Seletor de cores do GNOME.

:vulcan_salute:

2 curtidas

Boa noite pessoal.

Bom, eu acabei encontrando um seletor de cores chamado ColorPie, funciona aproximadamente como o Seletor de Cores do Gnome, permitindo criar uma paleta de cores e exibindo várias informações sobre a cor selecionada.


@JG22 Era uma instalação via Flatpak, mas acredito ser um problema na própria aplicação que causa incompatibilidade com o Cinnamom.
Ah, agradeço pela sugestão alternativa!
Eu fiz o download do pacote .deb do Colorpicker, mas não consegui selecionar nenhuma cor, pois essa mensagem de erro fica aparecendo:
Captura de tela de 2022-10-10 19-08-20

Tentei testar também a versão AppImage disponível no repositório, mas ela não chegou a abrir, mesmo tornando o arquivo executável.


@eddiecsilva Agradeço pelos testes.
Realmente, boa parte dos aplicativos de seleção de cor parecem ter problemas de compatibilidade no Cinnamom.
O ColorPie foi o único que consegui utilizar sem problemas nesse ambiente.

No caso do Seletor de Cores do Gnome, o programa apresenta o mesmo problema em outros sistemas/ambientes gráficos, coforme li em algumas issues do projeto no GitLab:
Fedora(Mate, Xfce, GNOME)
Linux Mint(Cinnamom)


Obrigado mais uma vez pelas respostas esse tópico.

3 curtidas

Bom que conseguiu, champs. Esse erro acredito que bastava instala a dependencia e resolveria (sudo apt install glib2)

2 curtidas

Dei esse comando e o terminal retornou isso aqui:

lucas@pc:~$ sudo apt install glib2
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
E: Impossível encontrar o pacote glib2
lucas@pc:~$

Então no apt o nome do pacote é diferente. Faça uma busca e veja se aparece: sudo apt search glib
Se achar, basta instalar

Apareceram muitas opções de pacotes usando esse comando:

Saída de "sudo apt search glib"
Computador ligado há 1 hora e 28 minutos.
lucas@pc:~$ sudo apt search glib
[sudo] senha para lucas:        
p   appstream-glib-doc              - Developer documentation for the libappstre
p   geocode-glib-tests              - installed tests for the geocode-glib libra
p   geocode-glib-tests:i386         - installed tests for the geocode-glib libra
i   gir1.2-appstreamglib-1.0        - GObject introspection data for the libapps
p   gir1.2-appstreamglib-1.0:i386   - GObject introspection data for the libapps
v   gir1.2-dbusglib-1.0             -                                           
v   gir1.2-dbusglib-1.0:i386        -                                           
i   gir1.2-dbusmenu-glib-0.4        - typelib file for libdbusmenu-glib4        
p   gir1.2-geocodeglib-1.0          - introspection data for geocode-glib librar
p   gir1.2-geocodeglib-1.0:i386     - introspection data for geocode-glib librar
v   gir1.2-git2-glib-1.0            -                                           
i   gir1.2-glib-2.0                 - Introspection data for GLib, GObject, Gio 
p   gir1.2-glib-2.0:i386            - Introspection data for GLib, GObject, Gio 
v   gir1.2-icalglib-3.0             -                                           
v   gir1.2-icalglib-3.0:i386        -                                           
p   gir1.2-libvirt-glib-1.0         - GObject introspection files for the libvir
v   gir1.2-libvirtglib-1.0          -                                           
i   gir1.2-packagekitglib-1.0       - GObject introspection data for the Package
p   gir1.2-spiceclientglib-2.0      - GObject for communicating with Spice serve
p   gir1.2-telepathyglib-0.12       - Biblioteca de gerenciamento de conexão GLi
i   gir1.2-upowerglib-1.0           - GObject introspection data for upower     
p   gir1.2-upowerglib-1.0:i386      - GObject introspection data for upower     
p   gir1.2-urfkill-glib0            - GObject introspection data for the urfkill
i   glib-networking                 - giomodules relacionados a redes para a GLi
p   glib-networking:i386            - giomodules relacionados a redes para a GLi
i   glib-networking-common          - giomódulos relativos a redes para a GLib -
v   glib-networking-common:i386     -                                           
i   glib-networking-services        - giomodules relacionados a redes para a GLi
p   glib-networking-services:i386   - giomodules relacionados a redes para a GLi
p   glib-networking-tests           - network-related giomodules for GLib - inst
p   glib-networking-tests:i386      - network-related giomodules for GLib - inst
p   glibc-doc                       - GNU C Library: Documentation              
v   glibc-doc:i386                  -                                           
p   glibc-doc-reference             - GNU C Library: Documentation              
v   glibc-pic                       -                                           
v   glibc-pic:i386                  -                                           
p   glibc-source                    - GNU C Library: sources                    
p   guile-gnome2-glib               - Guile bindings for GLib                   
p   json-glib-tools                 - biblioteca de manipulação JSON GLib (ferra
p   json-glib-tools:i386            - biblioteca de manipulação JSON GLib (ferra
p   libaccounts-glib-dev            - library for single signon - development fi
p   libaccounts-glib-doc            - library for single signon - documentation 
p   libaccounts-glib-tools          - library for single signon - tools         
p   libaccounts-glib0               - library for single signon                 
p   libalglib-dev                   - Development files for the alglib library  
p   libalglib3.14                   - Numerical analysis and data processing lib
p   libappstream-glib-dev           - GNOME library to access AppStream services
p   libappstream-glib-dev:i386      - GNOME library to access AppStream services
i   libappstream-glib8              - GNOME library to access AppStream services
p   libappstream-glib8:i386         - GNOME library to access AppStream services
p   libavahi-glib-dev               - Development headers for the Avahi GLib int
p   libavahi-glib-dev:i386          - Development headers for the Avahi GLib int
i   libavahi-glib1                  - Avahi GLib integration library            
p   libavahi-glib1:i386             - Avahi GLib integration library            
p   libcglib-java                   - Code generation library for Java          
p   libcglib-java-doc               - Code generation library for Java (document
p   libcglib-nodep-java             - Code generation library for Java (without 
i   libdbus-glib-1-2                - deprecated library for D-Bus IPC          
p   libdbus-glib-1-2:i386           - deprecated library for D-Bus IPC          
v   libdbus-glib-1-2:i386           -                                           
p   libdbus-glib-1-dev              - deprecated library for D-Bus IPC (developm
p   libdbus-glib-1-dev:i386         - deprecated library for D-Bus IPC (developm
p   libdbus-glib-1-dev-bin          - deprecated library for D-Bus IPC (developm
p   libdbus-glib-1-dev-bin:i386     - deprecated library for D-Bus IPC (developm
p   libdbus-glib-1-doc              - deprecated library for D-Bus IPC (API docu
p   libdbus-glib1.0-cil             - CLI implementation of D-Bus (GLib mainloop
p   libdbus-glib1.0-cil-dev         - CLI implementation of D-Bus (GLib mainloop
p   libdbus-glib2.0-cil             - CLI implementation of D-Bus (GLib mainloop
p   libdbus-glib2.0-cil-dev         - CLI implementation of D-Bus (GLib mainloop
p   libdbusmenu-glib-dev            - library for passing menus over DBus - deve
p   libdbusmenu-glib-doc            - library for passing menus over DBus - docu
i   libdbusmenu-glib4               - library for passing menus over DBus       
p   libgeocode-glib-dev             - development files for geocode-glib library
p   libgeocode-glib-dev:i386        - development files for geocode-glib library
p   libgeocode-glib-doc             - gtk-doc documentation for geocode-glib lib
v   libgeocode-glib-doc:i386        -                                           
i   libgeocode-glib0                - biblioteca GLib de geocodificação e geocod
p   libgeocode-glib0:i386           - biblioteca GLib de geocodificação e geocod
p   libghc-gi-glib-dev              - GLib bindings                             
v   libghc-gi-glib-dev-2.0.17-988a3 -                                           
p   libghc-gi-glib-doc              - GLib bindings; documentation              
p   libghc-gi-glib-prof             - GLib bindings; profiling libraries        
v   libghc-gi-glib-prof-2.0.17-988a -                                           
p   libghc-glib-dev                 - Binding to the GLIB library for Gtk2Hs    
v   libghc-glib-dev-0.13.7.0-a3e61  -                                           
p   libghc-glib-doc                 - Binding to the GLIB library for Gtk2Hs; do
p   libghc-glib-prof                - Binding to the GLIB library for Gtk2Hs; pr
v   libghc-glib-prof-0.13.7.0-a3e61 -                                           
p   libgit2-glib-1.0-0              - glib wrapper library around the libgit2 gi
p   libgit2-glib-1.0-dev            - glib wrapper library around the libgit2 gi
p   libgit2-glib-1.0-doc            - glib wrapper library around the libgit2 gi
i   libglib-object-introspection-pe - Perl bindings for gobject-introspection li
i   libglib-perl                    - interface to the GLib and GObject librarie
p   libglib-perl:i386               - interface to the GLib and GObject librarie
i   libglib2.0-0                    - GLib library of C routines                
i A libglib2.0-0:i386               - GLib library of C routines                
i   libglib2.0-bin                  - Programs for the GLib library             
p   libglib2.0-bin:i386             - Programs for the GLib library             
i A libglib2.0-cil                  - CLI binding for the GLib utility library 2
p   libglib2.0-cil-dev              - CLI binding for the GLib utility library 2
i   libglib2.0-data                 - Common files for GLib library             
v   libglib2.0-data:i386            -                                           
p   libglib2.0-dev                  - Development files for the GLib library    
p   libglib2.0-dev:i386             - Development files for the GLib library    
p   libglib2.0-dev-bin              - Development utilities for the GLib library
p   libglib2.0-dev-bin:i386         - Development utilities for the GLib library
p   libglib2.0-doc                  - Documentation files for the GLib library  
v   libglib2.0-doc:i386             -                                           
p   libglib2.0-tests                - GLib library of C routines - installed tes
p   libglib2.0-tests:i386           - GLib library of C routines - installed tes
p   libglib3.0-cil                  - CLI binding for the GLib library of C rout
p   libglib3.0-cil-dev              - CLI binding for the GLib utility library 2
p   libglibd-2.0-0                  - GLib library of C routines - D bindings   
p   libglibd-2.0-dev                - GLib library of C routines - development f
i   libglibmm-2.4-1v5               - invólucro C++ para o kit de ferramentas GL
p   libglibmm-2.4-1v5:i386          - invólucro C++ para o kit de ferramentas GL
p   libglibmm-2.4-dev               - C++ wrapper for the GLib toolkit (developm
p   libglibmm-2.4-dev:i386          - C++ wrapper for the GLib toolkit (developm
p   libglibmm-2.4-doc               - C++ wrapper for the GLib toolkit (document
v   libglibmm-2.4-doc:i386          -                                           
p   libimglib2-java                 - multidimensional image processing library 
p   libimglib2-java-doc             - documentation for ImgLib2                 
p   libio-async-loop-glib-perl      - Perl extension for an event loop using GLi
i   libjson-glib-1.0-0              - GLib JSON manipulation library            
p   libjson-glib-1.0-0:i386         - GLib JSON manipulation library            
i   libjson-glib-1.0-common         - GLib JSON manipulation library (common fil
v   libjson-glib-1.0-common:i386    -                                           
p   libjson-glib-dev                - GLib JSON manipulation library (developmen
p   libjson-glib-dev:i386           - GLib JSON manipulation library (developmen
p   libjson-glib-doc                - GLib JSON manipulation library (documentat
v   libjson-glib-doc:i386           -                                           
p   libjsonrpc-glib-1.0-1           - JSON-RPC library for GLib                 
p   libjsonrpc-glib-1.0-dev         - JSON-RPC library for GLib - development fi
p   libjsonrpc-glib-doc             - JSON-RPC library for GLib - documentation 
p   libkf5kmahjongglib-data         - shared library for kmahjongg and kshisen  
p   libkf5kmahjongglib-dev          - development files for the KDE kmahjongg li
p   libkf5kmahjongglib5             - shared library for kmahjongg and kshisen  
p   libmaliit-glib-dev              - Maliit Input Method Framework - GLib Devel
p   libmaliit-glib0                 - Maliit Input Method Framework - GLib Bindi
p   libmbim-glib-dev                - Header files for adding MBIM support to ap
p   libmbim-glib-dev:i386           - Header files for adding MBIM support to ap
p   libmbim-glib-doc                - API documentation for the MBIM protocol li
v   libmbim-glib-doc:i386           -                                           
i   libmbim-glib4                   - Biblioteca de suporte para usar o protocol
p   libmbim-glib4:i386              - Biblioteca de suporte para usar o protocol
p   libmm-glib-dev                  - D-Bus service for managing modems - librar
p   libmm-glib-dev:i386             - D-Bus service for managing modems - librar
p   libmm-glib-doc                  - D-Bus service for managing modems - librar
v   libmm-glib-doc:i386             -                                           
i   libmm-glib0                     - D-Bus service for managing modems - shared
p   libmm-glib0:i386                - D-Bus service for managing modems - shared
p   libnet-dbus-glib-perl           - extension for the DBus GLib bindings      
p   libnglib-6.2.1804               - Automatic 3d tetrahedral mesh generator sh
p   libnglib-dev                    - Automatic 3d tetrahedral mesh generator de
i   libpackagekit-glib2-18          - Library for accessing PackageKit using GLi
p   libpackagekit-glib2-dev         - Library for accessing PackageKit using GLi
p   libpoppler-glib-dev             - PDF rendering library -- development files
p   libpoppler-glib-dev:i386        - PDF rendering library -- development files
p   libpoppler-glib-doc             - PDF rendering library -- documentation for
i   libpoppler-glib8                - biblioteca de renderização de PDF (bibliot
p   libpoppler-glib8:i386           - biblioteca de renderização de PDF (bibliot
i   libpulse-mainloop-glib0         - bibliotecas de cliente do PulseAudio (supo
p   libpulse-mainloop-glib0:i386    - bibliotecas de cliente do PulseAudio (supo
v   libpulse-mainloop-glib0:i386    -                                           
p   libqmi-glib-dev                 - Header files for adding QMI support to app
p   libqmi-glib-dev:i386            - Header files for adding QMI support to app
p   libqmi-glib-doc                 - API documentation for libqmi-glib         
v   libqmi-glib-doc:i386            -                                           
i   libqmi-glib5                    - biblioteca de suporte para usar o protocol
p   libqmi-glib5:i386               - biblioteca de suporte para usar o protocol
p   libqt5glib-2.0-0                - C++ bindings library for GLib and GObject 
p   librtcom-telepathy-glib-dev     - RTCom telepathy-glib extensions (developme
p   librtcom-telepathy-glib0        - RTCom telepathy-glib extension library    
p   librust-cairo-rs+glib-dev       - Rust bindings for the Cairo library - feat
p   librust-cairo-rs+glib-sys-dev   - Rust bindings for the Cairo library - feat
p   librust-cairo-rs+use-glib-dev   - Rust bindings for the Cairo library - feat
v   librust-cairo-rs-0+glib-dev     -                                           
v   librust-cairo-rs-0+glib-sys-dev -                                           
v   librust-cairo-rs-0+use-glib-dev -                                           
v   librust-cairo-rs-0.7+glib-dev   -                                           
v   librust-cairo-rs-0.7+glib-sys-d -                                           
v   librust-cairo-rs-0.7+use-glib-d -                                           
v   librust-cairo-rs-0.7.1+glib-dev -                                           
v   librust-cairo-rs-0.7.1+glib-sys -                                           
v   librust-cairo-rs-0.7.1+use-glib -                                           
p   librust-cairo-sys-rs+glib-sys-d - FFI bindings to libcairo - feature "glib-s
p   librust-cairo-sys-rs+use-glib-d - FFI bindings to libcairo - feature "use_gl
v   librust-cairo-sys-rs-0+glib-sys -                                           
v   librust-cairo-sys-rs-0+use-glib -                                           
v   librust-cairo-sys-rs-0.9+glib-s -                                           
v   librust-cairo-sys-rs-0.9+use-gl -                                           
v   librust-cairo-sys-rs-0.9.0+glib -                                           
v   librust-cairo-sys-rs-0.9.0+use- -                                           
v   librust-glib+default-dev        -                                           
p   librust-glib+dox-dev            - Rust bindings for the GLib library - featu
v   librust-glib+subclassing-dev    -                                           
p   librust-glib+v2-44-dev          - Rust bindings for the GLib library - featu
p   librust-glib+v2-46-dev          - Rust bindings for the GLib library - featu
p   librust-glib+v2-48-dev          - Rust bindings for the GLib library - featu
p   librust-glib+v2-50-dev          - Rust bindings for the GLib library - featu
p   librust-glib+v2-52-dev          - Rust bindings for the GLib library - featu
p   librust-glib+v2-54-dev          - Rust bindings for the GLib library - featu
p   librust-glib+v2-56-dev          - Rust bindings for the GLib library - featu
p   librust-glib+v2-58-dev          - Rust bindings for the GLib library - featu
v   librust-glib-0+default-dev      -                                           
v   librust-glib-0+dox-dev          -                                           
v   librust-glib-0+subclassing-dev  -                                           
v   librust-glib-0+v2-44-dev        -                                           
v   librust-glib-0+v2-46-dev        -                                           
v   librust-glib-0+v2-48-dev        -                                           
v   librust-glib-0+v2-50-dev        -                                           
v   librust-glib-0+v2-52-dev        -                                           
v   librust-glib-0+v2-54-dev        -                                           
v   librust-glib-0+v2-56-dev        -                                           
v   librust-glib-0+v2-58-dev        -                                           
v   librust-glib-0-dev              -                                           
v   librust-glib-0.8+default-dev    -                                           
v   librust-glib-0.8+dox-dev        -                                           
v   librust-glib-0.8+subclassing-de -                                           
v   librust-glib-0.8+v2-44-dev      -                                           
v   librust-glib-0.8+v2-46-dev      -                                           
v   librust-glib-0.8+v2-48-dev      -                                           
v   librust-glib-0.8+v2-50-dev      -                                           
v   librust-glib-0.8+v2-52-dev      -                                           
v   librust-glib-0.8+v2-54-dev      -                                           
v   librust-glib-0.8+v2-56-dev      -                                           
v   librust-glib-0.8+v2-58-dev      -                                           
v   librust-glib-0.8-dev            -                                           
v   librust-glib-0.8.2+default-dev  -                                           
v   librust-glib-0.8.2+dox-dev      -                                           
v   librust-glib-0.8.2+subclassing- -                                           
v   librust-glib-0.8.2+v2-44-dev    -                                           
v   librust-glib-0.8.2+v2-46-dev    -                                           
v   librust-glib-0.8.2+v2-48-dev    -                                           
v   librust-glib-0.8.2+v2-50-dev    -                                           
v   librust-glib-0.8.2+v2-52-dev    -                                           
v   librust-glib-0.8.2+v2-54-dev    -                                           
v   librust-glib-0.8.2+v2-56-dev    -                                           
v   librust-glib-0.8.2+v2-58-dev    -                                           
v   librust-glib-0.8.2-dev          -                                           
p   librust-glib-dev                - Rust bindings for the GLib library - Rust 
v   librust-glib-sys+default-dev    -                                           
v   librust-glib-sys+dox-dev        -                                           
v   librust-glib-sys+v2-44-dev      -                                           
v   librust-glib-sys+v2-46-dev      -                                           
v   librust-glib-sys+v2-48-dev      -                                           
v   librust-glib-sys+v2-50-dev      -                                           
v   librust-glib-sys+v2-52-dev      -                                           
v   librust-glib-sys+v2-54-dev      -                                           
v   librust-glib-sys+v2-56-dev      -                                           
v   librust-glib-sys+v2-58-dev      -                                           
v   librust-glib-sys-0+default-dev  -                                           
v   librust-glib-sys-0+dox-dev      -                                           
v   librust-glib-sys-0+v2-44-dev    -                                           
v   librust-glib-sys-0+v2-46-dev    -                                           
v   librust-glib-sys-0+v2-48-dev    -                                           
v   librust-glib-sys-0+v2-50-dev    -                                           
v   librust-glib-sys-0+v2-52-dev    -                                           
v   librust-glib-sys-0+v2-54-dev    -                                           
v   librust-glib-sys-0+v2-56-dev    -                                           
v   librust-glib-sys-0+v2-58-dev    -                                           
v   librust-glib-sys-0-dev          -                                           
v   librust-glib-sys-0.9+default-de -                                           
v   librust-glib-sys-0.9+dox-dev    -                                           
v   librust-glib-sys-0.9+v2-44-dev  -                                           
v   librust-glib-sys-0.9+v2-46-dev  -                                           
v   librust-glib-sys-0.9+v2-48-dev  -                                           
v   librust-glib-sys-0.9+v2-50-dev  -                                           
v   librust-glib-sys-0.9+v2-52-dev  -                                           
v   librust-glib-sys-0.9+v2-54-dev  -                                           
v   librust-glib-sys-0.9+v2-56-dev  -                                           
v   librust-glib-sys-0.9+v2-58-dev  -                                           
v   librust-glib-sys-0.9-dev        -                                           
v   librust-glib-sys-0.9.0+default- -                                           
v   librust-glib-sys-0.9.0+dox-dev  -                                           
v   librust-glib-sys-0.9.0+v2-44-de -                                           
v   librust-glib-sys-0.9.0+v2-46-de -                                           
v   librust-glib-sys-0.9.0+v2-48-de -                                           
v   librust-glib-sys-0.9.0+v2-50-de -                                           
v   librust-glib-sys-0.9.0+v2-52-de -                                           
v   librust-glib-sys-0.9.0+v2-54-de -                                           
v   librust-glib-sys-0.9.0+v2-56-de -                                           
v   librust-glib-sys-0.9.0+v2-58-de -                                           
v   librust-glib-sys-0.9.0-dev      -                                           
p   librust-glib-sys-dev            - FFI bindings to libglib-2.0 - Rust source 
p   libsignon-glib-dev              - library for signond - development files   
p   libsignon-glib-doc              - library for signond - documentation       
p   libsignon-glib1                 - library for signond                       
p   libsnapd-glib-dev               - GLib snapd library (development files)    
p   libsnapd-glib-dev:i386          - GLib snapd library (development files)    
i   libsnapd-glib1                  - GLib snapd library                        
p   libsnapd-glib1:i386             - GLib snapd library                        
p   libsofia-sip-ua-glib-dev        - Sofia-SIP library glib/gobject interface d
p   libsofia-sip-ua-glib3           - Sofia-SIP library glib/gobject interfaces 
p   libspice-client-glib-2.0-8      - GObject for communicating with Spice serve
p   libspice-client-glib-2.0-dev    - GObject for communicating with Spice serve
p   libtaglib-cil-dev               - CLI library for accessing audio and video 
p   libtaglib-ocaml                 - OCaml bindings for the TagLib Audio Meta-D
v   libtaglib-ocaml-bhme8           -                                           
p   libtaglib-ocaml-dev             - OCaml bindings for the TagLib Audio Meta-D
v   libtaglib-ocaml-dev-bhme8       -                                           
p   libtaglib2.1-cil                - CLI library for accessing audio and video 
p   libtaglibs-standard-impl-java   - Apache JSP Standard Taglib Implementation 
p   libtaglibs-standard-jstlel-java - Apache JSP Standard Taglib 1.0 EL Support 
p   libtaglibs-standard-spec-java   - Apache JSP Standard Taglib Specification A
p   libtelepathy-glib-dev           - GLib Telepathy connection manager library 
p   libtelepathy-glib-doc           - GLib Telepathy library (documentation)    
p   libtelepathy-glib0              - Telepathy framework - GLib library        
p   libtemplate-glib-1.0-0          - templating library for GLib               
p   libtemplate-glib-1.0-dev        - templating library for GLib - development 
p   libtemplate-glib-common         - templating library for GLib - common files
p   libtemplate-glib-doc            - templating library for GLib - documentatio
p   libthrift-c-glib-dev            - Thrift glib library (development headers) 
p   libthrift-c-glib0               - Thrift glib library                       
p   libtmglib-dev                   - test matrix generators of LAPACK - develop
p   libtmglib3                      - test matrix generators of LAPACK - shared 
p   libtmglib64-3                   - test matrix generators of LAPACK - shared 
p   libtmglib64-dev                 - test matrix generators of LAPACK - develop
p   libupower-glib-dev              - abstraction for power management - develop
p   libupower-glib-dev:i386         - abstraction for power management - develop
i   libupower-glib3                 - Abstração para gestão de energia - bibliot
p   libupower-glib3:i386            - Abstração para gestão de energia - bibliot
p   liburfkill-glib-dev             - wireless killswitch management library (de
p   liburfkill-glib0                - wireless killswitch management library    
p   libverto-glib1                  - Event loop abstraction for Libraries - gli
p   libverto-glib1:i386             - Event loop abstraction for Libraries - gli
p   libvirt-glib-1.0-0              - libvirt GLib and GObject mapping library  
p   libvirt-glib-1.0-dev            - Development files for the libvirt-glib lib
p   libxmmsclient++-glib-dev        - XMMS2 - glib client library for c++ - deve
p   libxmmsclient++-glib1v5         - XMMS2 - glib client library for c++       
p   libxmmsclient-glib-dev          - XMMS2 - glib client library - development 
p   libxmmsclient-glib1             - XMMS2 - glib client library               
p   monodoc-taglib-manual           - compiled XML documentation for taglib-shar
p   python3-hglib                   - Python3 library for interfacing with Mercu
p   python3-spglib                  - C library for crystal symmetry determinati
p   python3-taglib                  - Python3 bindings for the TagLib audio meta
v   python3.8-spglib                -                                           
p   ruby-glib2                      - GLib 2 bindings for the Ruby language     
p   snapd-glib-tests                - GLib snapd library (installed tests)      
p   snapd-glib-tests:i386           - GLib snapd library (installed tests)      
p   spice-client-glib-usb-acl-helpe - Helper tool to validate usb ACLs          
lucas@pc:~$ 

Dei uma pesquisada no Google e aqui no Diolinux Plus sobre qual delas deveria ser instalada para resolver esse problema e encontrei um tópico aqui no fórum sobre um problema igual, embora com outro software, que esclarece esse problema de dependência relacionado as versões do GLIBC.


Aí vão alguns trechos desse tópico:


Descobri que o comando para ver a versão do GLIBC é ldd --version.
No meu caso a versão atualmente instalada, no Linux Mint 20.3, é a 2.31.

lucas@pc:~$ ldd --version
ldd (Ubuntu GLIBC 2.31-0ubuntu9.9) 2.31
Copyright (C) 2020 Free Software Foundation, Inc.
Este é um software livre; leia os fontes para condições de cópia. NÃO HÁ
QUALQUER GARANTIA; nem para COMERCIALIZAÇÃO ou ADEQUAÇÃO A QUALQUER
PROPÓSITO EME PARTICULAR.
Escrito por Roland McGrath e Ulrich Drepper.

O Colorpicker que você recomendou, em sua versão 2.1.0(mais atual até o momento) depende do GLIBC 2.32 conforme informado naquela mensagem de erro.

E é basicamente isso. O Colorpicker, em sua versão atual, é incompatível com o Linux Mint 20.3.


Mas, há pelos menos 2 formas de contornar essa incompatibilidade:

  1. Atualizar o sistema pra uma versão com um GLIBC mais recente por padrão.
    No meu caso seria o Linux Mint 21, mas não tenho intenção de fazer essa atualização a curto prazo.

  2. Usar uma versão mais antiga de um software que dependa de algum GLIBC específico, no caso o Colorpicker.
    Dei uma olhada nas releases do Colorpicker no GitHub, baixei a versão 2.0.3, .deb, e instalei aqui. Funcionou sem problemas.
    Peek 12-10-2022 16-54


Peço desculpas pelo textão, mas acho que não faria sentido guardar essas pequenas descobertas só pra mim.
Mais umas vez, obrigado pela ajuda.

2 curtidas

Este tópico foi fechado automaticamente 3 dias depois da última resposta. Novas respostas não são mais permitidas.