Ruído no aúdio e travamento ao assistir videos em tela cheia

Boa tarde!

Recentemente instalei o Debian 10 e percebi que quando tento reproduzir vídeos em tela cheia o áudio começa a apresentar ruídos, parecidos com chuviscos de televisores analógicos, além disso o video começa a apresentar leg’s. Inicialmente pensei que poderia ser o navegador, então resolvi executar um video offline, porém o mesmo aconteceu.

As configurações do PC são essas:

.

Vale ressaltar que como eu tinha uma partição livre resolvi instalar o manjaro pra testar, porém o mesmo aconteceu. Isto posto, estou inclinado a acreditar que possa ser algum problema no Hardware, porém como sou iniciante em linux gostaria da opinião de vcs.

Valeu!

qual a sa;ida do comando

lspci -k

pois ai não tem o áudio

https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting#Enable_Echo/Noise-Cancellation
### Enable Echo/Noise-Cancellation

Arch does not load the Pulseaudio Echo-Cancellation module by default, therefore, we have to add it in `/etc/pulse/default.pa` . First you can test if the module is present with `pacmd` and entering `list-modules` . If you cannot find a line showing `name: <module-echo-cancel>` you have to add

/etc/pulse/default.pa

### Enable Echo/Noise-Cancellation load-module module-echo-cancel use_master_format=1 aec_method=webrtc aec_args="analog_gain_control=0\ digital_gain_control=1" source_name=echoCancel_source sink_name=echoCancel_sink set-default-source echoCancel_source set-default-sink echoCancel_sink

then restart Pulseaudio

$ pulseaudio -k $ pulseaudio --start

https://wiki.archlinux.org/index.php/NVIDIA/Troubleshooting#Avoid_screen_tearing
## Avoid screen tearing

**Note:** This has been reported to reduce the performance of some OpenGL applications and may produce issues in WebGL. It also drastically increases the time the driver needs to clock down after load ([Nvidia-Support-Thread](https://devtalk.nvidia.com/default/topic/1048768/linux/if-you-have-gpu-clock-boost-problems-please-try-__gl_experimentalperfstrategy-1/)).

Tearing can be avoided by forcing a full composition pipeline, regardless of the compositor you are using. To test whether this option will work, run:

$ nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"

Or click on the *Advanced* button that is available on the *X Server Display Configuration* menu option. Select either *Force Composition Pipeline* or *Force Full Composition Pipeline* and click on *Apply* .

In order to make the change permanent, it must be added to the `"Screen"` section of the [Xorg](https://wiki.archlinux.org/index.php/Xorg) configuration file. When making this change, `TripleBuffering` should be enabled and `AllowIndirectGLXProtocol` should be disabled in the driver configuration as well. See example configuration below:

/etc/X11/xorg.conf.d/20-nvidia.conf

Section "Device" Identifier "Nvidia Card" Driver "nvidia" VendorName "NVIDIA Corporation" BoardName "GeForce GTX 1050 Ti" EndSection Section "Screen" Identifier "Screen0" Device "Device0" Monitor "Monitor0" Option "metamodes" "nvidia-auto-select +0+0 {ForceFullCompositionPipeline=On}" Option "AllowIndirectGLXProtocol" "off" Option "TripleBuffer" "on" EndSection

If you do not have an Xorg configuration file, you can create one for your present hardware using `nvidia-xconfig` (see [NVIDIA#Automatic configuration](https://wiki.archlinux.org/index.php/NVIDIA#Automatic_configuration)) and move it from `/etc/X11/xorg.conf` to the preferred location `/etc/X11/xorg.conf.d/20-nvidia.conf` .

**Note:** Many of the configuration options produced in `20-nvidia.conf` by using `nvidia-xconfig` are set automatically by the driver and are not needed. To only use this file for enabling composition pipeline, only the section `"Screen"` containing lines with values for `Identifier` and `Option` are necessary. Other sections may be removed from this file.

Certo…
Creio que a parte da saída do comando lspci -k, referente ao áudio é:

00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06) Subsystem: ASUSTeK Computer Inc. 5 Series/3400 Series Chipset High Definition Audio Kernel driver in use: snd_hda_intel Kernel modules: snd_hda_intel

Quanto aos links, dei uma olhada e acrescentei ao final do arquivo /etc/pulse/default.pa o que foi recomendado, depois reiniciei o Pulseaudio como foi indicado, porém não obtive sucesso.

Já com a parte do video, ao rodar o comando
$ nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
apareceu a mensagem de comando não encontrado.

parece ser problema com a placa de vídeo, mas veja o link abaixo. Pois só afeta em tela cheia.
https://bbs.archlinux.org/viewtopic.php?id=211318

Sobre o video foi mal… Vi que usa o drive nouveau, por isso nvidia-settings não funcionou.

Sobre o nouveau
Você pode instalar o picom

https://wiki.archlinux.org/index.php/Picom#Flicker

e para vertical sync
https://wiki.archlinux.org/index.php/Nouveau#Vertical_Sync

E aí Adriano, beleza!

Seguinte eu dei uma olhada no primeiro link como vc recomendou porém não consegui resolver o problema por lá, dai olhei os dois links seguintes, porém não tive sucesso. Sendo assim, como vc havia sugerido que poderia ser problema com placa de vídeo resolvi fazer o seguinte:

Instalar o windows no lugar do manjaro (ainda em dual boot com o Debian) pra verificar se o problema iria permanecer, e ao reproduzir vídeos em tela cheia no windows notei que o ruido desapareceu. No entanto, os legs do video continuavam, na verdade pareciam até um pouco mais fortes. Isso me levou a pesquisar um pouco mais a respeito de drives de vídeo, o que me levou a esse video https://youtu.be/jzYA1ojXVhM e a esse artigo Como atualizar o driver da NVIDIA no Linux - Mateus Müller - 4Fasters.

Todavia, creio que fiz algo de errado pois ao tentar dar boot no Debian só dava um tela preta. Logo, resolvi criar um pendrive botavel com o Debian novamente, e ao iniciar pelo pendrive ficava aparecendo algum tipo de erro em Algum módulo e/ou Kernel não entendi muito bem pois meu inglês não é lá essas coisas…(Se não me engano as palavras nouveal e initrd também apareciam na muvuca de erros kkk). Achei isso estranho, porém decidi fazer outro pendrive, desta vez com o ubuntu. Todavia, o mesmo erro apareceu.

Antes de começar a ficar desesperado, pois nem o pendrive bootavel tava funcionando, tentei iniciar pelo windows e por incrível que parece ele iniciou. Logo de cara, apareceu uma notificação pra que eu instala-se o drive da Geforce na versão 342.01 e assim o fiz. Então, após o término da sessão resolvi tentar dar boot pelo pendrive novamente, e dessa vez deu certo… instalei o Ubuntu 20.04 LTS com as opções de drivers proprietários habilitadas, e como mostra a imagem

no Ubuntu é a versão 340 que está rodando, e agora os vídeos em tela cheia estão funcionando perfeitamente, sem nenhum ruído, sem nenhum leg.

CONCLUSÃO: O problema realmente era com os drivers de vídeo.

SOLUÇÃO: No meu caso, instalar o Ubuntu com a opção de instalação de drivers proprietários habilitada.

OBSERVAÇÃO: Sei que instalar o Ubuntu no lugar do Debian na verdade não é realmente resolver o problema, e sim contorná-lo… Porém, agora que realmente sei onde atacar o problema pretendo instalar o Debian novamente para aprender como instalar esse drive 340.

Valeu pela força!

1 Curtida