[RESOLVIDO] Ubuntu server perdeu a configuração de rede depois de reiniciar

Estava montando um laboratório usando o nextcloud e o ubuntu server, porem depois que reiniciei meu ubuntu server ele perdeu o acesso a internet. Percebi que alterando o IP do meu server ele voltava a se conectar com a internet mas ao reiniciar ele novamente perdia a
conexão.

Algumas informações importante sobre o meu lab

  • Ubuntu 18.04.4 LTS
  • Estou usando VirtualBox
  • Estou usando a versão estável do nextcloud.

Segue um print do meu arquivo 50-cloud-init.yaml

Qual método você está usando para atribuir o IP às máquinas? DHCP ou Estático?
Aparentemente o problema é com o DNS. Você consegue pingar outras máquinas locais, via IP?
E pingar o google diretamente pelo IP (ex.: 172.217.162.100)?

Estou usando IP Estático. Testei aqui ele pingou pelo IP do Google e também pingou em maquinas locais, deve ser realmente algo sobre DNS.

Estranho que quando dou o comando apt update ele da aqueles erros do print, será que isso é relacionado com o DNS também ?

Obrigado pela resposta :slight_smile:

Então realmente falta configurar o DNS, só não sei dizer como de acordo com a sua instalação.
Por isso o sistema está reclamando na resolução dos nomes, pois falta o tradutor. O APT utiliza o nome dos servidores então acontece a mesma coisa.

1 Curtida

Vou dar um jeito de configurar o DNS pra ver se resolve.

1 Curtida

Realmente era o DNS, agora tudo está funcionando normalmente.

Adicionei esses novos DNS da Cloudflare ficando assim meu arquivo 50-cloud-init.yaml

Muito obrigado pela ajuda.

1 Curtida