(Resolvido) ODrive Ubuntu Wayland

Boa tarde!
Fiz a instalação do ODrive via flatpak no meu notebook com Ubuntu 19.04, e percebi que o mesmo não funciona quando inicializo com Wayland. Pela sessão “normal” ele roda e sincroniza normalmente.
Em função do meu notebook rodar melhor via Wayland, gostaria de saber se existe uma forma de fazer o ODrive funcionar normalmente via Wayland.
Desde já eu agradeço.

1 Like

Você poderia tentar rodar por linha de comando e nos postar o erro? se for grande, use uma solução como pastebin/hastebin pra guardar o erro

Fala William!
Obrigado pelo retorno.
Quando eu tento abri-lo normalmente (sem ser pelo terminal), não apare erro algum, ele simplesmente não abre.
Como sou bem leigo em relação ao terminal e tal, se você puder me passar o comando, eu executo e informo o que deu.

Na verdade a sessão “normal do GNOME” tecnicamente é a Wayland e não Xorg, já experimentou somente adicionar sua conta do google e depois abrir direto pelo gerenciador de arquivos, sem a necessidade de uma aplicação externa?


Mas pelo menos o rpm aqui no fedora funcionou tranquilamente, já experimentou pegar o pacote nativo da sua distribuição, o rpm aqui solicitou a instalação da libappindicator creio que para suporte a systray, instalei somente para testar pois você afirma não rodar sobre Wayland, mas isto é um problema que não observei aqui, seria um problema em sua distro? ou um problema no flatpak, pois não ví esse formato oficialmente disponibilizado no git?


Posso confirmar que não é com o Wayland com certeza absoluta.


Captura%20de%20tela%20de%202019-06-11%2008-12-04
Captura%20de%20tela%20de%202019-06-11%2008-28-11

1 Like

Tenta a versão AppImage:

https://github.com/liberodark/ODrive/releases/download/0.2.2/OpenDrive.0.2.2.AppImage

Se funcionar o problema vai estar no Flatpak se não provavelmente é o Wayland

Wayland do Ubuntu no caso só para ser mais específico, pois acima frisei justamente que funciona normalmente no Wayland.

Tem a questão da versão e do XWayland, porque wayland por wayland é tudo a mesma coisa

Verdade, provavelmente o Ubuntu não traz a última versão do Wayland mas não sei se isto influenciaria muito já que se fosse esse o problema, muitas pessoas também teriam.

1 Like

Xterminator e Natanael.755, obrigado pelas dicas!
Vou dar uma olhada e volto a falar o que deu.

Fiz exatamente isso que você indicou e deu certo, baixei o deb do link e está tudo ok, funcionando perfeitamente.

Muito obrigado pela ajuda!

1 Like