(Resolvido) Instalação do Kde via Snap não funciona

Olá não estou conseguido usar o Kde via snap no Debian queria baixar e testar o Kde mas não queria instalar usando o repositório, segui esse tutorial:

Eu vi um warning após baixar pelo terminal

e aparece uma caixa de mensagem quando tento iniciar a interface gráfica do Plasma

Meu inglês é péssimo, mas entendi q ele tá dizendo pra vc reiniciar a sessão, caso você ainda não tenha feito isso. :thinking:

1 Curtida

Você tem o snapd instalado?

Então já reiniciei o computador mas ainda assim continua

1 Curtida

Sim já instalei o Snap

1 Curtida

Aparece a opção de iniciar com o KDE Plasma na tela de login?

Sim e quando escolho aparece uma mensagem de erro e depois inicia o XFCE

1 Curtida

Você fez este passo? :thinking:

1 Curtida

Sim fiz esse passo, mas aparece um erro vou tentar tirar uma foto para ver se funcionar

1 Curtida

O problema (pelo menos até agora) é que /snap/bin não está nos locais onde o sistema procura os executáveis então se o xsession do plasma chama apenas o executável ele não vai executar

2 Curtidas

Acho que entendi, mas para resolver eu teria que criar uma variável ou editar o arquivo /usr/share/xsessions/plasma-snap.desktop?

1 Curtida

Qualquer um dos dois resolveria mas o ideal seria adicionar /snap/bin à variável PATH

2 Curtidas

Então para edita seria no /etc/passwd?

1 Curtida

Não, quando eu chegar em casa explico

2 Curtidas

Heheheh adicionei ele /etc/passwd e ele só facilitou a abertura de programas snaps pelo terminal.

1 Curtida

Coloca no seu .bashrc (você acha ele na sua home):

export PATH="/snap/bin:$PATH"

Isso resolve o warning

1 Curtida

Pessoal, na verdade, o snap está na pasta /usr/bin/:

1 Curtida

Agora estar funcionando, mas ele demora para iniciar e não consigo fazer muita coisa nele mas acho que isso é comum por ele estar em desenvolvimento, mas de qualquer forma obrigado a todos que me ajudaram

Valeu era isso mesmo só foi adicionar no meu .zshrc que resolveu