Problemas na Dash to Dock

Oi gente, queria ver se com vocês está dando o mesmo problema

Eu uso o Manjaro Gnome 3.36 e recentemente a extensão Dash to Dock (que já vem instalada no sistema) pediu atualização. Depois disso, ela começou a apresentar problemas - quando o sistema carrega, ela não mostra meus aplicativos que coloquei para inicializar no boot, como o Pulse Effects. Outro problema é ao fechar um programa que não é favorito, ele fica com o ícone lá e não desaparece de imediato; às vezes demora a sumir, outras vezes apenas fica lá. Já tentei desinstalar e reinstalar, seja pelo gnome-shell no Brave quanto pelo PAMAC e o problema persiste.

Aí faço duas perguntas: está acontecendo isso com mais alguém? E como resolver? Instalando uma versão anterior? E como fazer o downgrade?
Um exemplo: o Gnome-Boxes aberto e ele nem aparece na dock… (ah, estou rodando em Wayland, não sei se em XOrg o problema persiste)


Agradeço a ajuda, galera!

Ali, acabei de fechar o Boxes e o ícone dele tá ali, nada de sumir…


Se eu desativo e reativo pelo Gnome-extensions (no site mesmo) ele some… ???

Instala manuelmente o mais atualizado primeiro

No site do gnome tem o link para o site da extensão

Baixe o mais atualizado e depois

Extraia pra uma pasta é execute os comandos

make
make install

Não utilize o sudo … não execute como root
Acho que é isso.
No site explica…

Qualquer coisa depois passo o caminho correto

Por favor, pq ao abrir a pasta no terminal e digitar make, nada acontece

Fiz o outro caminho. Extraí o zip pra pasta /home/rodrigo/.local/share/gnome-shell/extensions e desativei e reativei pela página da Gnome… ainda nada… mas ele recomenda reiniciar o Gnome com Alt+F2 e r - só que no Wayland isso não funciona. Será algum problema com Wayland?

Extrair a pasta na pasta download, por exemplo.

Entre na pasta…

E execute os comandos

No site do gnome…

Vc pode escolher a versão anterior e fazer o mesmo procedimento…

Antes para não ter problema

Delete a pasta da extensao em
home/rodrigo/.local/share/gnome-shell/extensions

Pois então, na hora em que fui copiar a pasta extraída que abri em downloads, nem tinha pasta da extensão… deixa terminar uns uploads aqui e reinicio pra ver o que acontece

O Github fala em make e make install
Pois então, abri um terminal na pasta e fiz o make, aí dá erro “não encontrou nenhum makefile”
E dei ls pra ter certeza que estou na pasta certa

Aparentemente funcionou copiar a pasta. Ele ainda demora a sumir com o ícone do programa fechado, mas acaba indo. Parece que é um problema com a extensão rodar sob Wayland, abri no Gnome XOrg e ele funciona normal. Vou reportar o bug na página da Gnome-extensions

você tem que executar o make dentro da pasta com os arquivos, vc pode se mover para elas pelo terminal, ou ir na pasta e abrir de lá o terminal, que ja vai setar o caminho da pasta

1 Curtida

Cara…

Para ter o make tem que ter o pacote no arch

base-deve

pacman -S base-devel

1 Curtida

Isso aí…

Tem que ser dentro da pasta extraída

O make já estava instalado, acabei de rodar a instalação do base-devel
Mas me parece mesmo o problema ser na integração da extensão com Wayland, pq - como disse - sob XOrg ela roda tranquila…

wayland até aonde eu tinha parado de me informar, ele estava em desenvolvimento para substituir/alternar o Xorg, e tinha alguns bugs e imcompatibilidaes, tanto em hardware, programas e plugins

1 Curtida

O XOrg tbm tem uns problemas… quando iniciava o Gnome e apertava super, as janelas abertas nas minhas 3 áreas de trabalho se embaralhavam, tinha que clicar numa delas pra resolver, isso no carregamento. Com Wayland isso parou. O esquisito é que a anormalidade da extensão só começou quando a atualizei, antes não rolava. Veremos o que os devs dizem a respeito

sim, varios tbm, o wayland conserta alguns e tras alguns novos.

Linux é um sistema que esta sempre em evolução

1 Curtida