Problemas com Tangram flatpak

Estou tentando usar o Tangram para substituir os vários Webapps que tenho no meu PC. Contudo, ao instalar o programa dá um erro na interface. Como abaixo:

Tentei instalar de três formas.

  1. Ubuntu Software(Gnome-Software) - Instalado, com problema acima.

  2. AppOutlet - Instalado, também com problema acima.

  3. Terminal - Instalado, também com problema acima, porém com uma saída de texto que pode dar uma dica.

re.sonny.Tangram permissions:
ipc network pulseaudio wayland x11 dri
ID Arch Ramo Remote Baixar

  1. [✗] org.freedesktop.Platform.openh264 x86_64 19.08 flathub < 593,4 kB
  2. [✓] re.sonny.Tangram x86_64 stable flathub 37,0 kB / 38,9 kB
    Warning: org.freedesktop.Platform.openh264 needs a later flatpak version
    Installation complete.

update:

Consegui atualizar o org.freedesktop.Platform.openh264 mas continua bugado:

É 100% chute, mas parece uma fonte quebrada+erro na integração do tema. Como poderia proceder?

Atualize o pacote flatpak, se está no Ubuntu Flatpak no Ubuntu

Se após atualizar o flatpak, e rodar um flatpak uodate o erro persistir reporte aqui Issues · flathub/re.sonny.Tangram · GitHub

Após atualizar e reiniciar o computador nada mudou. Reportei no Git. Obrigado!

Testei aqui e está ok, tu está com a org.gnome.Platform 3.34 instalada? depois que atualizou o flatpak,ele concluiu aquele download que falhou por estar com o flatpak antigo?

Notei que não está usando o tema padrão ou o Yaru no Ubuntu. Tentou efetuar o teste sem as customizações que fez? Aqui a versão é o Flatpak do PPA, contudo com o tema Yaru e funcionando normalmente, conforme relatou o @fastos2016. Talvez o problema seja por conta de alguma alteração no shell, tema ou fonte… Outro detalhe é que também possuo o tema Yaru via flatpak.

Oficialmente ele é distribuído via Flatpak, o local que você tem mais chances de obter ajuda talvez seja no git hub do programa:

Voltei o tema para Yaru e mesmo assim não funcionou, a interface seguiu não integrada. As fontes não tentei mudar por motivos de: nem lembro quais eram as padrão. (também acho que o problema pode ser as fontes que alterei)

sim, isso eu já havia conseguido fazer e postei aqui:

Essas são as fontes que vem por default.

Usando essas fontes o programa funciona normal, então faz parte disso mesmo, agora o tema mesmo com Yaru não integra o Tangram. Como você disse que também tem o Yaru via flatpak, deve ser isso que resolve, se possível, diga como faço esse procedimento.

Utilize o seguinte comando para listar os temas disponíveis:

**

flatpak search theme

**

Encontre o desejado e instale (no exemplo peguei o tema Arc)

**

flatpak install org.gtk.Gtk3theme.Arc

**

Depois aplique como faz com os demais temas… Ou se for como eu sem paciência, utilize os comandos (adaptando as suas necessidades, obviamente)…

**

gsettings set org.gnome.desktop.interface gtk-theme “Arc”

**

**

gsettings set org.gnome.desktop.wm.preferences theme “Arc”

**

E seja feliz, Sistematicamente! kkkkkkk

2 Curtidas

Jeito beeeem ais simples:

Copie o tema para $HOME/.themes

SE o flatpak tiver permissão para ler a home ou essa pasta ele vai integrar automaticamente

Cobri um santo para descobrir o o outro. Funcionou e o Tangram pegou o tema, mas ai os outros programas perderam o tema.

Todos os apps do sistema ou apenas os em Flatpak? Tenta outro tema, o Yaru por exemplo… E depois reinicia o GNOME Shell com “Alt+F2” digitando “r” na caixa de diadiálogo.

1 Curtida

Consegui resolver. São necessários alguns pontos!

Primeiro, seguir o que @henriquead7 diz e instalar o tema em flatpak(o mesmo que usa no resto do sistema, ou não).

Feito isso, precisei ir até o /.themes que é onde está instalado meu tema GTK, e renomear a pasta para o mesmo que usei na configuração anterior, no exemplo colocaria a pasta como Arc.

Por fim, precisei ir ao Tweaks e selecionar o tema “Arc” e reiniciar o shell com alt+f2 e r.

Com isso o sistema busca sempre o “Arc” ou qualquer outro tema para ambos tipos de aplicações.

2 Curtidas