Problemas com atualizações

Então, eu instalei o Microsoft Edge e agora aparece esta mensagem sempre que tento atualizar o sistema no Gerenciador de Atualizações (ou mesmo com o comando sudo apt update no Terminal). Como resolvo isso?

“Erro GPG: Index of /repos/edge/ stable InRelease: As assinaturas a seguir não puderam ser verificadas devido à chave pública não estar disponível: NO_PUBKEY EB3E94ADBE1229CFO repositório ‘Index of /repos/edge/ stable InRelease’ não está assinado.”

Grato!

Olá :wave:

É uma questão de segurança, ele tem que verificar se o repositório é seguro, é como o erro já diz:

Bem, creio que esse erro seja o mesmo que esse aqui.

Pelo post parece que isso pode ser contonado de 2 formas, faça por sua conta e risco!

Você deve rodar o comando de atualizar com um parâmetro que permite repositórios não autentificados e tals, ficaria assim:

sudo apt update --allow-unauthenticated

Outra forma é colocar o parâmetro [trusted=yes] na linha do repositório do Edge que fica dentro do arquivo /etc/apt/sources.list.d/microsoft-edge-beta.list.

Ele é assim:

deb [arch=amd64] https://packages.microsoft.com/repos/edge stable main

Ficaria assim:

deb [trusted=yes] [arch=amd64] https://packages.microsoft.com/repos/edge stable main

Aí só precisaria dar o comando de atualizar.

1 curtida

Muito obrigado!

1 curtida

Este tópico foi fechado automaticamente 3 dias depois da última resposta. Novas respostas não são mais permitidas.