Problemas ao tentar rodar o MegaSoftware (Programa de sequências e filogenia) - `GLIBC_2.34' não foi encontrado

Estou com para iniciar o programa, baixei todas os pacotes anteriores que pedia, mas mostra que o `GLIBC_2.34’ não foi encontrado. Como descrito abaixo:

PROBLEMA :

regianesilva  regiane  ~  sudo mega
[sudo] senha para regianesilva: 
/usr/lib/mega/mega: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.34' not found (required by /usr/lib/mega/mega)
VERSÃO DO LIBC6
apt policy libc6
libc6:
  Instalado: 2.31-13+deb11u7
  Candidato: 2.31-13+deb11u7

Qual a distribuição? Como procedeu pra fazer a instalação?

Em tese, o comando para instalar é:
sudo apt install ./mega_11.0.13-1_amd64.deb

**DISTRO**
PRETTY_NAME="Lux 1 (acrux)"
NAME="Lux"
VERSION_ID="1"
VERSION="1 (acrux)"
ID=lux
ID_LIKE=debian
VERSION_CODENAME=acrux
DEBIAN_CODENAME=bullseye

Sobre a instalação
de acordo com o próprio site do Mega dava essa instrução:
sudo dpkg -i mega_11.0.13-1_amd64.deb

E ao ir executando no terminal, dava aqueles erros de pacotes dependentes e seus nomes, então eu ia baixando os pacotes que faltavam.

OBS
Desinstalei o mega, e fiz de acordo com o seu comando (sudo apt install ./mega_11.0.13-1_amd64.deb), continuo com o mesmo problema com o `GLIBC_2.34’ not found (required by /usr/lib/mega/mega)

Você tentou dar um apt update?

sim fiz, continuo com o mesmo problema

sudo mega
/usr/lib/mega/mega: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.34' not found (required by /usr/lib/mega/mega)

Achei o problema.

Minha dica: instale outra distro, pra ter certeza que vai funcionar.

2 curtidas

O programa em questão exige um requisito mais novo do que tem na sua distribuição, mas como ela é uma distro estável, projetada para servidores que não têm como aguentar contratempos causados por mudanças de versão, isso não vai ocorrer.

Tem várias possíveis soluções – a mais direta, sugerida pelo @Daigo, é mudar para uma distro com pacotes mais novos, talvez até rolling-release.

Se não tiver como mudar de distro, há soluções de container como o Distrobox (que criam um “enclave” contendo uma distro com versões mais novas dos requisitos dentro de sua distro estável).

(Eu até procurei no site, mas não tem um pacote .tar.gz extraível – nesse caso, eu sugeriria uma gambiarra com Flatpak, cujos runtimes trazem glibcs mais novas que a maioria das distros estáveis).


Nas informações do sistema, está avisado que a distro é um derivado do Debian 10, ou seja, essa Glibc nunca vai sair do 2.31.

1 curtida

Tentar atualizar glib vai quebrar totalmente o sistema, se não der pra substituir essa distro arcaica vai ter q usar ou uma vm ou distrobox

@Regiane_da_Luz dá uma conferida nesse meu projeto:

https://tigeros.com.br/download-e-dual-boot/

1 curtida

Pacotes quebrados são bem problemáticos. Com isso, você pode instalar uma distro com foco em biomedicina ou ver se esse software é distribuído em snap, flatpak e/ou appimage.

Se não me falha a memória, o Pop OS ganhou destaque em faculdades estadunidenses por ter em sua loja de aplicativos, softwares especializados em manipulação genética :dna:, e outras ciências biológicas.

Creio que usar o Pop OS ou a loja de aplicativos dessa distro, seria uma boa alternativa para estudantes de ciência químicas e biológicas.

1 curtida

Acabei instalando uma versão mais antiga do Megasoftware (Mega X), e funcionou, vou levar em consideração suas dicas para o POP OS. Vlw mesmo

2 curtidas

Vlw Daigo e parabéns pelo conteúdo do seu site (as videoaulas são incríveis), acredito que vou instalar outra distro (se quiser usar o MEGA software mais atual) e sair dessa arcaica como disseram os colegas aqui.

2 curtidas

Que bom que conseguiu solucionar, muita gente acha que o Pop OS é só fama, mas eu li que essas faculdades estadunidenses trocaram, nos cursos de biomedicina, o Ubuntu pelo Pop OS. Logo, acho que é algo a se ficar de olho.

@Regiane_da_Luz O TigerOS compartilha dessa loja.

1 curtida

Marketing orgânico (risos)? O Tiger OS está na lista pra eu testar, mas como não tenho outro Pc, fica ruim eu fazer backup só pra fazer troca de distro. Quero um Compaq simples pra testar distros; aí irei instalar o tigrinho kkkkkk

PS: Pronto, ajudei a vender seu peixe, cupade @Daigo kkkkkkk

2 curtidas

Este tópico foi fechado automaticamente 3 dias depois da última resposta. Novas respostas não são mais permitidas.